summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/bincimap/bincimap-1.2.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/bincimap/bincimap-1.2.13.ebuild')
-rw-r--r--net-mail/bincimap/bincimap-1.2.13.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/net-mail/bincimap/bincimap-1.2.13.ebuild b/net-mail/bincimap/bincimap-1.2.13.ebuild
new file mode 100644
index 000000000000..816032a6f3dc
--- /dev/null
+++ b/net-mail/bincimap/bincimap-1.2.13.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="IMAP server for Maildir"
+SRC_URI="http://www.bincimap.org/dl/tarballs/1.2/${P}final.tar.bz2"
+HOMEPAGE="http://freshmeat.net/projects/bincimap/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp
+ net-mail/checkpassword"
+
+# get rid of old style virtual - bug 350792
+# all blockers really needed?
+RDEPEND="${RDEPEND}
+ !mail-mta/courier
+ !net-mail/courier-imap
+ !net-mail/cyrus-imapd
+ !net-mail/uw-imap"
+
+S="${WORKDIR}/${P}final"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.2-gcc43.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_compile() {
+ econf $(use_enable ssl) --sysconfdir=/etc/bincimap || die
+ emake localstatedir=/etc/bincimap || die
+}
+
+src_install () {
+ make DESTDIR="${D}" localstatedir=/etc/bincimap prefix=/usr install || die
+ keepdir /var/log/bincimap || die
+ if use ssl; then
+ keepdir /var/log/bincimap-ssl || die
+ fi
+
+ dodoc AUTHORS ChangeLog INSTALL \
+ NEWS README README.SSL TODO
+ dohtml doc/*.{html,css}
+ rm -rf "${D}"/usr/share/doc/"${PN}"
+
+ # backward compatibility
+ dosym /etc/bincimap/service/bincimap /etc/bincimap/service/imap
+ dosym /etc/bincimap/service/bincimaps /etc/bincimap/service/imaps
+}
+
+pkg_postinst() {
+ elog "To start bicimap at boot you have to enable the /etc/init.d/svscan rc file"
+ elog "and create the following link:"
+ elog "ln -s /etc/bincimap/service/bincimap /service/bincimap"
+ elog
+
+ if use ssl; then
+ elog "If you want to use ssl connections, create the following link:"
+ elog "ln -s /etc/bincimap/service/bincimaps /service/bincimaps"
+ elog
+ elog "And this command will setup bincimap-ssl on your system."
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+ fi
+
+ elog "NOTE: Default Maildir path is '~/.maildir'. If you want to modify it,"
+ elog "edit /etc/bincimap/bincimap.conf"
+ elog
+}
+
+pkg_config() {
+ if use ssl; then
+ local pemfile=/etc/bincimap/bincimap.pem
+ if [ ! -f $pemfile ]; then
+ echo "Creating a self-signed ssl-cert:"
+ /usr/bin/openssl req -new -x509 -nodes -out $pemfile -days 366 -keyout $pemfile
+ chmod 640 $pemfile
+
+ einfo "If You want to have a signed cert, do the following:"
+ einfo "openssl req -new -nodes -out req.pem \\"
+ einfo "-keyout $pemfile"
+ einfo "chmod 640 $pemfile"
+ einfo "Send req.pem to your CA to obtain signed_req.pem, and do:"
+ einfo "cat signed_req.pem >> $pemfile"
+ fi
+ fi
+}