summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2019-10-18 08:59:13 +0200
committerRobin H. Johnson <robbat2@gentoo.org>2019-11-01 21:43:06 -0700
commiteb69fc34f003b38035037daf7f9e322110fb2769 (patch)
treeae15fbdb66fe0c9fdbf6842ab9a8c2b409412e24 /net-mail/checkpassword/checkpassword-0.90-r4.ebuild
parentnet-mail/checkpassword: use https (diff)
downloadgentoo-eb69fc34f003b38035037daf7f9e322110fb2769.tar.gz
gentoo-eb69fc34f003b38035037daf7f9e322110fb2769.tar.bz2
gentoo-eb69fc34f003b38035037daf7f9e322110fb2769.zip
net-mail/checkpassword: bump to EAPI7
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> (cherry picked from commit d538de140833170bf5da393ae38b136a6c924c65) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13332
Diffstat (limited to 'net-mail/checkpassword/checkpassword-0.90-r4.ebuild')
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/checkpassword/checkpassword-0.90-r4.ebuild b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
new file mode 100644
index 000000000000..5029a6bdbeeb
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="https://cr.yp.to/checkpwd.html"
+SRC_URI="https://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-errno.patch
+ "${FILESDIR}"/${P}-exit.patch
+ "${FILESDIR}"/${P}-headers.diff
+)
+
+src_prepare() {
+ default
+
+ ht_fix_file Makefile print-cc.sh
+
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > ./conf-cc || die 'Patching conf-cc failed.'
+ echo "$(tc-getCC) ${LDFLAGS}" > ./conf-ld || die 'Patching conf-ld failed.'
+}
+
+src_install() {
+ dobin checkpassword
+ einstalldocs
+}