summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/checkpw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/checkpw')
-rw-r--r--net-mail/checkpw/Manifest1
-rw-r--r--net-mail/checkpw/checkpw-1.02.ebuild61
-rw-r--r--net-mail/checkpw/files/checkpw-1.02-qa.patch16
-rw-r--r--net-mail/checkpw/metadata.xml14
4 files changed, 92 insertions, 0 deletions
diff --git a/net-mail/checkpw/Manifest b/net-mail/checkpw/Manifest
new file mode 100644
index 000000000000..a5a6d7f6216e
--- /dev/null
+++ b/net-mail/checkpw/Manifest
@@ -0,0 +1 @@
+DIST checkpw-1.02.tar.gz 28631 SHA256 685a7fd4f4c783d0dcee342d109b0e492d3251e3c0cbc0ef77d33613cac6bced
diff --git a/net-mail/checkpw/checkpw-1.02.ebuild b/net-mail/checkpw/checkpw-1.02.ebuild
new file mode 100644
index 000000000000..fc74a8e3bb6d
--- /dev/null
+++ b/net-mail/checkpw/checkpw-1.02.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="an implementation of the checkpassword interface that checks a password"
+HOMEPAGE="http://checkpw.sourceforge.net/checkpw/"
+SRC_URI="mirror://sourceforge/checkpw/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="static"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-qa.patch"
+ sed -i -e 's/head -1/head -n 1/g' Makefile auto_*.do default.do || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+ echo ".maildir" > conf-maildir || die
+
+ if [ -z "${QMAIL_HOME}" ]; then
+ QMAIL_HOME="/var/qmail"
+ ewarn "QMAIL_HOME is null! Using default."
+ ewarn "Create the qmail user and set the homedir to your desired location."
+ fi
+ einfo "Using ${QMAIL_HOME} as qmail's default home directory."
+ echo "${QMAIL_HOME}" > conf-qmail || die
+
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin checkpw checkapoppw selectcheckpw loginlog
+ fperms 0700 /bin/checkpw /bin/checkapoppw /bin/selectcheckpw
+
+ dodoc CHANGES README
+ docinto samples
+ dodoc run-{apop,both,multidir,multipw,pop,rules}
+}
+
+pkg_postinst() {
+ elog
+ elog "How to set password:"
+ elog
+ elog " % echo 'YOURPASSWORD' > ~/.maildir/.password"
+ elog " % chmod 600 ~/.maildir/.password"
+ elog
+ elog "Replace YOURPASSWORD with your plain password."
+ elog
+}
diff --git a/net-mail/checkpw/files/checkpw-1.02-qa.patch b/net-mail/checkpw/files/checkpw-1.02-qa.patch
new file mode 100644
index 000000000000..d529ce87b9d4
--- /dev/null
+++ b/net-mail/checkpw/files/checkpw-1.02-qa.patch
@@ -0,0 +1,16 @@
+diff -Naur checkpw-1.02.orig/checkapoppw.c checkpw-1.02/checkapoppw.c
+--- checkpw-1.02.orig/checkapoppw.c 2002-01-07 16:25:10.000000000 +0900
++++ checkpw-1.02/checkapoppw.c 2008-12-06 01:14:38.000000000 +0900
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include "error.h"
+ #include "pathexec.h"
+diff -Naur checkpw-1.02.orig/checkpw.c checkpw-1.02/checkpw.c
+--- checkpw-1.02.orig/checkpw.c 2002-01-07 16:23:51.000000000 +0900
++++ checkpw-1.02/checkpw.c 2008-12-06 01:24:07.000000000 +0900
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include "error.h"
+ #include "pathexec.h"
diff --git a/net-mail/checkpw/metadata.xml b/net-mail/checkpw/metadata.xml
new file mode 100644
index 000000000000..fdf0b6093f91
--- /dev/null
+++ b/net-mail/checkpw/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>checkpw checks password which is stored in a file in the Maildir directory.
+The file has read and write permissions to the user only.
+checkpw checks real user's password. For virtual users, vucheckpw is available
+http://checkpw.sourceforge.net/vucheckpw/</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">checkpw</remote-id>
+ </upstream>
+</pkgmetadata>