summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch')
-rw-r--r--net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch
new file mode 100644
index 000000000000..a05941408250
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch
@@ -0,0 +1,56 @@
+--- perl/Makefile.in 2011-06-21 22:50:39.000000000 +0300
++++ perl/Makefile.in 2011-06-22 12:42:04.000000000 +0300
+@@ -74,6 +74,7 @@
+ cyrus_prefix = @cyrus_prefix@
+
+ CC = @CC@
++LDFLAGS = @LDFLAGS@
+ PLMAKE = imap/Makefile
+
+ all::
+@@ -83,6 +84,7 @@
+ if [ -f Makefile.PL -a ! -f Makefile ]; then \
+ LIB_RT="$(LIB_RT)" \
+ ZLIB="$(ZLIB)" \
++ LDDLFLAGS="-shared $(LDFLAGS)" \
+ BDB_LIB="$(BDB_LIB)" BDB_INC="$(BDB_INC)" \
+ OPENSSL_LIB="$(OPENSSL_LIB)" OPENSSL_INC="$(OPENSSL_INC)" \
+ SASL_LIB="$(SASL_LIB)" SASL_INC="$(SASL_INC)" CC="$(CC)" \
+--- perl/imap/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/imap/Makefile.PL 2011-06-22 12:42:22.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDDLFLAGS};
++
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+ $libs = "-lcyrus";
+@@ -75,6 +77,7 @@
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '../../lib/libcyrus.a ../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "$LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../../lib -I../.. -I../../com_err/et $SASL_INC $OPENSSL_INC",
+ 'EXE_FILES' => [cyradm],
+--- perl/sieve/managesieve/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/sieve/managesieve/Makefile.PL 2011-06-22 13:13:04.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDFLAGS};
++
+ $libs = "-lcyrus";
+
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+@@ -63,6 +65,7 @@
+ 'VERSION_FROM' => 'managesieve.pm', # finds $VERSION
+ 'MYEXTLIB' => '../lib/isieve.o ../lib/lex.o ../lib/mystring.o ../lib/request.o ../../../lib/libcyrus.a ../../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "-shared $LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../lib/ -I../../../lib/ $SASL_INC $OPENSSL_INC",
+ );