summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2017-08-11 18:47:31 +0300
committerEray Aslan <eras@gentoo.org>2017-08-11 18:50:43 +0300
commit286be1db4511e0bde9f8094b03ce936407b06364 (patch)
tree298a60a3bad84bd07d8a46807aeb92bd5c3ef40b /net-mail/cyrus-imapd
parentmedia-tv/mythtv: Drop old (diff)
downloadgentoo-286be1db4511e0bde9f8094b03ce936407b06364.tar.gz
gentoo-286be1db4511e0bde9f8094b03ce936407b06364.tar.bz2
gentoo-286be1db4511e0bde9f8094b03ce936407b06364.zip
net-mail/cyrus-imapd: security bump to 3.0.3
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-mail/cyrus-imapd')
-rw-r--r--net-mail/cyrus-imapd/Manifest1
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-3.0.3.ebuild215
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch127
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.rc722
-rw-r--r--net-mail/cyrus-imapd/metadata.xml20
5 files changed, 375 insertions, 10 deletions
diff --git a/net-mail/cyrus-imapd/Manifest b/net-mail/cyrus-imapd/Manifest
index d9f96c0ec774..3917ba2fa701 100644
--- a/net-mail/cyrus-imapd/Manifest
+++ b/net-mail/cyrus-imapd/Manifest
@@ -2,3 +2,4 @@ DIST cyrus-imapd-2.5.10.tar.gz 3103914 SHA256 b38f4fd72825a298ac47426dcd2a50c843
DIST cyrus-imapd-2.5.11.tar.gz 3109188 SHA256 36a79117b320c78d62bc6842c3024d970d3bec7aa12908f862d92cf1d63397d5 SHA512 bbb0e11f31d91d85037306321165e3608f8d5e2699b971fc4fbdd1630ec0a1485c8f6f17900142dec584ab41b0ec0c65c11cfaf8c5bbf1054b194a8f5f361538 WHIRLPOOL e6aaedb642b634d9fc0c56f7ddd06e15130091bd21f4e089ae46168fb2976c7e1fa281f8c6fc0f3e171e70bbfeb5cec8f6cc613f62d5b769fb8b6af4dede6e67
DIST cyrus-imapd-3.0.1.tar.gz 10515460 SHA256 24a9886aa6bbe001484a54b29309ff99415c0f355b98325ebb29ad61fff5e257 SHA512 0a2bf13b4793e642f3df53231fd66774e0c5ad753b436a7fb0645db6ee70121d0da245038527cc58cb078255fec3e7b32a6230c196cceea040f74813ef78e337 WHIRLPOOL 830284e3d96b2d34d88350f8e65de2cac28c34c9d302dc7fe4247022c5d96251d72989714062408cfcf08828650a7b67aecfb1672165fed344b2e98c2dc06265
DIST cyrus-imapd-3.0.2.tar.gz 10706654 SHA256 5612f3cfa0504eb50bc3e49a77bf04a31c1aff3096fa1bbddb26cd7dbb69d94d SHA512 95f145733a4b2589b2f7eb6281ce0d1df5788521dea0c81fda10c7c7ae4ac7cf1a9037dba45deee6101a73bbde4552906d7c6bfa9369aa3c802061a7f5cec85d WHIRLPOOL cf56390ea0d8ecd9fcfb9a2459a552ba7815474b52b089c54b1428b42691826f91b163cfe723c795b28289530911ed614e2252e038919c4d710d9a95658f8997
+DIST cyrus-imapd-3.0.3.tar.gz 10819454 SHA256 6a76d8d00b26a2c9d03c65197724a28ab6d044527d7e230e6331f8de79af889a SHA512 0b5c3167d80d91371e3f07e64b8bc8c085481946e6536dd407976f6f8ae66405fd1f6d2ff5ad51e5e0eb827a64d90d93daf72d5a1afa409782a287bec29665df WHIRLPOOL 6d543b09d3f18d10c481133fafb78f82a6e2d0dd3fb7c4cdb1d181d906acef7db4c6da5dcc86254a836f69fc7cbd54034f889b0808da060a083f35dd8ee40434
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-3.0.3.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-3.0.3.ebuild
new file mode 100644
index 000000000000..f4638e0cc79e
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-3.0.3.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools pam ssl-cert user
+
+MY_P=${P/_/}
+
+DESCRIPTION="The Cyrus IMAP Server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/${MY_P}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs backup calalarm caps clamav http jmap kerberos ldap lmdb \
+ mysql nntp pam perl postgres replication +server sieve snmp \
+ sphinx sqlite ssl static-libs tcpd test xapian"
+
+# virtual/mysql-5.5 added for the --variable= option below
+CDEPEND="sys-libs/zlib
+ dev-libs/libpcre
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-libs/jansson
+ dev-libs/icu:=
+ afs? ( net-fs/openafs )
+ caps? ( sys-libs/libcap )
+ clamav? ( app-antivirus/clamav )
+ http? ( dev-libs/libxml2 dev-libs/libical )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ lmdb? ( dev-db/lmdb )
+ mysql? ( >=virtual/mysql-5.5 )
+ nntp? ( !net-nntp/leafnode )
+ pam? (
+ virtual/pam
+ >=net-mail/mailbase-1
+ )
+ perl? ( dev-lang/perl:= )
+ postgres? ( dev-db/postgresql:* )
+ snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
+ ssl? ( >=dev-libs/openssl-1.0.1e:0[-bindist] )
+ sqlite? ( dev-db/sqlite:3 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 snmp? ( net-analyzer/net-snmp[tcpd=] ) )
+ xapian? ( >=dev-libs/xapian-1.4.0 )"
+
+DEPEND="${CDEPEND}
+ test? ( dev-util/cunit )"
+
+# all blockers really needed?
+RDEPEND="${CDEPEND}
+ !mail-mta/courier
+ !net-mail/bincimap
+ !net-mail/courier-imap
+ !net-mail/uw-imap
+ !net-mail/cyrus-imap-admin"
+
+REQUIRED_USE="afs? ( kerberos )
+ backup? ( sqlite )
+ calalarm? ( http )
+ http? ( sqlite )
+ jmap? ( http xapian )
+ sphinx? ( mysql )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewuser cyrus -1 -1 /usr/cyrus mail
+}
+
+src_prepare() {
+ # bug 604470
+ eapply -p1 "${FILESDIR}/${PN}-sieve-libs-v4.patch"
+ eapply -p1 "${FILESDIR}/${PN}-fix-tests.patch"
+ # Fix master(8)->cyrusmaster(8) manpage.
+ for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+ sed -i -e 's:master\.8:cyrusmaster.8:g' \
+ -e 's:master(8):cyrusmaster(8):g' \
+ "${i}" || die "sed failed" || die "sed failed"
+ done
+ mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+ sed -i -e "s:MASTER:CYRUSMASTER:g" \
+ -e "s:Master:Cyrusmaster:g" \
+ -e "s:master:cyrusmaster:g" \
+ man/cyrusmaster.8 || die "sed failed"
+
+ # lock.h to afs/lock.h
+ sed -i -e '/lock.h/s:lock.h:afs/lock.h:' \
+ ptclient/afskrb.c || die
+
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use afs ; then
+ myconf+=" --with-afs-libdir=/usr/$(get_libdir)"
+ myconf+=" --with-afs-incdir=/usr/include/afs"
+ fi
+ econf \
+ --enable-unit-tests \
+ --enable-murder \
+ --enable-idled \
+ --enable-event-notification \
+ --enable-autocreate \
+ --enable-pcre \
+ --with-cyrus-user=cyrus \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-sasl \
+ --without-krb \
+ --without-krbdes \
+ --enable-squat \
+ --with-zlib \
+ $(use_enable afs) \
+ $(use_enable afs krb5afspts) \
+ $(use_enable backup) \
+ $(use_enable calalarm calalarmd) \
+ $(use_with caps libcap) \
+ $(use_with clamav) \
+ $(use_enable jmap) \
+ $(use_enable nntp) \
+ $(use_enable http) \
+ $(use_enable replication) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with lmdb) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_with ssl openssl) \
+ $(use_enable server) \
+ $(use_enable sieve) \
+ $(use_with snmp) \
+ $(use_enable sphinx) \
+ $(use_enable static-libs static) \
+ $(use_with tcpd libwrap) \
+ $(use_enable xapian) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install
+
+ dodoc README*
+ dodoc -r doc
+ cp -r contrib tools "${D}/usr/share/doc/${PF}"
+ rm -f doc/text/Makefile*
+
+ mv "${D}"usr/libexec/{master,cyrusmaster} || die
+
+ insinto /etc
+ newins "${D}usr/share/doc/${P}/doc/examples/cyrus_conf/normal.conf" cyrus.conf
+ newins "${D}usr/share/doc/${P}/doc/examples/imapd_conf/normal.conf" imapd.conf
+
+ sed -i -e '/^configdirectory/s|/var/.*|/var/imap|' \
+ -e '/^partition-default/s|/var/.*|/var/spool/imap|' \
+ -e '/^sievedir/s|/var/.*|/var//imap/sieve|' \
+ "${D}"etc/imapd.conf
+
+ # turn off sieve if not installed
+ if ! use sieve; then
+ sed -i -e "/sieve/s/^/#/" "${D}/etc/cyrus.conf" || die
+ fi
+ # same thing for http(s) as well
+ if ! use http; then
+ sed -i -e "/http/s/^/#/" "${D}/etc/cyrus.conf" || die
+ fi
+
+ newinitd "${FILESDIR}/cyrus.rc7" cyrus
+ newconfd "${FILESDIR}/cyrus.confd" cyrus
+ newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+ for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+ keepdir "/var/${subdir}"
+ fowners cyrus:mail "/var/${subdir}"
+ fperms 0750 "/var/${subdir}"
+ done
+ for subdir in imap/{user,quota,sieve} spool/imap ; do
+ for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+ keepdir "/var/${subdir}/${i}"
+ fowners cyrus:mail "/var/${subdir}/${i}"
+ fperms 0750 "/var/${subdir}/${i}"
+ done
+ done
+}
+
+pkg_preinst() {
+ if ! has_version ${CATEGORY}/${PN} ; then
+ elog "For correct logging add the following to /etc/syslog.conf:"
+ elog " local6.* /var/log/imapd.log"
+ elog " auth.debug /var/log/auth.log"
+ echo
+
+ elog "You have to add user cyrus to the sasldb2. Do this with:"
+ elog " saslpasswd2 cyrus"
+ fi
+}
+
+pkg_postinst() {
+ # do not install server.{key,pem) if they exist
+ if use ssl ; then
+ if [ ! -f "${ROOT}"etc/ssl/cyrus/server.key ]; then
+ install_cert /etc/ssl/cyrus/server
+ chown cyrus:mail "${ROOT}"etc/ssl/cyrus/server.{key,pem}
+ fi
+ fi
+
+ echo
+ ewarn "Please see http://www.cyrusimap.org/imap/download/upgrade.html"
+ ewarn "for upgrade instructions."
+ echo
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch
new file mode 100644
index 000000000000..4a7bac2e3c1f
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch
@@ -0,0 +1,127 @@
+--- a/configure.ac 2017-04-20 04:21:48.000000000 +0300
++++ b/configure.ac 2017-05-16 10:30:37.337965921 +0300
+@@ -666,7 +666,9 @@
+ fi
+
+ if test "$cyrus_cv_pcre_utf8" = "yes"; then
+- LIBS="$LIBS -lpcre -lpcreposix";
++ PCRE_LIBS="-lpcre -lpcreposix"
++ AC_SUBST(PCRE_LIBS)
++ LIBS="$LIBS $PCRE_LIBS"
+ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+ AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
+ else
+@@ -1938,6 +1940,7 @@
+ fi
+
+ LIBS="${LIBS} ${SQLITE_LIBADD}"
++ AC_SUBST(SQLITE_LIBADD)
+ CPPFLAGS="${SQLITE_INCADD} ${CPPFLAGS}"
+ AC_DEFINE(HAVE_SQLITE,[],[Build in SQLite support?])
+ else
+--- a/perl/imap/Makefile.PL.in 2017-04-07 08:31:10.000000000 +0300
++++ b/perl/imap/Makefile.PL.in 2017-05-16 10:26:08.193965921 +0300
+@@ -90,7 +90,7 @@
+ 'clean' => {'FILES' => 'libcyrperl.a cyradm'},
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
+ 'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in 2017-04-07 08:31:10.000000000 +0300
++++ b/perl/sieve/managesieve/Makefile.PL.in 2017-05-16 10:26:31.048965921 +0300
+@@ -69,7 +69,7 @@
+ 'ABSTRACT' => 'Cyrus Sieve management interface',
+ 'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'CCFLAGS' => '@GCOV_CFLAGS@',
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
+--- a/configure.ac 2017-05-16 15:18:23.648756211 +0300
++++ b/configure.ac 2017-05-16 15:26:49.241756211 +0300
+@@ -633,8 +633,6 @@
+
+ AC_ARG_ENABLE(sieve,
+ [AS_HELP_STRING([--disable-sieve], [disable Sieve support])],,[enable_sieve="yes";])
+-AC_ARG_ENABLE(pcre,
+- [AS_HELP_STRING([--disable-pcre], [disable PCRE library])])
+
+ if test "$enable_sieve" != "no"; then
+ AC_DEFINE(USE_SIEVE,[],[Build in Sieve support?])
+@@ -650,42 +648,46 @@
+ if test -z "$ac_cv_prog_LEX"; then
+ AC_MSG_ERROR([Sieve requires flex/lex, but none is installed])
+ fi
++fi
++AM_CONDITIONAL([SIEVE], [test "${enable_sieve}" != "no"])
++
+
+- if test "$enable_pcre" != "no"; then
+- AC_CHECK_HEADER(pcreposix.h)
+- if test "$ac_cv_header_pcreposix_h" = "yes"; then
+- AC_MSG_CHECKING(for utf8 enabled pcre)
+- AC_CACHE_VAL(cyrus_cv_pcre_utf8, AC_TRY_CPP([#include <pcreposix.h>
++AC_ARG_ENABLE(pcre,
++ [AS_HELP_STRING([--disable-pcre], [disable PCRE library])])
++
++if test "$enable_pcre" != "no"; then
++ AC_CHECK_HEADER(pcreposix.h)
++ if test "$ac_cv_header_pcreposix_h" = "yes"; then
++ AC_MSG_CHECKING(for utf8 enabled pcre)
++ AC_CACHE_VAL(cyrus_cv_pcre_utf8, AC_TRY_CPP([#include <pcreposix.h>
+ #ifndef REG_UTF8
+ #include </nonexistent>
+ #endif],cyrus_cv_pcre_utf8=yes,cyrus_cv_pcre_utf8=no))
+- AC_MSG_RESULT($cyrus_cv_pcre_utf8)
+- else
+- cyrus_cv_pcre_utf8="no"
+- fi
++ AC_MSG_RESULT($cyrus_cv_pcre_utf8)
++ else
++ cyrus_cv_pcre_utf8="no"
+ fi
++fi
+
+- if test "$cyrus_cv_pcre_utf8" = "yes"; then
+- PCRE_LIBS="-lpcre -lpcreposix"
+- AC_SUBST(PCRE_LIBS)
+- LIBS="$LIBS $PCRE_LIBS"
+- AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+- AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
++if test "$cyrus_cv_pcre_utf8" = "yes"; then
++ PCRE_LIBS="-lpcre -lpcreposix"
++ AC_SUBST(PCRE_LIBS)
++ LIBS="$LIBS $PCRE_LIBS"
++ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
++ AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
++else
++ AC_CHECK_HEADERS(rxposix.h)
++ if test "$ac_cv_header_rxposix_h" = "yes"; then
++ LIBS="$LIBS -lrx"
++ AC_DEFINE(ENABLE_REGEX, [],
++ [Do we have a regex library?])
+ else
+- AC_CHECK_HEADERS(rxposix.h)
+- if test "$ac_cv_header_rxposix_h" = "yes"; then
+- LIBS="$LIBS -lrx"
+- AC_DEFINE(ENABLE_REGEX, [],
+- [Do we have a regex library?])
+- else
+- AC_SEARCH_LIBS(regcomp, regex,
+- AC_DEFINE(ENABLE_REGEX, [],
+- [Do we have a regex library?]), [])
+- fi
++ AC_SEARCH_LIBS(regcomp, regex,
++ AC_DEFINE(ENABLE_REGEX, [],
++ [Do we have a regex library?]), [])
+ fi
+ fi
+
+-AM_CONDITIONAL([SIEVE], [test "${enable_sieve}" != "no"])
+
+ dnl look for an option to disable sign-comparison warnings (needed for
+ dnl flex-generated sieve sources when building with -Werror)
diff --git a/net-mail/cyrus-imapd/files/cyrus.rc7 b/net-mail/cyrus-imapd/files/cyrus.rc7
new file mode 100644
index 000000000000..348b01c04921
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.rc7
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+ use dns logger
+ after drac saslauthd
+}
+
+start() {
+ ebegin "Starting cyrus imapd"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/libexec/cyrusmaster -- ${CYRUS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cyrus imapd"
+ start-stop-daemon --stop --quiet --pidfile /run/cyrus-master.pid
+ eend $?
+}
diff --git a/net-mail/cyrus-imapd/metadata.xml b/net-mail/cyrus-imapd/metadata.xml
index f21a8fca8af6..23dc96dc53ab 100644
--- a/net-mail/cyrus-imapd/metadata.xml
+++ b/net-mail/cyrus-imapd/metadata.xml
@@ -6,15 +6,15 @@
<name>Net-Mail</name>
</maintainer>
<use>
- <flag name="replication">Enable replication support</flag>
- <flag name="sieve">Enable sieve support</flag>
- <flag name="http">Enable http support</flag>
- <flag name="server">Enable building server binaries</flag>
- <flag name="backup">Enable backup service support</flag>
- <flag name="calalarm">Enable CalDAV alarm support</flag>
- <flag name="jmap">Enable JMAP support</flag>
- <flag name="sphinx">Enable Sphinx search engine support</flag>
- <flag name="xapian">Enable Xapian search engine support</flag>
- <flag name="lmdb">Enable support for using <pkg>dev-db/lmdb</pkg></flag>
+ <flag name="replication">Enable replication support</flag>
+ <flag name="sieve">Enable sieve support</flag>
+ <flag name="http">Enable http support</flag>
+ <flag name="server">Enable building server binaries</flag>
+ <flag name="backup">Enable backup service support</flag>
+ <flag name="calalarm">Enable CalDAV alarm support</flag>
+ <flag name="jmap">Enable JMAP support</flag>
+ <flag name="sphinx">Enable Sphinx search engine support</flag>
+ <flag name="xapian">Enable Xapian search engine support</flag>
+ <flag name="lmdb">Enable support for using <pkg>dev-db/lmdb</pkg></flag>
</use>
</pkgmetadata>