summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-08 13:44:41 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-08 13:44:41 -0500
commitf97fa70d2cebe914a21f94eed58c3150125f56fc (patch)
tree1b54ef4a6dbcd02551378954c5e9c53e951b4312 /net-mail/getmail
parentmedia-gfx/feh: version bump to 2.21 (diff)
downloadgentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.tar.gz
gentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.tar.bz2
gentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.zip
net-mail/getmail: version bump to 5.4
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/Manifest1
-rw-r--r--net-mail/getmail/getmail-5.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index e7830fdcf5f2..535084d30634 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1 +1,2 @@
DIST getmail-4.54.0.tar.gz 192000 SHA256 d45657945353c68785b106dd9c5fae6bc2cec8f99fbb202d9dddd4967f483a65 SHA512 006503c6b5f523ad409d99e7e520b4801f1610d47aba70a1a8044380449cbd6a39a6d74ed2b940d317382111adedd3b45d9fa4dc614ce00821937da5186e08d5 WHIRLPOOL 977912bac3f492f2168ed1f892b4973ae70a0daaa21ca3f0622a4156646d9ec1dc9272b18de9ff3b4e4e9e59bbdba779f758f3066775aeea9bcde2bfd3f8a80e
+DIST getmail-5.4.tar.gz 194884 SHA256 ba896f7b3fbae4e9e79f7135e6c2b10b281170d2877b91fb2b265c927ed29ac7 SHA512 6557cc46df1d31116f9d28cda1232737c01a568e6ada44edb14cdec30a42160966e1e69f42c46855ce139c3b70d77747324adda8abff3dd772a54a79015b0050 WHIRLPOOL 5dffecaf8dfe96e052368d0df0632f9ef0c98064bcdb40bae2a5e35e37f144cf1cbdda847b627a6b62bd4fb40dcf4465fb4279fcf3d26da81b6641581b4e0ad0
diff --git a/net-mail/getmail/getmail-5.4.ebuild b/net-mail/getmail/getmail-5.4.ebuild
new file mode 100644
index 000000000000..a213f82d8658
--- /dev/null
+++ b/net-mail/getmail/getmail-5.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}