summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/imapsync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/imapsync')
-rw-r--r--net-mail/imapsync/Manifest2
-rw-r--r--net-mail/imapsync/imapsync-1.592-r1.ebuild34
-rw-r--r--net-mail/imapsync/imapsync-1.607-r1.ebuild35
-rw-r--r--net-mail/imapsync/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/net-mail/imapsync/Manifest b/net-mail/imapsync/Manifest
new file mode 100644
index 000000000000..83d3efccf756
--- /dev/null
+++ b/net-mail/imapsync/Manifest
@@ -0,0 +1,2 @@
+DIST imapsync-1.592.tgz 906578 SHA256 dd359a5b871dd278fbb39ba0c087576e97af1d746c49a104bc00a533b463ab64 SHA512 3d41b28396d9b8bf83200b324b2e312c76ef88e42f4ff8993c8d697b18f321400d7a157b1fee2d3ad4eae11400dc2186a18528bde50e370d856eac1b09c28f68 WHIRLPOOL ab0783acc911dacf394e19c4b3bbcd0bcc6de55088e11846271a590ffd4d79935d2bcffbe601bd1e599dffd1df5d9ade0fc6578b9252d3363f81f3982e96ff34
+DIST imapsync-1.607.tgz 973467 SHA256 784331cfa6cc391751dcdc5290eba5d50bf3ddbe9b213f072b413941a3fe4f2a SHA512 2630d32683f74ec260d322d2d9f13fb30938c077275cd43cece392b43bbdf8989f8ff6df648d520b785a568bf5d6f45d43761bf4fb94649e210611224ad43841 WHIRLPOOL b2c089879a475aba14fec66912d024b1365e0b6c7bf56c3e4c291c3f5c96008ff302241d3a8675c82dc1fced36ca88a05b06054058c107edcfd7f73bac7e9544
diff --git a/net-mail/imapsync/imapsync-1.592-r1.ebuild b/net-mail/imapsync/imapsync-1.592-r1.ebuild
new file mode 100644
index 000000000000..57c87043d523
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.592-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another"
+HOMEPAGE="http://ks.lamiral.info/imapsync/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tgz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Digest-HMAC
+ dev-perl/File-Copy-Recursive
+ dev-perl/IO-Socket-SSL
+ dev-perl/IO-Tee
+ dev-perl/Mail-IMAPClient
+ dev-perl/TermReadKey
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s/^install: testp/install:/" \
+ -e "/^DO_IT/,/^$/d" \
+ -i "${S}"/Makefile || die
+}
+
+src_compile() { :; }
diff --git a/net-mail/imapsync/imapsync-1.607-r1.ebuild b/net-mail/imapsync/imapsync-1.607-r1.ebuild
new file mode 100644
index 000000000000..9cca9492513c
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.607-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another"
+HOMEPAGE="http://ks.lamiral.info/imapsync/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tgz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Digest-HMAC
+ dev-perl/File-Copy-Recursive
+ dev-perl/IO-Socket-SSL
+ dev-perl/IO-Tee
+ dev-perl/Mail-IMAPClient
+ dev-perl/TermReadKey
+ dev-perl/Unicode-String
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s/^install: testp/install:/" \
+ -e "/^DO_IT/,/^$/d" \
+ -i "${S}"/Makefile || die
+}
+
+src_compile() { :; }
diff --git a/net-mail/imapsync/metadata.xml b/net-mail/imapsync/metadata.xml
new file mode 100644
index 000000000000..940fde8f70ce
--- /dev/null
+++ b/net-mail/imapsync/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+</pkgmetadata>