summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-06 18:38:03 +0000
committerSam James <sam@gentoo.org>2021-12-06 18:38:03 +0000
commit9f1c117aa91d3f249a5e2867a5edb500e2b6f705 (patch)
treecf5d5daa9136909db974adc89adcf50a67d260ef /net-mail/isync
parentdev-python/pillow: Stabilize 8.4.0 arm, #825662 (diff)
downloadgentoo-9f1c117aa91d3f249a5e2867a5edb500e2b6f705.tar.gz
gentoo-9f1c117aa91d3f249a5e2867a5edb500e2b6f705.tar.bz2
gentoo-9f1c117aa91d3f249a5e2867a5edb500e2b6f705.zip
net-mail/isync: add 1.4.4
Bug: https://bugs.gentoo.org/826902 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/isync')
-rw-r--r--net-mail/isync/Manifest1
-rw-r--r--net-mail/isync/isync-1.4.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-mail/isync/Manifest b/net-mail/isync/Manifest
index 2b008333bf17..a45d7d4f0af6 100644
--- a/net-mail/isync/Manifest
+++ b/net-mail/isync/Manifest
@@ -1,2 +1,3 @@
DIST isync-1.3.6.tar.gz 317174 BLAKE2B 3a230cd4bfac061ceb3325732c336ccd808a662989d2fc81459b4b27fce927a62e335200ef233f63d28b80f6ba79b1e5e102fda8ec68c9cd8e368f8ddd7188a0 SHA512 16e859361b27f00e1ef9eda0a2d06edf271b2643107a1f90c90713c34ffe9b542cdedb31218db72db633e12cf39a6aa2ac509333647c79a1825faac8ad4ead38
DIST isync-1.4.2.tar.gz 336940 BLAKE2B d37dea100c5a994ce65812612a9571fe5649168560799ae17ec866774bb46b4ff989a87f4172a24006f0704e4387260716f4811f6e765df17719e598064119bd SHA512 4f95e06c5bf159b7bd8fedb75e72a8f08ee0907362dde068347706610ed251eb511b00281711ddd40a0ece31dbf07f07487cd4e5504f0898638870c51a506853
+DIST isync-1.4.4.tar.gz 340544 BLAKE2B fdf38b1066af10315b780897f1fe09c8f7d0b4d2202383a5f0ef24b98f11dff625bf178bbb0dc846460f661b18f923d2823bf79643d4d376b606b03980f22e18 SHA512 b769f474f2296764cabaae7e2b23e47c22714fca5919e9f1c916ed70b18c71c0bc9301fff0f64434f4f0ae28c9d16216e72556b48014ec94d1b7646de7183011
diff --git a/net-mail/isync/isync-1.4.4.ebuild b/net-mail/isync/isync-1.4.4.ebuild
new file mode 100644
index 000000000000..07b35974fe65
--- /dev/null
+++ b/net-mail/isync/isync-1.4.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="berkdb sasl ssl zlib"
+
+RDEPEND="
+ berkdb? ( >=sys-libs/db-4.2:= )
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( >=dev-libs/openssl-0.9.6:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ use berkdb || export ac_cv_berkdb4=no
+ econf \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}