summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:18:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:19:06 -0500
commitdbe00997921d45989109e352474d5a96f5e0b716 (patch)
tree5f4f523f0fb2f09df9f7755bdcab3f7414ad5801 /net-mail/mailman/mailman-3.2.1.ebuild
parentdev-python/authheaders: add for mailman2 (diff)
downloadgentoo-dbe00997921d45989109e352474d5a96f5e0b716.tar.gz
gentoo-dbe00997921d45989109e352474d5a96f5e0b716.tar.bz2
gentoo-dbe00997921d45989109e352474d5a96f5e0b716.zip
net-mail/mailman: update to 3.2.1
Fixes: https://bugs.gentoo.org/548078 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-mail/mailman/mailman-3.2.1.ebuild')
-rw-r--r--net-mail/mailman/mailman-3.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/mailman/mailman-3.2.1.ebuild b/net-mail/mailman/mailman-3.2.1.ebuild
new file mode 100644
index 000000000000..108bd97f853c
--- /dev/null
+++ b/net-mail/mailman/mailman-3.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mailman -- the GNU mailing list manager"
+HOMEPAGE="http://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="" # nothing til this is finished
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/aiosmtpd-1.1[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/authheaders-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/falcon-1.0.0[${PYTHON_USEDEP}]
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ dev-python/lazr-config[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"