summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:30:12 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:30:50 -0600
commit79b4900762b744e951b7f7ab5cc9db6cdc2818e8 (patch)
treebaf22604d252f00d996239ce9d0c114d16883f32 /net-mail/mailman
parentdev-python/aiosmtpd: 1.0 for mailman-3.1.1 (diff)
downloadgentoo-79b4900762b744e951b7f7ab5cc9db6cdc2818e8.tar.gz
gentoo-79b4900762b744e951b7f7ab5cc9db6cdc2818e8.tar.bz2
gentoo-79b4900762b744e951b7f7ab5cc9db6cdc2818e8.zip
net-mail/mailman: adding 3.1.1 for dev
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-mail/mailman')
-rw-r--r--net-mail/mailman/Manifest1
-rw-r--r--net-mail/mailman/mailman-3.1.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-mail/mailman/Manifest b/net-mail/mailman/Manifest
index 359dd48de485..c15ff367a430 100644
--- a/net-mail/mailman/Manifest
+++ b/net-mail/mailman/Manifest
@@ -1,2 +1,3 @@
DIST mailman-2.1.23.tgz 9290881 BLAKE2B 79b1740c6980327f904622a28e93a6a7f7cd47a508c0293dfdad9050ab1735143770001ab8bb0c5e6a082f97d2b288f30164e66f25bf0e9bfb936910bbeca4ed SHA512 398dd5c301005512900aff38c068ee641eea9f2970dfde17c37a8641759bd6fff8e6d37ad63c0c86b4b1594459b3c92023844ca4ec23d1681ac02542bd97f8db
DIST mailman-2.1.24.tgz 9251009 BLAKE2B a1530e424554b762ef2996cd2423cae15bff18760295d42b50d258451b9ba421509555b70b92bfaca01919d454b94d27c99560e18140c970e3cb119e2f7052b2 SHA512 f62f224abe5eb4804828a4d83389432b34595b8d4533310cda4da58ab10c2e62e0b2419929dcc53c32e2754d8f62fa8ef68877db4c65f6112f08f0e452fd6a38
+DIST mailman-3.1.1.tar.gz 749014 BLAKE2B 00cf756de1a6ce5a05f30b033ad7d1ebc5664bb1c6fadb5d602c4e34e373ee7a0df0801e6b68b0816ee819f77caef33bbc4b8490df1c8f01fd2fb35664fd3757 SHA512 b09962ec99ca1ce1eafd40409a00f976dc47d82adb707313f4516400db6439af8597a1c4e30262fb228c102508ede688912480dbb1dcca9721bb0333693f1d85
diff --git a/net-mail/mailman/mailman-3.1.1.ebuild b/net-mail/mailman/mailman-3.1.1.ebuild
new file mode 100644
index 000000000000..e8c5877caad4
--- /dev/null
+++ b/net-mail/mailman/mailman-3.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mailman -- the GNU mailing list manager"
+HOMEPAGE="http://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="" # nothing til this is finished
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ~dev-python/aiosmtpd-1.0[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/falcon-1.0.0[${PYTHON_USEDEP}]
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
+ dev-python/lazr-config[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"