summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/mairix/mairix-0.23.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/mairix/mairix-0.23.ebuild')
-rw-r--r--net-mail/mairix/mairix-0.23.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/mairix/mairix-0.23.ebuild b/net-mail/mairix/mairix-0.23.ebuild
new file mode 100644
index 000000000000..9d8891a0f700
--- /dev/null
+++ b/net-mail/mairix/mairix-0.23.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Indexes and searches Maildir/MH folders"
+HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ gnus? ( mirror://gentoo/${P}-gnus-marks-propagation.patch.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-macos"
+
+IUSE="zlib bzip2 gnus"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+# Fail on various locales
+RESTRICT="test"
+
+src_prepare() {
+ # econf would fail with unknown options.
+ # Now it only prints "Unrecognized option".
+ sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed"
+
+ # Add support for gnus marks propagation (bug #274578)
+ use gnus && epatch "${WORKDIR}"/${P}-gnus-marks-propagation.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable zlib gzip-mbox) \
+ $(use_enable bzip2 bzip-mbox)
+}
+
+src_install() {
+ dobin mairix
+ doman mairix.1 mairixrc.5
+ dodoc NEWS README dotmairixrc.eg
+}