summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/metamail/metamail-2.7.53.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/metamail/metamail-2.7.53.3-r1.ebuild')
-rw-r--r--net-mail/metamail/metamail-2.7.53.3-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-mail/metamail/metamail-2.7.53.3-r1.ebuild b/net-mail/metamail/metamail-2.7.53.3-r1.ebuild
new file mode 100644
index 000000000000..04379b6edb6f
--- /dev/null
+++ b/net-mail/metamail/metamail-2.7.53.3-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+WANT_AUTOCONF="2.5"
+
+inherit autotools eutils toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DEB_PV=${MY_PV}-$(get_version_component_range 3)
+
+DESCRIPTION="Metamail (with Debian patches) - Generic MIME package"
+HOMEPAGE="http://ftp.funet.fi/pub/unix/mail/metamail/"
+SRC_URI="http://ftp.funet.fi/pub/unix/mail/metamail/mm${MY_PV}.tar.Z
+ mirror://debian/pool/main/m/metamail/metamail_${DEB_PV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="sys-libs/ncurses
+ app-arch/sharutils
+ net-mail/mailbase"
+RDEPEND="app-misc/mime-types
+ sys-apps/debianutils
+ !app-misc/run-mailcap"
+
+S=${WORKDIR}/mm${MY_PV}/src
+
+src_prepare() {
+ epatch "${WORKDIR}"/metamail_${DEB_PV}.diff
+ epatch "${FILESDIR}"/${PN}-2.7.45.3-CVE-2006-0709.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+
+ # respect CFLAGS
+ sed -i -e 's/CFLAGS/LIBS/' \
+ "${S}"/src/{metamail,richmail}/Makefile.am || die
+
+ # add missing include - QA
+ sed -i -e '/config.h/a #include <string.h>' \
+ "${S}"/src/metamail/shared.c || die
+
+ # Fix building with ncurses[tinfo]
+ sed -i -e "s/-lncurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" \
+ src/richmail/Makefile.am \
+ src/metamail/Makefile.am || die
+ eautoreconf
+ chmod +x "${S}"/configure
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc CREDITS README
+ rm man/mmencode.1
+ doman man/* debian/mimencode.1 debian/mimeit.1
+
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+}