summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 14:43:01 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 14:47:00 -0500
commitcb1e3a55ca15156b21b726b197caecd9f83c274a (patch)
tree882f78e7f0dfa4bf117b5d9f19ca78cd966c5c3e /net-mail/mhonarc-gentoo
parentgames-simulation/corsix-th: add maintainer-needed (diff)
downloadgentoo-cb1e3a55ca15156b21b726b197caecd9f83c274a.tar.gz
gentoo-cb1e3a55ca15156b21b726b197caecd9f83c274a.tar.bz2
gentoo-cb1e3a55ca15156b21b726b197caecd9f83c274a.zip
net-mail/mhonarc-gentoo: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-mail/mhonarc-gentoo')
-rw-r--r--net-mail/mhonarc-gentoo/metadata.xml1
-rw-r--r--net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18-r2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/mhonarc-gentoo/metadata.xml b/net-mail/mhonarc-gentoo/metadata.xml
index 097975e3adc2..6f49eba8f496 100644
--- a/net-mail/mhonarc-gentoo/metadata.xml
+++ b/net-mail/mhonarc-gentoo/metadata.xml
@@ -1,4 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<!-- maintainer-needed -->
</pkgmetadata>
diff --git a/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18-r2.ebuild b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18-r2.ebuild
new file mode 100644
index 000000000000..8af0c4f0fba3
--- /dev/null
+++ b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter, Gentoo fork"
+HOMEPAGE="http://www.mhonarc.org/"
+LICENSE="GPL-2"
+SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!net-mail/mhonarc"
+
+MY_P="${P/mhonarc-gentoo/MHonArc}"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${P}-archives-gentoo.patch" )
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}' -prefix '${D}'|g" -i Makefile || die "sed on Makefile failed"
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me || die "sed on install.me failed"
+
+ perl-module_src_install
+}