summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-01-04 14:41:26 +0000
committerSam James <sam@gentoo.org>2021-01-04 16:45:16 +0000
commit073ae175a293b868284f772ebcd07f12994ce8ce (patch)
tree3740acd7cc59ba55611557984d4bc48a094176a2 /net-mail/mu
parentnet-mail/mu: Drop old (diff)
downloadgentoo-073ae175a293b868284f772ebcd07f12994ce8ce.tar.gz
gentoo-073ae175a293b868284f772ebcd07f12994ce8ce.tar.bz2
gentoo-073ae175a293b868284f772ebcd07f12994ce8ce.zip
net-mail/mu: Bump to 1.4.14
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/18942 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.4.14.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index d2d96b0efc6b..5b54cfba18e8 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1 +1,2 @@
DIST mu-1.4.13.tar.gz 2309545 BLAKE2B 9a83e86ab73e325617694f01877a11a93a5bd701cedc776640563f0a5e61946064e201d3f5da2110e1f9583dde9a73e401dd2f018161380435f48f132b2df103 SHA512 0f8e7f75332257e8cfdecf2c27bc23c83420387e40ecf92089232af6c545700a6c4925665b39fc236cacf8b26fa4b81df71775cdbe04c340fe3455c54c0d1bbc
+DIST mu-1.4.14.tar.gz 2309663 BLAKE2B 0c043596f6570f9749aba647054a7da78229fcaef03fc0f480c9381e057e34f15872f8e536f1754fdf30f22489cc9acfb83b301eb9f2fab8847b4fcc7f4863d1 SHA512 c51b9e1b8539349116cbd0e62741b3500ed51d12ada99bb3cde39a3e99b93d4a4f487795d56a31ae8189bf349003fe2fbfd95fa652c29231411bda04d9a6d06b
diff --git a/net-mail/mu/mu-1.4.14.ebuild b/net-mail/mu/mu-1.4.14.ebuild
new file mode 100644
index 000000000000..ab29acf0a6fd
--- /dev/null
+++ b/net-mail/mu/mu-1.4.14.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile mug"
+
+DEPEND="
+ dev-libs/glib:2=
+ dev-libs/gmime:3.0=
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-24.4:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ mug? (
+ net-libs/webkit-gtk:4=
+ x11-libs/gtk+:3=
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable mug gtk)
+ $(use_enable mug webkit)
+ $(use_enable guile)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dobin mu/mu
+ dodoc AUTHORS HACKING NEWS NEWS.org TODO README ChangeLog
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo mu4e/mu4e.info
+ fi
+
+ doman man/mu-*.*
+
+ if use guile; then
+ doinfo guile/mu-guile.info
+ fi
+
+ if use mug; then
+ dobin toys/mug/mug
+ fi
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}