summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-10-17 11:25:18 +0100
committerSam James <sam@gentoo.org>2021-10-20 01:11:09 +0000
commit1ff0e7da8b05d24d9074ae0fa3581206110e7ed3 (patch)
treefc75fb8a3b78b0bf980252b8632349d3e72c4238 /net-mail/mu
parentnet-mail/mu: Drop old (diff)
downloadgentoo-1ff0e7da8b05d24d9074ae0fa3581206110e7ed3.tar.gz
gentoo-1ff0e7da8b05d24d9074ae0fa3581206110e7ed3.tar.bz2
gentoo-1ff0e7da8b05d24d9074ae0fa3581206110e7ed3.zip
net-mail/mu: Bump to 1.6.7
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/22612 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.6.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index db4d54365573..56fec1cd99a4 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1 +1,2 @@
DIST mu-1.6.6.tar.xz 866724 BLAKE2B 3417d4b3e5bfae943558fbc936ca0207be912f9548621b1599437484e94f3b49271aa1e97e7cc2b5b6027b8e0cf97d3b96d2052772f7783d897b4fa0dcf03184 SHA512 07daf9864bfd1ff4278aee98a0ae9c4fc3be94468e3b2022ae801f048f339b5becdb9ad8ebb2e12b9131e0e6dfcfb541bdca8288657dc19d47b0e510831f54eb
+DIST mu-1.6.7.tar.xz 867136 BLAKE2B 12b19d15c01a7101e3a936b12ee87fa5519c0e047e354f2fd1d481939dd5dffa34a94a5e7f3fda20e27771377e78524065cf5f93f7a2f818e202cdc93090ebff SHA512 ceae7b4508fc607dcda0fc20e9fb92b3533b1ba7ef94823cba2cd3a6ad3f18ccd3d2ea7da20e4c190e53f2d00ccdd3e1d25e12b89a08bf5233f5656be90b3c14
diff --git a/net-mail/mu/mu-1.6.7.ebuild b/net-mail/mu/mu-1.6.7.ebuild
new file mode 100644
index 000000000000..94eaeb52fa23
--- /dev/null
+++ b/net-mail/mu/mu-1.6.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable guile)
+ $(use_enable readline)
+ --disable-gtk
+ --disable-webkit
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}