summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-06-09 20:13:39 +0100
committerMatthew Smith <matthew@gentoo.org>2022-06-09 20:32:42 +0100
commit64fe1f5dde73e646daf892b321365c3c6e18045d (patch)
treeff791076f910eac6f0fc25212e19fe8bb27402a4 /net-mail/mu
parentx11-terms/terminator: Stabilize 2.1.1-r1 x86, #850292 (diff)
downloadgentoo-64fe1f5dde73e646daf892b321365c3c6e18045d.tar.gz
gentoo-64fe1f5dde73e646daf892b321365c3c6e18045d.tar.bz2
gentoo-64fe1f5dde73e646daf892b321365c3c6e18045d.zip
net-mail/mu: add 1.6.11
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.6.11.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 9f778db017a0..91bc485d6b1c 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,2 +1,3 @@
DIST mu-1.6.10.tar.xz 867008 BLAKE2B 6cce22f18691c3ad6dda1ec012d72c398df2ba4d1beca70fc6f88d87aa9b749e2aa4c03f5c0e0d70f4f9978e2beb60ea02642b8ff71e86e0668df726e5923b52 SHA512 a51847b338afeff9c9fa88c4698df4b85289d017063cb5e3410eb967c605d8779618dcbd988e2d923a92291c1e0738ec84afecf017c76a63776149619d134887
+DIST mu-1.6.11.tar.xz 870188 BLAKE2B ec2ab4312800e8357b4fc902251708e27968cdde389e2403fca9ad6b1ef5e00154aa018d5a7751ec5372b5ca2be2eb030a9148c0d53f35040f420877d51ca3f3 SHA512 78faa4f9b34827676203ab305797deb96c0c0f9b0e8158e627c9a992bccd9c5708d4a1f5cc93c0b9c7f9a224b047800bd389bf3fceb163aa139ecff0cfa19274
DIST mu-1.7.23.tar.xz 2136016 BLAKE2B 9b0a27fc07072e52c06d8d4b807a77491d314d4c531799a83b1281ce935b79f5eab3510dc94be98ee0effe86c69379331172cfea3db330b8302d03582f7bf364 SHA512 412789146e4962f670c356576906e5eabc5783dd0fc7d04440146f064877f53b4e948713ed557e97b114a96d7a41b3087a8e3c528b48bb363e68fd0eabfe42fc
diff --git a/net-mail/mu/mu-1.6.11.ebuild b/net-mail/mu/mu-1.6.11.ebuild
new file mode 100644
index 000000000000..311a0e76b0b5
--- /dev/null
+++ b/net-mail/mu/mu-1.6.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable guile)
+ $(use_enable readline)
+ --disable-gtk
+ --disable-webkit
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # On some systems make -n errors out so the default src_test
+ # implementation does not call the tests. Bug #836782
+ emake test
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}