summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-22 18:44:10 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-22 18:46:26 +0100
commit65700246aa7143d1fa622f67756c239a7e7981af (patch)
treeab8426a91953af3fd6ef462175d9b54a8bbdd119 /net-mail/mu
parentnet-p2p/go-ipfs: add note re vendor tarball (diff)
downloadgentoo-65700246aa7143d1fa622f67756c239a7e7981af.tar.gz
gentoo-65700246aa7143d1fa622f67756c239a7e7981af.tar.bz2
gentoo-65700246aa7143d1fa622f67756c239a7e7981af.zip
net-mail/mu: explicitly call emake test
Closes: https://bugs.gentoo.org/836782 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/mu-1.6.10.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-mail/mu/mu-1.6.10.ebuild b/net-mail/mu/mu-1.6.10.ebuild
index ce62a8d42dd1..7900e1384200 100644
--- a/net-mail/mu/mu-1.6.10.ebuild
+++ b/net-mail/mu/mu-1.6.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,6 +38,12 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ # On some systems make -n errors out so the default src_test
+ # implementation does not call the tests. Bug #836782
+ emake test
+}
+
src_install() {
default
find "${ED}" -name '*.la' -type f -delete || die