summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-07-09 11:15:03 +0100
committerMatthew Smith <matthew@gentoo.org>2022-07-09 11:16:37 +0100
commita951a05aa831cf50b2a16e58a5a3ad4fe2453bc8 (patch)
treef4cc81f30e0faa53b6ad651555abe36ae6363a8e /net-mail/mu
parentdev-util/unicorn: drop redundant BUILD_SHARED_LIBS (diff)
downloadgentoo-a951a05aa831cf50b2a16e58a5a3ad4fe2453bc8.tar.gz
gentoo-a951a05aa831cf50b2a16e58a5a3ad4fe2453bc8.tar.bz2
gentoo-a951a05aa831cf50b2a16e58a5a3ad4fe2453bc8.zip
net-mail/mu: add 1.8.5
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.8.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 928feb8f4afd..0cb493566cce 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -2,3 +2,4 @@ DIST mu-1.6.10.tar.xz 867008 BLAKE2B 6cce22f18691c3ad6dda1ec012d72c398df2ba4d1be
DIST mu-1.6.11.tar.xz 870188 BLAKE2B ec2ab4312800e8357b4fc902251708e27968cdde389e2403fca9ad6b1ef5e00154aa018d5a7751ec5372b5ca2be2eb030a9148c0d53f35040f420877d51ca3f3 SHA512 78faa4f9b34827676203ab305797deb96c0c0f9b0e8158e627c9a992bccd9c5708d4a1f5cc93c0b9c7f9a224b047800bd389bf3fceb163aa139ecff0cfa19274
DIST mu-1.7.23.tar.xz 2136016 BLAKE2B 9b0a27fc07072e52c06d8d4b807a77491d314d4c531799a83b1281ce935b79f5eab3510dc94be98ee0effe86c69379331172cfea3db330b8302d03582f7bf364 SHA512 412789146e4962f670c356576906e5eabc5783dd0fc7d04440146f064877f53b4e948713ed557e97b114a96d7a41b3087a8e3c528b48bb363e68fd0eabfe42fc
DIST mu-1.8.1.tar.xz 537892 BLAKE2B dda0cdd3a45572000861557b04d8c92c0d61c283c6ace69a034ce209d22dc7e26ea4ac77c6493c505e0c7bcbf47ace82cd82ab20295170b2a986fcccaa0c5df9 SHA512 01b4c349aecf4134c700b6e4b1bc58d1e1360a74feec3f3ee56d1f350c7640b7447bdc35f158ce892427b7b7fbe15cfb00ab28d5aa05b9eaba1d4b4f32e5ed26
+DIST mu-1.8.5.tar.xz 539368 BLAKE2B 6efc12f82aab2beee86475ee49492ce59cb70e8b4fa63f2099a6071ec3275e7f0f308a868133ab3be4646d2280f720a4f6bb5673563a4437d2135e149b1cdfac SHA512 f43afb9484937077f32a38f347352b1ec8fb74c85be74f3afdd53ff75b965f42ab88daa58433fd9292a10c69ed2f2daf3ddbaf3d8d5d5595b0b29b81629a846f
diff --git a/net-mail/mu/mu-1.8.5.ebuild b/net-mail/mu/mu-1.8.5.ebuild
new file mode 100644
index 000000000000..af673005c01c
--- /dev/null
+++ b/net-mail/mu/mu-1.8.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Don't compress the info file.
+ sed -i '/gzip/d' build-aux/meson-install-info.sh || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature readline)
+ -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
+ # NOTE: Guile interface is deprecated to be removed shortly.
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}