summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-13 00:08:45 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-13 00:09:34 -0700
commit719fd8b321b84fe261561a78f6d73212a31f0bec (patch)
treec2dec4a6587dd46708f733ab89310fe01dba368f /net-mail/notmuch
parentdev-ruby/debug_inspector: add 1.1.0 (diff)
downloadgentoo-719fd8b321b84fe261561a78f6d73212a31f0bec.tar.gz
gentoo-719fd8b321b84fe261561a78f6d73212a31f0bec.tar.bz2
gentoo-719fd8b321b84fe261561a78f6d73212a31f0bec.zip
net-mail/notmuch: add 0.32.1
Closes: https://bugs.gentoo.org/791079 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/files/notmuch-0.32.1-tests.patch174
-rw-r--r--net-mail/notmuch/notmuch-0.32.1.ebuild291
3 files changed, 466 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index 447108fd7212..a3ebf895d3a6 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -1,2 +1,3 @@
DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b4046772058706f13d516f65421a5105593660f1c556907bb2bb9607a3c2521243d1be07bffb70817ad3b8461680ca SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0
DIST notmuch-0.31.3.tar.xz 713900 BLAKE2B 64aa5c707a74544d31f1dce4e49f3e19cf8c733dfe6f0761dec5522eae94bacf0c01ab7c8212373f1857eeecbad569482365a53a10f56dfee72cefc8d3f4f05a SHA512 99119216b7ef7f9e336b11d03ebb61d9667a8fbddcf6fccc49b17d07f07867f0342b2766375e164b58eaa9a43237ec4d6567d616fe8813b929d28b203aedfa44
+DIST notmuch-0.32.1.tar.xz 725196 BLAKE2B 6163f512e88f1b9415b93f7c4a146dc1af6e41bacdbbd29bdb48706af4af4822b626a719d50146f0cfe4d35508d8aa767b0e75eadebf9d619912f3ee6ba0e59e SHA512 c561658919a3c19bfe282e28a5c95db5d58030f044307fdfcaee02d3bf6fc15c9ae9d6d9d8a948c9e6f9b54f563dc82cde757a26a7d7c33eb976b3cfe7ce8c36
diff --git a/net-mail/notmuch/files/notmuch-0.32.1-tests.patch b/net-mail/notmuch/files/notmuch-0.32.1-tests.patch
new file mode 100644
index 000000000000..8a5643254856
--- /dev/null
+++ b/net-mail/notmuch/files/notmuch-0.32.1-tests.patch
@@ -0,0 +1,174 @@
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sat, 22 May 2021 13:39:57 +0000 (+0300)
+Subject: test: replace notmuch_passwd_sanitize() with _libconfig_sanitize()
+X-Git-Url: https://git.notmuchmail.org/git?p=notmuch;a=commitdiff_plain;h=8675be1d307bc2df882107744641f6a7858e65ad;hp=3baa61e0e58402bc50c5df529fcf669bf4b2facb
+
+test: replace notmuch_passwd_sanitize() with _libconfig_sanitize()
+
+notmuch_passwd_sanitize() in test-lib.sh is too generic, it cannot
+work in many cases...
+
+The more specific version _libconfig_sanitize() replaces it in
+T590-libconfig.sh and the code that uses it is modified to output
+the keys (ascending numbers printed in hex) so the sanitizer knows
+what to sanitize in which lines...
+
+"@" + fqdn -> "@FQDN" replacement is used as fqdn could
+-- in theory -- be substring of 'USERNAME'.
+
+'user -> 'USER_FULL_NAME replacement to work in cases where user
+is empty -- as only first ' is replaced that works as expected.
+
+In addition to ".(none)" now also ".localdomain" is filtered from
+USERNAME@FQDN.
+
+/dev/fd/{n} is not defined in posix, but it is portable enough
+(if it weren't it is easy to fix -- now code looks clearer).
+---
+
+diff --git a/test/T590-libconfig.sh b/test/T590-libconfig.sh
+index 745e1bb4..bc7298f8 100755
+--- a/test/T590-libconfig.sh
++++ b/test/T590-libconfig.sh
+@@ -5,6 +5,25 @@ test_description="library config API"
+
+ add_email_corpus
+
++_libconfig_sanitize() {
++ ${NOTMUCH_PYTHON} /dev/fd/3 3<<'EOF'
++import os, sys, pwd, socket
++
++pw = pwd.getpwuid(os.getuid())
++user = pw.pw_name
++name = pw.pw_gecos.partition(",")[0]
++fqdn = socket.getaddrinfo(socket.gethostname(), 0, 0,
++ socket.SOCK_STREAM, 0, socket.AI_CANONNAME)[0][3]
++for l in sys.stdin:
++ if l[:4] == "08: ":
++ l = l.replace(user, "USERNAME", 1).replace("@" + fqdn, "@FQDN", 1)
++ l = l.replace(".(none)", "", 1).replace(".localdomain", "", 1)
++ elif l[:4] == "10: ":
++ l = l.replace("'" + name, "'USER_FULL_NAME", 1)
++ sys.stdout.write(l)
++EOF
++}
++
+ cat <<EOF > c_head
+ #include <string.h>
+ #include <stdlib.h>
+@@ -380,26 +399,26 @@ cat c_head - c_tail <<'EOF' | test_C ${MAIL_DIR} '' %NULL%
+ key < NOTMUCH_CONFIG_LAST;
+ key = (notmuch_config_key_t)(key + 1)) {
+ const char *val = notmuch_config_get (db, key);
+- printf("%s\n", val ? val : "NULL" );
++ printf("%02d: '%s'\n", key, val ? val : "NULL" );
+ }
+ }
+ EOF
+
+-notmuch_passwd_sanitize < OUTPUT > OUTPUT.clean
++_libconfig_sanitize < OUTPUT > OUTPUT.clean
+
+ cat <<'EOF' >EXPECTED
+ == stdout ==
+-MAIL_DIR
+-MAIL_DIR
+-MAIL_DIR/.notmuch/hooks
+-MAIL_DIR/.notmuch/backups
+-
+-unread;inbox
+-
+-true
+-USERNAME@FQDN
+-NULL
+-USER_FULL_NAME
++00: 'MAIL_DIR'
++01: 'MAIL_DIR'
++02: 'MAIL_DIR/.notmuch/hooks'
++03: 'MAIL_DIR/.notmuch/backups'
++04: ''
++05: 'unread;inbox'
++06: ''
++07: 'true'
++08: 'USERNAME@FQDN'
++09: 'NULL'
++10: 'USER_FULL_NAME'
+ == stderr ==
+ EOF
+ unset MAILDIR
+@@ -694,23 +713,23 @@ cat c_head2 - c_tail <<'EOF' | test_C ${MAIL_DIR} %NULL% %NULL%
+ key < NOTMUCH_CONFIG_LAST;
+ key = (notmuch_config_key_t)(key + 1)) {
+ const char *val = notmuch_config_get (db, key);
+- printf("%s\n", val ? val : "NULL" );
++ printf("%x: '%s'\n", key, val ? val : "NULL" );
+ }
+ }
+ EOF
+ cat <<'EOF' >EXPECTED
+ == stdout ==
+-MAIL_DIR
+-MAIL_DIR
+-MAIL_DIR/.notmuch/hooks
+-MAIL_DIR/.notmuch/backups
+-foo;bar;fub
+-unread;inbox
+-sekrit_junk
+-true
+-test_suite@notmuchmail.org
+-test_suite_other@notmuchmail.org;test_suite@otherdomain.org
+-Notmuch Test Suite
++0: 'MAIL_DIR'
++1: 'MAIL_DIR'
++2: 'MAIL_DIR/.notmuch/hooks'
++3: 'MAIL_DIR/.notmuch/backups'
++4: 'foo;bar;fub'
++5: 'unread;inbox'
++6: 'sekrit_junk'
++7: 'true'
++8: 'test_suite@notmuchmail.org'
++9: 'test_suite_other@notmuchmail.org;test_suite@otherdomain.org'
++a: 'Notmuch Test Suite'
+ == stderr ==
+ EOF
+ test_expect_equal_file EXPECTED OUTPUT
+@@ -723,25 +742,26 @@ cat c_head2 - c_tail <<'EOF' | test_C ${MAIL_DIR} /nonexistent %NULL%
+ key < NOTMUCH_CONFIG_LAST;
+ key = (notmuch_config_key_t)(key + 1)) {
+ const char *val = notmuch_config_get (db, key);
+- printf("%s\n", val ? val : "NULL" );
++ printf("%02d: '%s'\n", key, val ? val : "NULL" );
+ }
+ }
+ EOF
+
+-notmuch_passwd_sanitize < OUTPUT > OUTPUT.clean
++_libconfig_sanitize < OUTPUT > OUTPUT.clean
++
+ cat <<'EOF' >EXPECTED
+ == stdout ==
+-MAIL_DIR
+-MAIL_DIR
+-MAIL_DIR/.notmuch/hooks
+-MAIL_DIR/.notmuch/backups
+-
+-unread;inbox
+-
+-true
+-USERNAME@FQDN
+-NULL
+-USER_FULL_NAME
++00: 'MAIL_DIR'
++01: 'MAIL_DIR'
++02: 'MAIL_DIR/.notmuch/hooks'
++03: 'MAIL_DIR/.notmuch/backups'
++04: ''
++05: 'unread;inbox'
++06: ''
++07: 'true'
++08: 'USERNAME@FQDN'
++09: 'NULL'
++10: 'USER_FULL_NAME'
+ == stderr ==
+ EOF
+ test_expect_equal_file EXPECTED OUTPUT.clean
diff --git a/net-mail/notmuch/notmuch-0.32.1.ebuild b/net-mail/notmuch/notmuch-0.32.1.ebuild
new file mode 100644
index 000000000000..26acc520cdb7
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.32.1.ebuild
@@ -0,0 +1,291 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+NEED_EMACS="24.1"
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit bash-completion-r1 desktop distutils-r1 elisp-common flag-o-matic pax-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="https://notmuchmail.org/releases/${P}.tar.xz
+ test? ( https://notmuchmail.org/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
+REQUIRED_USE="
+ apidoc? ( doc )
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+"
+IUSE="apidoc crypt doc emacs mutt nmbug python test valgrind"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ apidoc? (
+ app-doc/doxygen
+ dev-lang/perl
+ )
+ doc? (
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ )
+ test? ( sys-process/parallel )
+"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ dev-libs/gmime:3.0[crypt]
+ >=dev-libs/xapian-1.4.0:=
+ sys-libs/talloc
+ sys-libs/zlib:=
+ emacs? ( >=app-editors/emacs-${NEED_EMACS}:* )
+ python? (
+ ${PYTHON_DEPS}
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="${COMMON_DEPEND}
+ test? (
+ >=app-editors/emacs-${NEED_EMACS}:*[libxml2]
+ app-misc/dtach
+ sys-devel/gdb
+ crypt? (
+ app-crypt/gnupg
+ dev-libs/openssl
+ )
+ )
+ valgrind? ( dev-util/valgrind )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ mutt? (
+ dev-perl/File-Which
+ dev-perl/Mail-Box
+ dev-perl/MailTools
+ dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ )
+ nmbug? ( dev-vcs/git )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tests.patch"
+)
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_unpack() {
+ unpack "${P}".tar.xz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ use python && distutils-r1_src_prepare
+
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # Override 'install' target, we want to install manpages with doman, but let it install texinfo files.
+ sed -i "s/all install-man install-info/all $(usex doc install-info '')/" "Makefile.local" || die
+
+ use test && append-flags '-g'
+
+ # Non-autoconf configure
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags '-lnsl' '-lsocket'
+
+ # sphinx-4 broke everything. https://bugs.gentoo.org/789492
+ echo 'man_make_section_directory = False' >> doc/conf.py || die
+}
+
+src_configure() {
+ python_setup # For sphinx
+
+ tc-export CC CXX
+
+ local myconf=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with apidoc api-docs)
+ $(use_with doc docs)
+ $(use_with emacs)
+ )
+
+ econf "${myconf[@]}"
+}
+
+python_compile() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_compile
+ # copy stuff just in case
+ if use test; then
+ mkdir -p build/stage/tests || die
+ cp -v tests/*.py build/stage/tests || die
+ fi
+ popd > /dev/null || die
+
+ # TODO: we want to drop those, research revdeps
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_compile
+ popd > /dev/null || die
+}
+
+python_compile_all() {
+ use doc && emake -C bindings/python/docs html
+}
+
+src_compile() {
+ python_setup # For sphinx
+
+ # prevent race in emacs doc generation
+ # FileNotFoundError: [Errno 2] No such file or directory: '..work/notmuch-0.31/emacs/notmuch.rsti'
+ if use emacs; then
+ use doc && emake -j1 -C emacs docstring.stamp V=1 #nowarn
+ fi
+
+ emake V=1
+
+ use python && distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ emake notmuch-mutt.1
+ popd > /dev/null || die
+ fi
+}
+
+python_test() {
+ # we only have tests for cffi bindings
+ pushd bindings/python-cffi > /dev/null || die
+ rm -f tox.ini || die
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+src_test() {
+ local test_failures=()
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${S}/lib" \
+ nonfatal emake test V=1 OPTIONS="--verbose --tee" || test_failures+=( "'emake tests'" )
+ pax-mark -ze notmuch
+
+ # both lib and bin needed for testsuite.
+ if use python; then
+ LD_LIBRARY_PATH="${S}/lib" \
+ PATH="${S}:${PATH}" \
+ nonfatal distutils-r1_src_test || test_failures+=( "'python tests'" )
+ fi
+
+ [[ ${test_failures} ]] && die "Tests failed: ${test_failures[@]}"
+}
+
+python_install() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ pushd doc/_build/man/man1 > /dev/null || die
+ ln notmuch.1 notmuch-setup.1 || die
+ popd > /dev/null || die
+ if use apidoc; then
+ # rename overly generic manpage to avoid clashes
+ mv doc/_build/man/man3/deprecated.3 \
+ doc/_build/man/man3/notmuch-deprecated.3 || die
+ fi
+ doman doc/_build/man/man?/*.?
+ fi
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ domenu emacs/notmuch-emacs-mua.desktop
+ fi
+
+ if use nmbug; then
+ # TODO: those guys need proper deps
+ python_fix_shebang devel/nmbug/{nmbug,notmuch-report}
+ dobin devel/nmbug/{nmbug,notmuch-report}
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ dobin notmuch-mutt
+ # this manpage is built by pod2man
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd > /dev/null || die
+ fi
+
+ local DOCS=( README{,.rst} INSTALL NEWS )
+ einstalldocs
+
+ if use python; then
+ use doc && local HTML_DOCS=( bindings/python/docs/html/. )
+ distutils-r1_src_install
+ fi
+}
+
+pkg_preinst() {
+ local _rcfile="/etc/mutt/notmuch-mutt.rc"
+ if use mutt && ! [[ -e "${EROOT}"${_rcfile} ]]; then
+ elog "To enable notmuch support in mutt, add the following line"
+ elog "to your mutt config file:"
+ elog ""
+ elog " source ${_rcfile}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}