summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-06 03:00:45 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-06 03:00:45 -0600
commitaa7631b856e4730d8f8ad5b304914ebb016fad67 (patch)
tree5640f1fee95cdb5da935702d4f62be7ac0073739 /net-mail/offlineimap
parentdev-python/decorator: remove old (diff)
downloadgentoo-aa7631b856e4730d8f8ad5b304914ebb016fad67.tar.gz
gentoo-aa7631b856e4730d8f8ad5b304914ebb016fad67.tar.bz2
gentoo-aa7631b856e4730d8f8ad5b304914ebb016fad67.zip
net-mail/offlineimap: version bump to 7.2.4
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.2.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index 894079be1e00..2f6ecc93dcc5 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -3,3 +3,4 @@ DIST offlineimap-6.7.0.3.tar.gz 679221 BLAKE2B bdc5013dff0a3dc1e79326d6c7bac6ebb
DIST offlineimap-7.1.5.tar.gz 711529 BLAKE2B 055fcaa714529407d404b45afc56f2b9c407865bbb6403a205f916926905c845c3dd9d025824de82850c17e2791c335aa11a38e9688c847d388ffaa97dbf5d2b SHA512 5e49e5e2f13a15f02036860d1622a79a1342c8d3c0ad1c3e56c32a90e9c6e439ed9b9de6b67e36bda19229e28bd17dcb132f093eb19524375b182dde079d6101
DIST offlineimap-7.2.1.tar.gz 720220 BLAKE2B 309a51e88ebbc8dd7a4d807bc506a0d0d8a355e71f464e5347ba3ea02de6fd89a089bb982475982d62bed0900eb1aa5320163e49ac787b9d8abff029ac47ee7d SHA512 4e6bcda576fbf023e0192e8d19627d72ea824cd795ef65604d56b00f239298031ea512dcc17d47ae340be1515770c8588907bc767489717a9ab136e34843c197
DIST offlineimap-7.2.2.tar.gz 721359 BLAKE2B f59f26aa3cb7a3a5d994e5e9f48dd9de4f00193a71dbb2cd976dd6c8459b7dc6750c0a0bbcc8b954745ffe18e16cbeb6739f63ec9c4a530fbf2489db36771117 SHA512 de60472d24368ff4f5c43ecb50b021c671e6fe713220475da8bd900de6bfb6a10ec8c585f96f6091caea32344f65886e2870d097974ebef343b0ca56a81ddd7c
+DIST offlineimap-7.2.4.tar.gz 721887 BLAKE2B f5c7c8eb541167b3f0d46ee71be418d4697f89a1dc11a1c5c9840e5def09d108b7ab391d773dc79e0882ce0a9e21388e11217915112f476d384bf3018d5ea750 SHA512 837f822a08f5df59f5332c65b33e0186c215a633c5c17f08790f4c2128a4f6470a75eb02e883dd592b456dbc0ba2b32f670cb716eb602dd8a6bdf12ba2d72cd8
diff --git a/net-mail/offlineimap/offlineimap-7.2.4.ebuild b/net-mail/offlineimap/offlineimap-7.2.4.ebuild
new file mode 100644
index 000000000000..401eb0958288
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.2.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="https://www.offlineimap.org/"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}