summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Ogilvie <mmogilvi+gnto@zoho.com>2019-10-23 19:39:58 -0600
committerMichał Górny <mgorny@gentoo.org>2019-11-05 23:14:55 +0100
commit4f24163bf1e2145f36eb2183b91bd553770b4945 (patch)
tree485c51ee9159969d3b2fa06738ad000a19418861 /net-mail/poppassd_ceti
parentmail-filter/procmail-lib: Remove last-rited pkg (diff)
downloadgentoo-4f24163bf1e2145f36eb2183b91bd553770b4945.tar.gz
gentoo-4f24163bf1e2145f36eb2183b91bd553770b4945.tar.bz2
gentoo-4f24163bf1e2145f36eb2183b91bd553770b4945.zip
net-mail/poppassd_ceti: bump 1.8.7, EAPI=7
In addition to 1.8.7 changes from upstream, the changes compared to 1.8.5-r2 include: - Change to EAPI=7. - LICENSE=GPL-2+ (Although strictly speaking the "or later version" terminology was only added upstream after the 1.8.7 tarball was cut.) - Drop the xinetd RDEPEND, and document it (and the sudo alternative) using readme.gentoo-r1.eclass Bug: https://bugs.gentoo.org/696252 Signed-off-by: Matthew Ogilvie <mmogilvi+gnto@zoho.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-mail/poppassd_ceti')
-rw-r--r--net-mail/poppassd_ceti/Manifest1
-rw-r--r--net-mail/poppassd_ceti/poppassd_ceti-1.8.7.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-mail/poppassd_ceti/Manifest b/net-mail/poppassd_ceti/Manifest
index b69052218de2..5edcaf737ef5 100644
--- a/net-mail/poppassd_ceti/Manifest
+++ b/net-mail/poppassd_ceti/Manifest
@@ -1 +1,2 @@
DIST poppassd-1.8.5.tar.gz 6054 BLAKE2B f97c908a3880aa9ddb76ce09f33046649dfa2d145c8d8d5b70f1a7b473ba2ba8901b62d8e0644187c5987e3c4c8257c8f2bee9504b98bf3d81035e0acda4522c SHA512 4d8d9c3b15b986bd34e5e459f654e8137019a2466b9fec001d9e61a3267b09f150c3faee8e6914d98742c7b3a7301271ba522ee6dff614cca97815a3ae241ae9
+DIST poppassd-ceti-1.8.7.tar.xz 71400 BLAKE2B ca26f7298a8f679c595a9cd66622f1e8ddeff80a7b1655df91a7a15668337112113806d0aef788a374c483cbc957e765b178428d839da2c853ebf87e16039548 SHA512 d50549a4f6bdd9eac7fa74a7787e47dbffff14da883d4e8e23e24802883761c1a392b8a7fbffe5fa726845f48b3b33e0dbc1743ad2d689a4d396c91d0a42f8f1
diff --git a/net-mail/poppassd_ceti/poppassd_ceti-1.8.7.ebuild b/net-mail/poppassd_ceti/poppassd_ceti-1.8.7.ebuild
new file mode 100644
index 000000000000..2ec3e4e92f26
--- /dev/null
+++ b/net-mail/poppassd_ceti/poppassd_ceti-1.8.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam readme.gentoo-r1
+
+# Long ago it was just "poppassd", but upstream now seems to have
+# settled on "poppassd-ceti" (instead of "poppassd_ceti" or no suffix).
+MY_PN="poppassd-ceti"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Password change daemon with PAM support"
+HOMEPAGE="https://github.com/kravietz/poppassd-ceti"
+SRC_URI="https://github.com/kravietz/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz"
+
+# Strictly speaking the "or later version" clarification was only
+# added upstream after 1.8.7:
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+FORCE_PRINT_ELOG=1 # possibly remove in the next bump
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="poppassd is installed, but has to be run as root to work.
+
+Most commonly a front end would require sys-apps/xinetd and connect to
+port 106: For this, edit /etc/xinetd.d/poppassd, install sys-apps/xinetd,
+and start the xinetd service.
+
+Alternatively, a front end may be able to run it directly (if already
+root), or might use app-admin/sudo. To use sudo, you'll need to configure
+/etc/sudoers with something similar to:
+
+ apache ALL=(ALL) NOPASSWD: /usr/sbin/poppassd
+
+See also README.md.bz2 for related configuration and security
+considerations.
+"
+
+src_install() {
+ dodoc README.md
+ readme.gentoo_create_doc
+
+ pamd_mimic_system poppassd auth account password
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/poppassd.xinetd poppassd
+
+ exeinto /usr/sbin
+ exeopts -o root -g bin -m 500
+ doexe poppassd
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}