summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-08-02 09:07:05 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-08-02 09:09:51 -0400
commit98539b029b43e863988d0ee2558577c7c08f2321 (patch)
tree0afeefa51e3d1b13e5eae313764cc58b2e02f98f /net-mail/postfix-logwatch
parentmedia-sound/abcmidi: removed obsolete 2021.05.25 (diff)
downloadgentoo-98539b029b43e863988d0ee2558577c7c08f2321.tar.gz
gentoo-98539b029b43e863988d0ee2558577c7c08f2321.tar.bz2
gentoo-98539b029b43e863988d0ee2558577c7c08f2321.zip
net-mail/postfix-logwatch: new (forked) version 1.40.04.
I have finally forked this project, since I'm the only one who's been patching it to work with new versions of perl and postfix. This is the first release that I've made of the fork, which now thankfully does not require any patches or workarounds in the ebuild. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/postfix-logwatch')
-rw-r--r--net-mail/postfix-logwatch/Manifest1
-rw-r--r--net-mail/postfix-logwatch/metadata.xml3
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild31
3 files changed, 32 insertions, 3 deletions
diff --git a/net-mail/postfix-logwatch/Manifest b/net-mail/postfix-logwatch/Manifest
index a2d125504895..d7d14eaf1743 100644
--- a/net-mail/postfix-logwatch/Manifest
+++ b/net-mail/postfix-logwatch/Manifest
@@ -1 +1,2 @@
DIST postfix-logwatch-1.40.03.tgz 107065 BLAKE2B 153f83c3414d2773ec528260369a564624aacc6de5627ee1da77d1eea89b276fb014c045785bc8ae1fbf7e6da2279a0d309ab171ff55d1087d3379466570c5ea SHA512 7059f409cabb3cb638885342ab876e1c85c87530c3544bf04c54a56707695acdc5cbb706e3f192ef5608c9a00706e4d7be3cc7b32286460719d7b497e44b3341
+DIST postfix-logwatch-1.40.04.tar.xz 78996 BLAKE2B fea2a08a7bc776cf0106a60bc0f86730c562d6c893629a1028183150a246803bda8ada6a5ec7e264685fe40016b82ce4140031af7e508ac4b1d9a34e552b865d SHA512 194917fe4d05e9808893da0c175859e932d5e48956d1dda96129dd5de7f9ee23131ae1831b558c8c2d32d03ffda80aa95cfd5048543b7766a0486a71efa6c19b
diff --git a/net-mail/postfix-logwatch/metadata.xml b/net-mail/postfix-logwatch/metadata.xml
index c2f0518836b4..a0128bcd9ef0 100644
--- a/net-mail/postfix-logwatch/metadata.xml
+++ b/net-mail/postfix-logwatch/metadata.xml
@@ -4,7 +4,4 @@
<maintainer type="person">
<email>mjo@gentoo.org</email>
</maintainer>
- <upstream>
- <remote-id type="sourceforge">logreporters</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild
new file mode 100644
index 000000000000..bab89768c04c
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://michael.orlitzky.com/code/postfix-logwatch.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}