summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-28 23:57:15 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-28 23:57:39 +0100
commitd2c01217ce9c1c87dd81c3ed4f8da754006308c2 (patch)
treec66e6c13001d19a062a01daff4590803ccfed3ac /net-mail/public-inbox/public-inbox-1.7.0.ebuild
parentdev-perl/Search-Xapian: Allow newer xapian (diff)
downloadgentoo-d2c01217ce9c1c87dd81c3ed4f8da754006308c2.tar.gz
gentoo-d2c01217ce9c1c87dd81c3ed4f8da754006308c2.tar.bz2
gentoo-d2c01217ce9c1c87dd81c3ed4f8da754006308c2.zip
net-mail/public-inbox: New package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-mail/public-inbox/public-inbox-1.7.0.ebuild')
-rw-r--r--net-mail/public-inbox/public-inbox-1.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/public-inbox/public-inbox-1.7.0.ebuild b/net-mail/public-inbox/public-inbox-1.7.0.ebuild
new file mode 100644
index 000000000000..6d7bfd810fcf
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+HOMEPAGE="https://public-inbox.org"
+SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+DESCRIPTION="An archives-first approach to mailing lists"
+LICENSE="AGPL-3+"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-vcs/git
+ dev-perl/DBD-SQLite
+ virtual/mta
+ dev-perl/URI
+ dev-perl/Plack
+ dev-perl/TimeDate
+ dev-perl/Inline-C
+ dev-perl/Email-Address-XS
+ dev-perl/Search-Xapian
+ dev-perl/Parse-RecDescent
+ dev-perl/Mail-IMAPClient
+ dev-perl/BSD-Resource
+ net-misc/curl
+ dev-perl/Linux-Inotify2
+ dev-perl/Net-Server
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"