summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-20 18:29:07 +0100
committerSam James <sam@gentoo.org>2023-09-20 18:29:48 +0100
commit2a3a8306a2836566b879e7ef04474773c14ea9d2 (patch)
tree82c393a8c245ab405dfffb994351007e7b4e6c5f /net-mail/public-inbox
parentdev-libs/simdjson: drop 3.2.1 (diff)
downloadgentoo-2a3a8306a2836566b879e7ef04474773c14ea9d2.tar.gz
gentoo-2a3a8306a2836566b879e7ef04474773c14ea9d2.tar.bz2
gentoo-2a3a8306a2836566b879e7ef04474773c14ea9d2.zip
net-mail/public-inbox: add 1.9.0_p20230918, 9999
Add snapshot for infra b/c last version has issues w/ our message IDs and the last release was a while ago. Add a live ebuild while at it. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/public-inbox')
-rw-r--r--net-mail/public-inbox/Manifest1
-rw-r--r--net-mail/public-inbox/public-inbox-1.9.0_p20230918.ebuild53
-rw-r--r--net-mail/public-inbox/public-inbox-9999.ebuild53
3 files changed, 107 insertions, 0 deletions
diff --git a/net-mail/public-inbox/Manifest b/net-mail/public-inbox/Manifest
index 9a28f4741c02..bef1b8e9acc2 100644
--- a/net-mail/public-inbox/Manifest
+++ b/net-mail/public-inbox/Manifest
@@ -1,3 +1,4 @@
DIST public-inbox-1.7.0.tar.gz 805628 BLAKE2B 4403cd11a2c4f793b136aff07ccc06ea60011c21484196e497921ca36599870eecdf7b93f550ef44e876bca814a3b03e1d8d4b484113506ee809098124cfd1b2 SHA512 cb03d2ec3e28f1fc75bdbff2b8ea5b417898ddb2895d27b105624cab35f0dcab99269d86bfc158bdf42faecb7b7a5734363a81d2202970e8d079bf05fa359250
DIST public-inbox-1.8.0.tar.gz 808979 BLAKE2B 1b68121429f9d9b56008951c0fef8eca4082a71969c907d0e2ba1db434774a451e4080e88c7d0fe80960dba906e0981e19bfcacd63042acfe3c6e16f36aba675 SHA512 878c60d6e6bfdcac3218d71b8aa5cab766c622ff1a81c8ebb04399a48da7ef1ab86cae67f8f05e8486f92451f90b9c068ab67ba35dfb74179163598fb5860229
DIST public-inbox-1.9.0.tar.gz 828312 BLAKE2B 0de7a2437074ca75b56872697d7dbc69e8f4cd3735d85b314f80f1d6037da27f29aaaae8aaf9836f089f950ec3be25e473d9cabff60bd8ec6cf4b90da4ee2ac0 SHA512 9d98b78d29fc35a80bd22b9e133a70ebb0dfacc68859b3ae602037485f44e36cd4cc60f86a9d732da657ea665f20ba31f28b0a6cfea34badd5f124cbc13a6533
+DIST public-inbox-1.9.0_p20230918.tar.gz 918459 BLAKE2B e263d1ab599203ef9c4cfee3546856a5f472cec65b85d16014eec5359bbd6eb357242e98ffb1b355ce11ba1a5ce3e5c9c22dd51ce672adf0f83ed3c0f9df6ba2 SHA512 4359ba6876b5644cfa6e04ed0d8ed9a307407651f68503ed40841e7f2aaed540bf8d3ac07e7dde4fc2f19d8b0cadf2016e89bb346f58b24b8bb217003680a831
diff --git a/net-mail/public-inbox/public-inbox-1.9.0_p20230918.ebuild b/net-mail/public-inbox/public-inbox-1.9.0_p20230918.ebuild
new file mode 100644
index 000000000000..e3774a99b324
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-1.9.0_p20230918.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="An archives-first approach to mailing lists"
+HOMEPAGE="https://public-inbox.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="
+ https://public-inbox.org/public-inbox.git/
+ https://repo.or.cz/public-inbox.git
+ "
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ PUBLIC_INBOX_COMMIT="1febc5cbb633cf7eac7dcaf382dd0ebbfe085380"
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${PUBLIC_INBOX_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PUBLIC_INBOX_COMMIT}
+else
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+fi
+
+LICENSE="AGPL-3+"
+SLOT="0"
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64"
+fi
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-perl/BSD-Resource
+ dev-perl/DBD-SQLite
+ dev-perl/Email-Address-XS
+ dev-perl/Inline-C
+ dev-perl/Linux-Inotify2
+ dev-perl/Mail-IMAPClient
+ dev-perl/Net-Server
+ dev-perl/Parse-RecDescent
+ dev-perl/Plack
+ dev-perl/Search-Xapian
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-vcs/git
+ net-misc/curl
+ virtual/mta
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/net-mail/public-inbox/public-inbox-9999.ebuild b/net-mail/public-inbox/public-inbox-9999.ebuild
new file mode 100644
index 000000000000..e3774a99b324
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="An archives-first approach to mailing lists"
+HOMEPAGE="https://public-inbox.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="
+ https://public-inbox.org/public-inbox.git/
+ https://repo.or.cz/public-inbox.git
+ "
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ PUBLIC_INBOX_COMMIT="1febc5cbb633cf7eac7dcaf382dd0ebbfe085380"
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${PUBLIC_INBOX_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PUBLIC_INBOX_COMMIT}
+else
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+fi
+
+LICENSE="AGPL-3+"
+SLOT="0"
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64"
+fi
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-perl/BSD-Resource
+ dev-perl/DBD-SQLite
+ dev-perl/Email-Address-XS
+ dev-perl/Inline-C
+ dev-perl/Linux-Inotify2
+ dev-perl/Mail-IMAPClient
+ dev-perl/Net-Server
+ dev-perl/Parse-RecDescent
+ dev-perl/Plack
+ dev-perl/Search-Xapian
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-vcs/git
+ net-misc/curl
+ virtual/mta
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"