summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qmail-notify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qmail-notify')
-rw-r--r--net-mail/qmail-notify/Manifest1
-rw-r--r--net-mail/qmail-notify/files/qmail-notify.cron6
-rw-r--r--net-mail/qmail-notify/metadata.xml5
-rw-r--r--net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild44
4 files changed, 56 insertions, 0 deletions
diff --git a/net-mail/qmail-notify/Manifest b/net-mail/qmail-notify/Manifest
new file mode 100644
index 000000000000..6f6852e65988
--- /dev/null
+++ b/net-mail/qmail-notify/Manifest
@@ -0,0 +1 @@
+DIST qmail-notify-0.93.tar.gz 37923 SHA256 f39c5a302613c31eccc0cb385a8ee03527c3cbb70b788bab64317178a6843a8d
diff --git a/net-mail/qmail-notify/files/qmail-notify.cron b/net-mail/qmail-notify/files/qmail-notify.cron
new file mode 100644
index 000000000000..9d713e508cfc
--- /dev/null
+++ b/net-mail/qmail-notify/files/qmail-notify.cron
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# uncomment this to make it work
+#
+
+#exec /usr/sbin/qmail-notify -r
diff --git a/net-mail/qmail-notify/metadata.xml b/net-mail/qmail-notify/metadata.xml
new file mode 100644
index 000000000000..210ce3ffc25e
--- /dev/null
+++ b/net-mail/qmail-notify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qmail</herd>
+</pkgmetadata>
diff --git a/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild b/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild
new file mode 100644
index 000000000000..d815eedc6a04
--- /dev/null
+++ b/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Delayed delivery notification for qmail"
+SRC_URI="http://untroubled.org/qmail-notify/archive/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/qmail-notify/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~hppa ~ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ virtual/cron
+ virtual/qmail
+"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/sbin
+ doexe qmail-notify
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}"/qmail-notify.cron
+
+ dodoc README ANNOUNCEMENT TODO cron.hourly NEWS VERSION
+}
+
+pkg_postinst() {
+ echo
+ elog "Edit qmail-notify.cron in /etc/cron.hourly"
+ elog "to activate qmail-notify!"
+ echo
+}