summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 20:20:50 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 20:26:27 +0100
commit64111c1235d91b065b80ff66906e5442d2365b86 (patch)
tree9a75919b46c63f7954c8bbe998e246319a422ee8 /net-mail/qtools
parentnet-mail/qmailanalog: Bump to EAPI 7 (diff)
downloadgentoo-64111c1235d91b065b80ff66906e5442d2365b86.tar.gz
gentoo-64111c1235d91b065b80ff66906e5442d2365b86.tar.bz2
gentoo-64111c1235d91b065b80ff66906e5442d2365b86.zip
net-mail/qtools: Bump to EAPI 7
Bug: https://bugs.gentoo.org/697246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-mail/qtools')
-rw-r--r--net-mail/qtools/qtools-0.56.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/net-mail/qtools/qtools-0.56.ebuild b/net-mail/qtools/qtools-0.56.ebuild
index 7251ba3d40ef..b5c83062f98b 100644
--- a/net-mail/qtools/qtools-0.56.ebuild
+++ b/net-mail/qtools/qtools-0.56.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Utilities for use with qmail, typically as part of .qmail command processing"
HOMEPAGE="http://www.superscript.com/qtools/intro.html"
@@ -15,28 +15,24 @@ KEYWORDS="alpha ~amd64 ~hppa ~mips ppc ~sparc x86"
IUSE="static"
RESTRICT="mirror bindist"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-errno.patch
- epatch "${FILESDIR}"/${P}-head.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-errno.patch
+ "${FILESDIR}"/${P}-head.patch
+)
-src_compile() {
+src_configure() {
use static && LDFLAGS="${LDFLAGS} -static"
export CC="$(tc-getCC)"
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
- echo "/usr" > conf-home
- emake || die "emake failed"
+ echo "${CC} ${CFLAGS}" > conf-cc || die
+ echo "${CC} ${LDFLAGS}" > conf-ld || die
+ echo "/usr" > conf-home || die
}
src_install() {
- into /usr
dobin 822addr 822body 822bodyfilter 822fields 822headerfilter \
- 822headerok 822headers checkaddr checkdomain \
- condtomaildir filterto ifaddr iftoccfrom replier \
- replier-config tomaildir
+ 822headerok 822headers checkaddr checkdomain \
+ condtomaildir filterto ifaddr iftoccfrom replier \
+ replier-config tomaildir
dodoc BAPVERSION CHANGES FILES README SYSDEPS TARGETS TODO VERSION
}