summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/swaks/swaks-20130209.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/swaks/swaks-20130209.0.ebuild')
-rw-r--r--net-mail/swaks/swaks-20130209.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/swaks/swaks-20130209.0.ebuild b/net-mail/swaks/swaks-20130209.0.ebuild
new file mode 100644
index 000000000000..ae07f3aea1dd
--- /dev/null
+++ b/net-mail/swaks/swaks-20130209.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="http://www.jetmore.org/john/code/swaks"
+SRC_URI="http://www.jetmore.org/john/code/swaks/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE="ssl"
+
+DEPEND=">=dev-lang/perl-5.8.8"
+
+RDEPEND="${DEPEND}
+ >=dev-perl/Net-DNS-0.65
+ ssl? ( >=dev-perl/Net-SSLeay-1.35 )
+ >=virtual/perl-MIME-Base64-3.07
+ >=virtual/perl-Digest-MD5-2.39
+ >=virtual/perl-Time-HiRes-1.97
+ >=virtual/perl-Time-Local-1.19
+ >=dev-perl/Authen-NTLM-1.02
+ >=dev-perl/Authen-DigestMD5-0.04
+ virtual/perl-Digest-SHA"
+
+src_compile() {
+ /usr/bin/pod2man -s 1 doc/ref.pod swaks.1 || die "man page compulation failed"
+}
+
+src_install() {
+ newbin swaks swaks || die "newbin failed"
+ doman swaks.1 || die
+ dodoc README doc/*.txt || die
+}