summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Habenicht <j.habenicht@gmx.de>2019-10-30 14:43:33 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 19:36:51 +0100
commitf44e1f08ddf3bcd16e1c2f99b07da1abc6cac26d (patch)
treefee6d76788bd0cc5f450d64a102f593ce1a6e22c /net-mail/vacation/vacation-1.2.7.0.ebuild
parentx11-themes/windowmaker-themes: Drop EAPI 0 ebuild (diff)
downloadgentoo-f44e1f08ddf3bcd16e1c2f99b07da1abc6cac26d.tar.gz
gentoo-f44e1f08ddf3bcd16e1c2f99b07da1abc6cac26d.tar.bz2
gentoo-f44e1f08ddf3bcd16e1c2f99b07da1abc6cac26d.zip
net-mail/vacation: upgrade to EAPI7
fixes build error on incorrect man page path Bug: https://bugs.gentoo.org/696252 Signed-off-by: Jörg Habenicht <j.habenicht@gmx.de> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Closes: https://github.com/gentoo/gentoo/pull/13499 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-mail/vacation/vacation-1.2.7.0.ebuild')
-rw-r--r--net-mail/vacation/vacation-1.2.7.0.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/net-mail/vacation/vacation-1.2.7.0.ebuild b/net-mail/vacation/vacation-1.2.7.0.ebuild
index a564b6285344..89462f5392f1 100644
--- a/net-mail/vacation/vacation-1.2.7.0.ebuild
+++ b/net-mail/vacation/vacation-1.2.7.0.ebuild
@@ -1,38 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="automatic mail answering program"
HOMEPAGE="http://vacation.sourceforge.net/"
SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="alpha amd64 x86"
SLOT="0"
-IUSE=""
-RDEPEND="virtual/mta
- sys-libs/gdbm"
-DEPEND="${RDEPEND}
- !mail-mta/sendmail"
+RDEPEND="!mail-mta/sendmail
+ sys-libs/gdbm
+ virtual/mta"
+DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ default
- sed -i -e "s:install -s -m:install -m:" Makefile
- sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
+ sed -i -e "s:install -s -m:install -m:" \
+ -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile || die
}
src_compile () {
- emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+ emake CFLAGS="${CFLAGS} -DMAIN"
}
src_install () {
- dodir /usr/bin
- dodir /usr/share/man/man1
- emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
- "make install failed"
+ emake BINDIR="${ED}/usr/bin" MANDIR="${ED}/usr/share/man/man" install
}