summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/vqadmin/vqadmin-2.3.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/vqadmin/vqadmin-2.3.7.ebuild')
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.7.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-mail/vqadmin/vqadmin-2.3.7.ebuild b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
new file mode 100644
index 000000000000..227287639b96
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp eutils autotools qmail
+
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+HOMEPAGE="http://www.inter7.com/index.php?page=vqadmin"
+SRC_URI="http://www.inter7.com/vqadmin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes for sane webapp integration
+ sed -i \
+ -e "s|html/|/usr/share/${PN}/|g" \
+ -e "s|/images/vqadmin/|/vqadmin/|g" \
+ -e "s|/cgi-bin/vqadmin/|/cgi-bin/|g" \
+ -e "s|vqadmin\.cgi|vqadmin|g" \
+ *.h *.c html/*.html
+}
+
+src_compile() {
+ econf ${myopts} \
+ --enable-qmaildir="${QMAIL_HOME}" \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ --enable-cgibindir="${MY_CGIBINDIR}" \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto /usr/share/${PN}
+ doins html/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins html/*.css
+
+ insinto "${MY_CGIBINDIR}"
+ doins vqadmin.acl
+ insopts -m 755
+ doins vqadmin
+
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}