summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-16 02:14:58 +0100
committerSam James <sam@gentoo.org>2021-09-16 02:17:35 +0100
commit05e63664ed98b45a24cb6cccac4c284ade728b4b (patch)
tree7a71eefee73d641e0abee20c00e0d76b72ad192a /net-mail
parentnet-mail/cyrus-imapd: add 3.0.16 (diff)
downloadgentoo-05e63664ed98b45a24cb6cccac4c284ade728b4b.tar.gz
gentoo-05e63664ed98b45a24cb6cccac4c284ade728b4b.tar.bz2
gentoo-05e63664ed98b45a24cb6cccac4c284ade728b4b.zip
net-mail/cyrus-imapd: add 3.4.2
Bug: https://bugs.gentoo.org/798111 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imapd/Manifest1
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-3.4.2.ebuild233
2 files changed, 234 insertions, 0 deletions
diff --git a/net-mail/cyrus-imapd/Manifest b/net-mail/cyrus-imapd/Manifest
index b22ec598adf9..680623a04a73 100644
--- a/net-mail/cyrus-imapd/Manifest
+++ b/net-mail/cyrus-imapd/Manifest
@@ -3,3 +3,4 @@ DIST cyrus-imapd-3.0.14.tar.gz 10865880 BLAKE2B 36f3e60d715d2eab430040964e93cb33
DIST cyrus-imapd-3.0.15.tar.gz 10843341 BLAKE2B efe65c7afc7d63770adef9e4ea13b87e3b7fdd1847e4ada028175999b31ebb84f9d84b014018bd2be3fee9af1b5e81dd08f63225bc62dc5a4fd4a0791da16594 SHA512 2f65209095f086092fec0bfc9547c999a6e568cccc0a4164e7a3751fe2881f47bbbbd67ba9c9169feafead8c40d42f594d34171d911e4028425cfd8ba72d8f4a
DIST cyrus-imapd-3.0.16.tar.gz 10875516 BLAKE2B 10915418b4de3f460a20d3808274f9ea83bdadc9a9edf2b383081605f7510a3e1563fa009e1dcc203f1c008f26e9db3ffd80f101f546de1dc8c3e714efc13596 SHA512 c17dd940102989d1e329ad8a1c08655bdd8b349ecb08e661f55ab8e602516ece1a86e52313e8cd5677048470f15f4272fcb598e4bbc61d27e5a673c01cb81ca3
DIST cyrus-imapd-3.4.1.tar.gz 12539102 BLAKE2B f791d26f34a9a5e9896231ec812ae623bb3f5fc85a577ea25deea956bda153f941f2a759f77de10d105d0746827243efed773fe67eea4921200cb2cddf81e049 SHA512 9fd13e93755aca98215c1bd9c21fa3ef3a3db8b1ff48f71dd6070e614e9c68cb591b1cb411fa1319d46ab1d49ddc971f188a41cc0c9a2e2c9df0cc08299f8bfa
+DIST cyrus-imapd-3.4.2.tar.gz 12603768 BLAKE2B 515c36fc3d6a29991283d47a3e523d87a68c3191b4aae85074f40b2416fe3a89793f1991dc5729912a3d56247f6fbf4aed52abcadbc37ca7cc9bf857a8641871 SHA512 4d7d14e222bc1e97b2d8188804139c4c477de66cb621caba475b57533739ee59d88504d4f47735bb6a6b3c9097dbec382ecfa2c678f978791b9a6956a3cd91d6
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-3.4.2.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-3.4.2.ebuild
new file mode 100644
index 000000000000..9f3b5413327e
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-3.4.2.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pam ssl-cert
+
+DESCRIPTION="The Cyrus IMAP Server"
+HOMEPAGE="https://www.cyrusimap.org/"
+SRC_URI="https://github.com/cyrusimap/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD-with-attribution GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs backup calalarm caps clamav http kerberos ldap \
+ mysql nntp pam perl postgres replication +server sieve \
+ sqlite ssl static-libs tcpd test xapian"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ sys-libs/zlib:0=
+ dev-libs/libpcre:3
+ >=dev-libs/cyrus-sasl-2.1.13:2
+ dev-libs/jansson
+ dev-libs/icu:0=
+ sys-fs/e2fsprogs
+ afs? ( net-fs/openafs )
+ calalarm? ( dev-libs/libical:0= )
+ caps? ( sys-libs/libcap )
+ clamav? ( app-antivirus/clamav )
+ http? (
+ dev-libs/libxml2:2
+ dev-libs/libical:0=
+ net-libs/nghttp2
+ )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ nntp? ( !net-nntp/leafnode )
+ pam? (
+ >=net-mail/mailbase-1
+ sys-libs/pam
+ )
+ perl? ( dev-lang/perl:= )
+ postgres? ( dev-db/postgresql:* )
+ ssl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist(-)] )
+ sqlite? ( dev-db/sqlite:3 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ xapian? ( >=dev-libs/xapian-1.4.0:0= )
+"
+DEPEND="${CDEPEND}
+ test? ( dev-util/cunit )
+"
+
+# all blockers really needed?
+# file collision with app-arch/dump - bug 619584
+RDEPEND="${CDEPEND}
+ acct-group/mail
+ acct-user/cyrus
+ !mail-mta/courier
+ !net-mail/bincimap
+ !net-mail/courier-imap
+ !net-mail/uw-imap
+ !app-arch/dump
+"
+
+REQUIRED_USE="
+ afs? ( kerberos )
+ backup? ( sqlite )
+ calalarm? ( http )
+ http? ( sqlite )
+"
+
+# https://bugs.gentoo.org/678754
+# TODO: check underlinking for other libraries
+#PATCHES=(
+# "${FILESDIR}/cyrus-imapd-libcap-libs-r1.patch"
+#)
+
+src_prepare() {
+ default
+
+ # Fix master(8)->cyrusmaster(8) manpage.
+ for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+ sed -i -e 's:master\.8:cyrusmaster.8:g' \
+ -e 's:master(8):cyrusmaster(8):g' \
+ "${i}" || die "sed failed" || die "sed failed"
+ done
+ mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+ sed -i -e "s:MASTER:CYRUSMASTER:g" \
+ -e "s:Master:Cyrusmaster:g" \
+ -e "s:master:cyrusmaster:g" \
+ man/cyrusmaster.8 || die "sed failed"
+
+ # lock.h to afs/lock.h
+ sed -i -e '/lock.h/s:lock.h:afs/lock.h:' \
+ ptclient/afskrb.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # https://bugs.gentoo.org/604466
+ append-ldflags $(no-as-needed)
+
+ if use afs ; then
+ myconf+=" --with-afs-libdir=/usr/$(get_libdir)"
+ myconf+=" --with-afs-incdir=/usr/include/afs"
+ fi
+
+ # TODO:
+ # - revisit --with-sphinx-build=no? (it's docs this time, not the search engine)
+ # - post-emerge message re lmdb removal?
+ econf \
+ --enable-unit-tests \
+ --enable-murder \
+ --enable-idled \
+ --enable-autocreate \
+ --enable-pcre \
+ --with-com_err \
+ --with-cyrus-user=cyrus \
+ --with-sasl \
+ --with-sphinx-build=no \
+ --without-krb \
+ --without-krbdes \
+ --enable-squat \
+ --with-zlib \
+ $(use_enable afs) \
+ $(use_enable afs krb5afspts) \
+ $(use_enable backup) \
+ $(use_enable calalarm calalarmd) \
+ $(use_with caps libcap) \
+ $(use_with clamav) \
+ $(use_enable nntp) \
+ $(use_enable http) \
+ $(use_with http nghttp2) \
+ $(use_enable replication) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_with ssl openssl) \
+ $(use_enable server) \
+ $(use_enable sieve) \
+ $(use_enable static-libs static) \
+ $(use_with tcpd libwrap) \
+ $(use_enable xapian) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install
+
+ dodoc README*
+ dodoc -r doc
+
+ cp -r contrib tools "${ED}/usr/share/doc/${PF}" || die
+ rm -f doc/text/Makefile* || die
+
+ mv "${ED}"/usr/libexec/{master,cyrusmaster} || die
+
+ insinto /etc
+ newins "${ED}/usr/share/doc/${PF}/doc/examples/cyrus_conf/normal.conf" cyrus.conf
+ newins "${ED}/usr/share/doc/${PF}/doc/examples/imapd_conf/normal.conf" imapd.conf
+
+ sed -i -e '/^configdirectory/s|/var/.*|/var/imap|' \
+ -e '/^partition-default/s|/var/.*|/var/spool/imap|' \
+ -e '/^sievedir/s|/var/.*|/var/imap/sieve|' \
+ "${ED}"/etc/imapd.conf || die
+
+ sed -i -e 's|/var/imap/socket/lmtp|/run/cyrus/socket/lmtp|' \
+ -e 's|/var/imap/socket/notify|/run/cyrus/socket/notify|' \
+ "${ED}"/etc/cyrus.conf || die
+
+ # turn off sieve if not installed
+ if ! use sieve; then
+ sed -i -e "/sieve/s/^/#/" "${ED}/etc/cyrus.conf" || die
+ fi
+
+ # same thing for http(s) as well
+ if ! use http; then
+ sed -i -e "/http/s/^/#/" "${ED}/etc/cyrus.conf" || die
+ fi
+
+ newinitd "${FILESDIR}/cyrus.rc8" cyrus
+ newconfd "${FILESDIR}/cyrus.confd" cyrus
+ newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+ for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+ keepdir "/var/${subdir}"
+ fowners cyrus:mail "/var/${subdir}"
+ fperms 0750 "/var/${subdir}"
+ done
+
+ for subdir in imap/{user,quota,sieve} spool/imap ; do
+ for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+ keepdir "/var/${subdir}/${i}"
+ fowners cyrus:mail "/var/${subdir}/${i}"
+ fperms 0750 "/var/${subdir}/${i}"
+ done
+ done
+}
+
+pkg_preinst() {
+ if ! has_version ${CATEGORY}/${PN} ; then
+ elog "For correct logging add the following to /etc/syslog.conf:"
+ elog " local6.* /var/log/imapd.log"
+ elog " auth.debug /var/log/auth.log"
+ echo
+
+ elog "You have to add user cyrus to the sasldb2. Do this with:"
+ elog " saslpasswd2 cyrus"
+ fi
+}
+
+pkg_postinst() {
+ # do not install server.{key,pem) if they exist
+ if use ssl ; then
+ if [[ ! -f "${ROOT}"/etc/ssl/cyrus/server.key ]]; then
+ install_cert /etc/ssl/cyrus/server
+ chown cyrus:mail "${ROOT}"/etc/ssl/cyrus/server.{key,pem}
+ fi
+ fi
+
+ echo
+ einfo "Please see https://www.cyrusimap.org/imap/download/upgrade.html"
+ einfo "for upgrade instructions."
+ echo
+}