summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2021-12-27 08:34:48 +0300
committerEray Aslan <eras@gentoo.org>2021-12-27 08:34:48 +0300
commit1a1eb2dfdfd41ba2eb9a5416e1b6f445fe00028d (patch)
treee2530bfd32d889bd8ff66b8930c2a58be13d9468 /net-mail
parentdev-python/typing-extensions: Remove old (diff)
downloadgentoo-1a1eb2dfdfd41ba2eb9a5416e1b6f445fe00028d.tar.gz
gentoo-1a1eb2dfdfd41ba2eb9a5416e1b6f445fe00028d.tar.bz2
gentoo-1a1eb2dfdfd41ba2eb9a5416e1b6f445fe00028d.zip
net-mail/mailbase: remove wildcards from mailcap
as noted in mailcap(5): Note that wildcards may only be specified in the subtype (e.g. "*" or "*/*" do not work), and as the entire subtype (e.g. "application/x-*" does not work) wildcards were introduced in the hope that they might be useful for some programs. however, some mailers reportedly error out with: s-nail: $MAILCAPS: /etc/mailcap: skip due to error: invalid MIME type: */* so, just remove */* wildcards from mailcap Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailbase/files/mailcap-r330
-rw-r--r--net-mail/mailbase/mailbase-1.8.ebuild45
2 files changed, 75 insertions, 0 deletions
diff --git a/net-mail/mailbase/files/mailcap-r3 b/net-mail/mailbase/files/mailcap-r3
new file mode 100644
index 000000000000..fe717f34e0b0
--- /dev/null
+++ b/net-mail/mailbase/files/mailcap-r3
@@ -0,0 +1,30 @@
+# Database binding MIME types to programs that can process them.
+# This file is generally used by mail clients to view attachments.
+#
+# Users should add their own rules to their ~/.mailcap file. That file will be
+# processed first before falling back to this one.
+#
+# For more information, see the mailcap(5) man page.
+
+# NB: Do not quote %s. Clients will handle expanding it with proper quoting,
+# so adding quotes ourselves just confuses things.
+
+application/pdf; xdg-open %s; needsterminal
+application/postscript; xdg-open %s; needsterminal
+application/x-info; info --subnodes -o /dev/stdout -f %s 2>/dev/null; copiousoutput; description=GNU Info document
+application/x-gtar; tar tvzf -; print=tar tvzf - | print text/plain:-; copiousoutput
+application/x-tar; tar tvf -; print=tar tvf - | print text/plain:-; copiousoutput
+application/x-troff-man; nroff -mandoc -Tutf8; copiousoutput; print=nroff -mandoc -Tutf8 | print text/plain:-
+# It'd be nice to limit this to compressed formats (e.g. x-*), but the file
+# format doesn't support that, and less has good fallbacks already.
+application/*; less %s; copiousoutput; needsterminal
+
+audio/*; xdg-open %s; needsterminal
+image/*; xdg-open %s; needsterminal
+
+text/html; lynx -dump -assume_charset=%{charset} %s; copiousoutput; description=HTML Text; nametemplate=%s.html
+text/troff; man -l %s; needsterminal; description=Man page
+text/*; less %s; needsterminal
+text/*; gview %s; edit=gvim -f %s; compose=gvim -f %s; test=test "$DISPLAY" != ""
+text/*; view %s; edit=vim %s; compose=vim %s; needsterminal
+text/*; more %s; needsterminal
diff --git a/net-mail/mailbase/mailbase-1.8.ebuild b/net-mail/mailbase/mailbase-1.8.ebuild
new file mode 100644
index 000000000000..699bdc713711
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pam
+
+DESCRIPTION="MTA layout package"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pam"
+
+RDEPEND="
+ acct-group/mail
+ acct-user/mail
+ acct-user/postmaster
+ pam? ( sys-libs/pam )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ newins "${FILESDIR}"/mailcap-r3 mailcap
+ doman "${FILESDIR}"/mailcap.5
+
+ dosym spool/mail /var/mail
+
+ if use pam ; then
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}