summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-03-19 10:55:24 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2020-03-20 03:31:25 -0500
commit2045785e424b288a2beb3d308ad3991f3b64cfa4 (patch)
tree3ed57d442ef79486da6c5cc123200c16f361fd42 /net-mail
parentdev-lang/ocaml: drop to ~hppa (diff)
downloadgentoo-2045785e424b288a2beb3d308ad3991f3b64cfa4.tar.gz
gentoo-2045785e424b288a2beb3d308ad3991f3b64cfa4.tar.bz2
gentoo-2045785e424b288a2beb3d308ad3991f3b64cfa4.zip
www-servers/automx2: Change category to net-mail
Move existing Gentoo package www-servers/automx2 to net-mail/automx2. Reasons for this change are as follows: * Package automx2 replaces package net-mail/automx, which has already been last-rited. * Some developers raised objections against using www-servers/automx2. While automx2 is a web service and hence uses web server technology, it is not a web server in the way www-servers is understood. As per https://devmanual.gentoo.org/ebuild-maintenance/package-moves/index.html all changes are deliberately combined into a single commit to ensure atomicity during the update. Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/15011 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/Manifest2
-rw-r--r--net-mail/automx2/automx2-2019.0.ebuild43
-rw-r--r--net-mail/automx2/automx2-2020.1.ebuild43
-rw-r--r--net-mail/automx2/files/conf20
-rw-r--r--net-mail/automx2/files/confd8
-rw-r--r--net-mail/automx2/files/init26
-rw-r--r--net-mail/automx2/metadata.xml27
7 files changed, 169 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
new file mode 100644
index 000000000000..a8ac298f32c7
--- /dev/null
+++ b/net-mail/automx2/Manifest
@@ -0,0 +1,2 @@
+DIST automx2-2019.0.tar.bz2 46670 BLAKE2B 6f62b4429be8046fce18ccba6827879a99627d8fbe9cf7973d8059e87b4968a280b62d5d005aaed3b0e1074053f4a6355c34f2cdce2f06a9afb14c52b4504fb7 SHA512 e494a48ffd3e6d133a89db5afd1dc75116a8efcc41f0571a24271bcbe6074c86d62184ce00bae9ced888a70be7d20f2a3614f28007d4481537d42c680dca4daa
+DIST automx2-2020.1.tar.bz2 49405 BLAKE2B 2c9b26300e32e613f622e0b3a39b7f408d22e22638d61da3c93f5d448fe3ebb325e9a0004e3351abed2c9e427373c42637e3539831c04cda8e65a4d1bba1773e SHA512 823e569eacedcf49d53f8ed623a75455e715e3d49186179927a0e10d3efe9823c336912789bbf3d7d2f9aba3053b601352c99bda4ffcc9a7b78e412c938cd91f
diff --git a/net-mail/automx2/automx2-2019.0.ebuild b/net-mail/automx2/automx2-2019.0.ebuild
new file mode 100644
index 000000000000..62c3980bd7bf
--- /dev/null
+++ b/net-mail/automx2/automx2-2019.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2
+ >=dev-python/flask-migrate-2.5.2[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+ HTML_DOCS="doc/*.html doc/*.svg"
+ fi
+ sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+ newconfd "${FILESDIR}/confd" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/automx2-2020.1.ebuild b/net-mail/automx2/automx2-2020.1.ebuild
new file mode 100644
index 000000000000..cce12b5bc749
--- /dev/null
+++ b/net-mail/automx2/automx2-2020.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2
+ >=dev-python/flask-migrate-2.5.2[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+ HTML_DOCS="doc/*.html doc/*.svg"
+ fi
+ sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+ newconfd "${FILESDIR}/confd" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/files/conf b/net-mail/automx2/files/conf
new file mode 100644
index 000000000000..ca19e0eebb68
--- /dev/null
+++ b/net-mail/automx2/files/conf
@@ -0,0 +1,20 @@
+[automx2]
+# A typical production setup would use loglevel = WARNING
+loglevel = WARNING
+# Echo SQL commands into log? Used for debugging.
+db_echo = no
+
+# In-memory SQLite database
+#db_uri = sqlite:///:memory:
+
+# SQLite database in a UNIX-like file system
+db_uri = sqlite:////var/lib/automx2/db.sqlite
+
+# MySQL database on a remote server. This example does not use an encrypted
+# connection and is therefore *not* recommended for production use.
+#db_uri = mysql://username:password@server.example.com/db
+
+# Number of proxy servers between automx2 and the client (default: 0).
+# If your logs only show 127.0.0.1 or ::1 as the source IP for incoming
+# connections, proxy_count probably needs to be changed.
+#proxy_count = 1
diff --git a/net-mail/automx2/files/confd b/net-mail/automx2/files/confd
new file mode 100644
index 000000000000..5a58d946aa23
--- /dev/null
+++ b/net-mail/automx2/files/confd
@@ -0,0 +1,8 @@
+# Additional parameters passed to Flask
+#AUTOMX2_ARGS="--host 127.0.0.1 --port 4243"
+
+# Configuration file
+#AUTOMX2_CONF="/etc/automx2.conf"
+
+# Process owner (choose a non-privileged user)
+#AUTOMX2_USER="automx2"
diff --git a/net-mail/automx2/files/init b/net-mail/automx2/files/init
new file mode 100644
index 000000000000..466461a6cd93
--- /dev/null
+++ b/net-mail/automx2/files/init
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+: ${AUTOMX2_CONF:="/etc/${RC_SVCNAME}.conf"}
+: ${AUTOMX2_USER:="automx2"}
+: ${AUTOMX2_ARGS:="--port 4243"}
+
+command="/usr/bin/python"
+command_args="/usr/bin/flask run ${AUTOMX2_ARGS}"
+command_background="true"
+command_user="${AUTOMX2_USER}"
+pidfile="/run/${RC_SVCNAME}.pid"
+required_files="${AUTOMX2_CONF}"
+
+depend() {
+ use logger net
+ before nginx
+}
+
+start_pre() {
+ export AUTOMX2_CONF
+ export EPYTHON="@EPYTHON@"
+ export FLASK_APP="automx2.server:app"
+ export FLASK_ENV="production"
+}
diff --git a/net-mail/automx2/metadata.xml b/net-mail/automx2/metadata.xml
new file mode 100644
index 000000000000..acba6de8fdfb
--- /dev/null
+++ b/net-mail/automx2/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ <description>Proxy</description>
+ </maintainer>
+ <longdescription>
+ automx2 makes configuring a mail account easy. It unites
+ methods for automated mailbox configuration from Apple
+ (mobileconfig), Microsoft (autodiscover) and Mozilla
+ (autoconfig) in one tool.
+ </longdescription>
+ <upstream>
+ <doc>https://gitlab.com/automx/automx2/blob/master/doc/automx2.adoc</doc>
+ <maintainer>
+ <email>automx2@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <remote-id type="gitlab">automx/automx2</remote-id>
+ </upstream>
+</pkgmetadata>