summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-23 15:09:21 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-23 15:09:21 +0100
commit5b6a443003a74df1ac2d620fd37de88316af6646 (patch)
treecb581142b65e3a163b45c2e0d8173a23db377182 /net-mail
parentnet-dns/bind-tools: Version bump (v9.16.0) (diff)
downloadgentoo-5b6a443003a74df1ac2d620fd37de88316af6646.tar.gz
gentoo-5b6a443003a74df1ac2d620fd37de88316af6646.tar.bz2
gentoo-5b6a443003a74df1ac2d620fd37de88316af6646.zip
net-mail/mailutils: Fix building with GCC 10
Bug: https://bugs.gentoo.org/709274 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailutils/files/mailutils-3.4-fno-common.patch11
-rw-r--r--net-mail/mailutils/files/mailutils-3.8-fno-common.patch22
-rw-r--r--net-mail/mailutils/mailutils-3.4-r3.ebuild6
-rw-r--r--net-mail/mailutils/mailutils-3.7.ebuild7
-rw-r--r--net-mail/mailutils/mailutils-3.8.ebuild9
5 files changed, 47 insertions, 8 deletions
diff --git a/net-mail/mailutils/files/mailutils-3.4-fno-common.patch b/net-mail/mailutils/files/mailutils-3.4-fno-common.patch
new file mode 100644
index 000000000000..d981ae6891a8
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.4-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/lib/tcpwrap.h
++++ b/lib/tcpwrap.h
+@@ -18,7 +18,7 @@
+ #include <mailutils/types.h>
+
+ extern int mu_tcp_wrapper_enable;
+-const char *mu_tcp_wrapper_daemon;
++extern const char *mu_tcp_wrapper_daemon;
+ extern int mu_tcpwrapper_access (int fd);
+ extern void mu_tcpwrapper_cfg_init (void);
+ extern int mu_tcp_wrapper_prefork (int fd,
diff --git a/net-mail/mailutils/files/mailutils-3.8-fno-common.patch b/net-mail/mailutils/files/mailutils-3.8-fno-common.patch
new file mode 100644
index 000000000000..c7aa72df10e8
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.8-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/imap4d/imap4d.h
++++ b/imap4d/imap4d.h
+@@ -229,8 +229,6 @@ extern struct mu_tls_config global_tls_conf;
+ extern int test_mode;
+ extern int silent_expunge;
+
+-int tls_available;
+-
+ /* Input functions */
+ extern mu_stream_t iostream;
+ extern int io_untagged_response (int, const char *, ...) MU_PRINTFLIKE(2,3);
+--- a/lib/tcpwrap.h
++++ b/lib/tcpwrap.h
+@@ -17,7 +17,7 @@
+ #include <mailutils/types.h>
+
+ extern int mu_tcp_wrapper_enable;
+-const char *mu_tcp_wrapper_daemon;
++extern const char *mu_tcp_wrapper_daemon;
+ extern int mu_tcpwrapper_access (int fd);
+ extern void mu_tcpwrapper_cfg_init (void);
+ extern int mu_tcp_wrapper_prefork (int fd,
diff --git a/net-mail/mailutils/mailutils-3.4-r3.ebuild b/net-mail/mailutils/mailutils-3.4-r3.ebuild
index 509c103ba016..c3edc69e6726 100644
--- a/net-mail/mailutils/mailutils-3.4-r3.ebuild
+++ b/net-mail/mailutils/mailutils-3.4-r3.ebuild
@@ -56,8 +56,10 @@ pkg_setup() {
src_prepare() {
# Disable bytecompilation of Python modules.
echo "#!/bin/sh" > build-aux/py-compile
- eapply "${FILESDIR}/${P}-MH-testsuite.patch" \
- "${FILESDIR}/${P}-fix-endianness.patch"
+ eapply \
+ "${FILESDIR}"/${P}-MH-testsuite.patch \
+ "${FILESDIR}"/${P}-fix-endianness.patch \
+ "${FILESDIR}"/${PN}-3.4-fno-common.patch
# add missing tests so that make check doesn't fail
cp "${FILESDIR}"/{hdr,nohdr,twomsg,weed}.at "${S}"/readmsg/tests || die
if use mysql; then
diff --git a/net-mail/mailutils/mailutils-3.7.ebuild b/net-mail/mailutils/mailutils-3.7.ebuild
index f565cbc30a7b..344b83bfb471 100644
--- a/net-mail/mailutils/mailutils-3.7.ebuild
+++ b/net-mail/mailutils/mailutils-3.7.ebuild
@@ -51,8 +51,11 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
servers? ( tcpd ldap )"
DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
-PATCHES=( "${FILESDIR}/${PN}-3.5-add-include.patch" \
- "${FILESDIR}/${PN}-3.6-underlinking.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-add-include.patch
+ "${FILESDIR}"/${PN}-3.6-underlinking.patch
+ "${FILESDIR}"/${PN}-3.8-fno-common.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
diff --git a/net-mail/mailutils/mailutils-3.8.ebuild b/net-mail/mailutils/mailutils-3.8.ebuild
index a0eac2746bf2..010b4f58138b 100644
--- a/net-mail/mailutils/mailutils-3.8.ebuild
+++ b/net-mail/mailutils/mailutils-3.8.ebuild
@@ -52,10 +52,11 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
PATCHES=(
- "${FILESDIR}/${PN}-3.5-add-include.patch" \
- "${FILESDIR}/${PN}-3.6-underlinking.patch" \
- "${FILESDIR}/${PN}-3.8-fix-tests.patch" \
- )
+ "${FILESDIR}"/${PN}-3.5-add-include.patch
+ "${FILESDIR}"/${PN}-3.6-underlinking.patch
+ "${FILESDIR}"/${PN}-3.8-fix-tests.patch
+ "${FILESDIR}"/${PN}-3.8-fno-common.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup