summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-12-06 19:34:07 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-12-09 01:40:35 -0500
commit6f2a914378e0023eccccdc9a4fbf280419fac469 (patch)
tree584d564ef8be1f88346cb0f1dc4def0f17972e6b /net-mail
parentapp-antivirus/fangfrisch: Remove obsolete ebuild (diff)
downloadgentoo-6f2a914378e0023eccccdc9a4fbf280419fac469.tar.gz
gentoo-6f2a914378e0023eccccdc9a4fbf280419fac469.tar.bz2
gentoo-6f2a914378e0023eccccdc9a4fbf280419fac469.zip
net-mail/automx2: Remove obsolete ebuild
automx2-2021.5.ebuild has been stabilised. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/23201 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2021.4.ebuild49
-rw-r--r--net-mail/automx2/files/init26
3 files changed, 0 insertions, 76 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index 72263a76bd5a..75113df8eefc 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1,2 +1 @@
-DIST automx2-2021.4.tar.gz 170903 BLAKE2B 9c8e9bc95eeac9a8a59430248d532d540e70a40c4d61f006d5d2649198e856e4b404ed75df745cfb06887c58049a9a233a597059e2f2971bf9f1c8ce65a34f3d SHA512 f306bfdca10dc884bef404e5ff24181dc9adfb8514fd0e0d984bac84ca4996f0978eda7161be46f1b3d93a9c0e61aaabdfb4b2886012570a51ad0aaf2286dd2c
DIST automx2-2021.5.tar.gz 172317 BLAKE2B 501dea5561d780fed538676e41dac46da01bae24388f477afa66e1b27e8a271e48bd6bddc8f9a4e0f5e7b3eb9f58fca9a9b2adaf78de2f7cd2feacfc8f85c9a4 SHA512 00281f32df6b117690d9780b8a587907518e2485dc37450765c3f35acb92a27da73ecd4e35cd05e0a5307d179ba3edaa1dec80900a059c975589ae904456c565
diff --git a/net-mail/automx2/automx2-2021.4.ebuild b/net-mail/automx2/automx2-2021.4.ebuild
deleted file mode 100644
index a5638470334b..000000000000
--- a/net-mail/automx2/automx2-2021.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Email client autoconfiguration service"
-HOMEPAGE="https://automx.org/"
-SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc"
-
-BDEPEND="acct-user/automx2"
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-migrate[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/ldap3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- sed -i -e "/('scripts'/d" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- export AUTOMX2_CONF="tests/unittest.conf"
- ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
- HTML_DOCS="doc/*.html doc/*.svg"
- fi
- sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
- newconfd "${FILESDIR}/confd" "${PN}"
- insinto /etc
- newins "${FILESDIR}/conf" "${PN}.conf"
- distutils-r1_python_install_all
-}
diff --git a/net-mail/automx2/files/init b/net-mail/automx2/files/init
deleted file mode 100644
index 466461a6cd93..000000000000
--- a/net-mail/automx2/files/init
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-: ${AUTOMX2_CONF:="/etc/${RC_SVCNAME}.conf"}
-: ${AUTOMX2_USER:="automx2"}
-: ${AUTOMX2_ARGS:="--port 4243"}
-
-command="/usr/bin/python"
-command_args="/usr/bin/flask run ${AUTOMX2_ARGS}"
-command_background="true"
-command_user="${AUTOMX2_USER}"
-pidfile="/run/${RC_SVCNAME}.pid"
-required_files="${AUTOMX2_CONF}"
-
-depend() {
- use logger net
- before nginx
-}
-
-start_pre() {
- export AUTOMX2_CONF
- export EPYTHON="@EPYTHON@"
- export FLASK_APP="automx2.server:app"
- export FLASK_ENV="production"
-}