summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-01-09 17:05:48 +0100
committerSam James <sam@gentoo.org>2021-01-09 18:43:10 +0000
commitaa81c631181e5c98ba02ea29190beed8d5aea5e8 (patch)
tree27397391c4f68ff3898f9f41da744ac229b36933 /net-mail
parentsys-kernel/gentoo-sources: Linux patch 5.10.6 and add support for shiftfs (diff)
downloadgentoo-aa81c631181e5c98ba02ea29190beed8d5aea5e8.tar.gz
gentoo-aa81c631181e5c98ba02ea29190beed8d5aea5e8.tar.bz2
gentoo-aa81c631181e5c98ba02ea29190beed8d5aea5e8.zip
net-mail/automx2: Bump to version 2021.0
Upstream bugfix release. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/19005 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2021.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index dd40d7416b0a..446ac1ad2ef4 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1,2 +1,3 @@
DIST automx2-2020.1.tar.bz2 49405 BLAKE2B 2c9b26300e32e613f622e0b3a39b7f408d22e22638d61da3c93f5d448fe3ebb325e9a0004e3351abed2c9e427373c42637e3539831c04cda8e65a4d1bba1773e SHA512 823e569eacedcf49d53f8ed623a75455e715e3d49186179927a0e10d3efe9823c336912789bbf3d7d2f9aba3053b601352c99bda4ffcc9a7b78e412c938cd91f
DIST automx2-2020.2.tar.bz2 50740 BLAKE2B 394d26a06d23efe18a3c147f89660a9dbdde7edba078fd361f188738fdc28d36122aa8182e965bb8e3d69d4cbcd3cb784bc7722dd382d1fbee36213459b91fa1 SHA512 dce790c754fd089a15d0baf023a9cb2e04ebb42a4558fc91b06c2de2105f3e00f3675a555739ff1bc35166c98f6cecec62c95f18f4144e88ac6024eaa6f39abe
+DIST automx2-2021.0.tar.bz2 50912 BLAKE2B de6fe1ea6dd5223518683220ff1210baa68c30e67f9cd3aac1a965759cb0f72c1119427043579fb805f68457ac4062000cf8066b6fa6d7106f3ee7f777346a57 SHA512 3ca632cc71d64a9d9d434a7109ab0f55e23e3babb6c1734689f89e5a83c9daa6666af9ce09cb5a0c14256bd6e19f6c5339bd3b3398db7b2d70ff3c6114ddb428
diff --git a/net-mail/automx2/automx2-2021.0.ebuild b/net-mail/automx2/automx2-2021.0.ebuild
new file mode 100644
index 000000000000..427c85ab79c3
--- /dev/null
+++ b/net-mail/automx2/automx2-2021.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+ HTML_DOCS="doc/*.html doc/*.svg"
+ fi
+ sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+ newconfd "${FILESDIR}/confd" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}