summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-04-07 14:39:16 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-04-07 14:39:32 +0200
commite4daeee8a489160ff934cc5eae72565e9a4118d6 (patch)
tree8e538f5a192a5ff2cd2f97305538cc7a8ccaac10 /net-mail
parentapp-portage/nattka: Remove old (diff)
downloadgentoo-e4daeee8a489160ff934cc5eae72565e9a4118d6.tar.gz
gentoo-e4daeee8a489160ff934cc5eae72565e9a4118d6.tar.bz2
gentoo-e4daeee8a489160ff934cc5eae72565e9a4118d6.zip
net-mail/fetchmail: 6.4.3 bump
Now requires OpenSSL 1.1.1 (or other compatible lib with TLS v1.3) Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.3.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 3e2fbd21e1b3..204b8885d0b6 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.1.tar.xz 1257488 BLAKE2B 101a7c2da7374eb180a4afd576bd436e074241b2071107676330e1773a33035a20f406e3dd1e0f1a280887b4556f68fc6c87be1eabf9b7e3003dff4cc740eebb SHA512 940b8df52f963f71537962ebe2b2cb88298fd2b54ca79932e5c974abe850f0b59cdc4919d606ee4f210e82d1e0a6f090ea87f1d3bdea18b531d4fbb36f7f9ea0
DIST fetchmail-6.4.2.tar.xz 1261472 BLAKE2B 11d00eeef39ceda6374a66909e2f8815c2f22ac7321ccd47eff8387e71056a8094c616f903ac0502a0a0a18929c11d4102d116229f6f875f413e026735040190 SHA512 8ec62a5df81b9b8c5e5479d35a10aded22aca74f671cded339dc7ae1c78d8a8638dfe4f04be35334184b5b27f3fb857402dc5b587cca8ede3f5b9b268b37edc1
+DIST fetchmail-6.4.3.tar.xz 1261452 BLAKE2B a52adb55153e8b9765cde8fe232a34cdea005d69105337336282e5d16fdd87eb44dde166f3c0a3ac869bce5e53eff2b49db38e80be66bc8bddad9d50ea456df6 SHA512 090647f4c6102048a882ce48d4fd57fe2a02f43ab2cbef9ef6a8874c3e075295f0dc01493deab37e2d47d98f337560c465a37397fd6d9002fa280d88d57564a7
diff --git a/net-mail/fetchmail/fetchmail-6.4.3.ebuild b/net-mail/fetchmail/fetchmail-6.4.3.ebuild
new file mode 100644
index 000000000000..93531029a5b4
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 systemd toolchain-funcs autotools
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks libressl"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.1.1:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ kerberos? (
+ virtual/krb5
+ !libressl? ( >=dev-libs/openssl-1.0.2:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}