summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-05-22 08:05:41 +0200
committerJeroen Roovers <jer@gentoo.org>2019-05-22 08:05:59 +0200
commit36f6d7b98ece51c3607837fc482687e6c7b0ea87 (patch)
tree3cf5ae3b0927997abfa52adb37a375d29261d5c8 /net-misc/apt-cacher-ng
parentdev-ruby/podcast: add ruby26 (diff)
downloadgentoo-36f6d7b98ece51c3607837fc482687e6c7b0ea87.tar.gz
gentoo-36f6d7b98ece51c3607837fc482687e6c7b0ea87.tar.bz2
gentoo-36f6d7b98ece51c3607837fc482687e6c7b0ea87.zip
net-misc/apt-cacher-ng: Version 3.2_p2
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/apt-cacher-ng')
-rw-r--r--net-misc/apt-cacher-ng/Manifest1
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-3.2_p2.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/net-misc/apt-cacher-ng/Manifest b/net-misc/apt-cacher-ng/Manifest
index 21498d91e43c..75ce6eb025d1 100644
--- a/net-misc/apt-cacher-ng/Manifest
+++ b/net-misc/apt-cacher-ng/Manifest
@@ -1 +1,2 @@
+DIST apt-cacher-ng_3.2-2.debian.tar.xz 48740 BLAKE2B ab2f6349aa66f39b778f346827767514761eeb8977d69a55940d7dd4c738b54ba20a9725387f769edf2cce454588746bc10361d4a174ed380a431a6ecf6b096d SHA512 e5299432b91cdf6cb51934fcc440e62d24c1b4849ad3a0c3a5e47a256c874ebb85c7ba56b97da27c2e03e0621b4ae42b69592440d521e718f4f8725a6ff379d4
DIST apt-cacher-ng_3.2.orig.tar.xz 319036 BLAKE2B 576fc7a409556d34ee702edd57527c9c35eb033d0e8c8ea4f7b8a8a2dae86f75cd1ca3a7fb0e02845e70d6f8715692b638ff9d574ce1664b67fec9247b60fbc0 SHA512 7dfee4a8f38e7c5251c761a5faae063926c5001fe0b97136d938cdbff907e97fb0a20b89dcf685645a518e92be04fe5660d840e738960b4465408f04fe532cae
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-3.2_p2.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-3.2_p2.ebuild
new file mode 100644
index 000000000000..97f303d5634c
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-3.2_p2.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils toolchain-funcs user
+
+DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
+HOMEPAGE="
+ https://www.unix-ag.uni-kl.de/~bloch/acng/
+ https://packages.qa.debian.org/a/apt-cacher-ng.html
+"
+LICENSE="BSD-4 ZLIB public-domain"
+SLOT="0"
+SRC_URI="
+ mirror://debian/pool/main/a/${PN}/${PN}_${PV/_*}.orig.tar.xz
+ mirror://debian/pool/main/a/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse systemd tcpd"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/openssl:*
+ sys-libs/zlib
+ systemd? (
+ sys-apps/systemd
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/cmake
+ >sys-devel/gcc-4.8
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/perl
+ fuse? ( sys-fs/fuse )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+PATCHES=(
+ "${WORKDIR}"/debian/patches/debian-changes
+)
+S=${WORKDIR}/${P/_*}
+
+pkg_pretend() {
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ fi
+}
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure(){
+ mycmakeargs=( "-DCMAKE_INSTALL_PREFIX=/usr" )
+ if use fuse; then
+ mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
+ else
+ mycmakeargs+=( "-DHAVE_FUSE_25=no" )
+ fi
+ if use tcpd; then
+ mycmakeargs=( "-DHAVE_LIBWRAP=yes" )
+ else
+ mycmakeargs=( "-DHAVE_LIBWRAP=no" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ pushd ${BUILD_DIR} || die
+ dosbin ${PN}
+ if use fuse; then
+ dobin acngfs
+ fi
+ popd
+
+ newinitd "${FILESDIR}"/initd-r1 ${PN}
+ newconfd "${FILESDIR}"/confd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN}
+
+ doman doc/man/${PN}*
+ if use fuse; then
+ doman doc/man/acngfs*
+ fi
+
+ # Documentation
+ dodoc doc/README TODO VERSION INSTALL ChangeLog
+ if use doc; then
+ dodoc doc/*.pdf
+
+ docinto html
+ dodoc doc/html/*
+
+ find conf -name '*.gz' -exec gzip -d {} \; || die
+ docinto examples/conf
+ dodoc conf/*
+ fi
+
+ # perl daily cron script
+ dosbin scripts/expire-caller.pl
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN}
+
+ # default configuration
+ insinto /etc/${PN}
+ newins "${BUILD_DIR}"/conf/acng.conf ${PN}.conf
+ doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
+
+ keepdir /var/log/${PN}
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ fowners -R ${PN}:${PN} \
+ /etc/${PN} \
+ /var/log/${PN}
+}