summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-08 18:09:43 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-08 18:12:57 +0100
commit7358182a560ec94119f2842a9f761c5772429538 (patch)
tree7ed6fc123b9b0ca670a06f8a6702a70cd025ce8c /net-misc/apt-cacher-ng
parentsys-kernel/gentoo-sources: Linux patch 4.9.61 (diff)
downloadgentoo-7358182a560ec94119f2842a9f761c5772429538.tar.gz
gentoo-7358182a560ec94119f2842a9f761c5772429538.tar.bz2
gentoo-7358182a560ec94119f2842a9f761c5772429538.zip
net-misc/apt-cacher-ng: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'net-misc/apt-cacher-ng')
-rw-r--r--net-misc/apt-cacher-ng/Manifest1
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-3.1.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-misc/apt-cacher-ng/Manifest b/net-misc/apt-cacher-ng/Manifest
index c3d33ccff0f6..2321e4543447 100644
--- a/net-misc/apt-cacher-ng/Manifest
+++ b/net-misc/apt-cacher-ng/Manifest
@@ -1 +1,2 @@
+DIST apt-cacher-ng_3.1.orig.tar.xz 319308 SHA256 21319a5f517f8de242701e5e66ab4233635e6c9479a12df86be16f705e6c0c5d SHA512 daebbf2fa6e140903eb6ddebcc62a4333486f2fa29a951724d316e4376b602e265094c42c9ffa5ba1f54aa93b1599d65c5c1bede39e088e9a52e4019276362fd WHIRLPOOL 76f994aa24a803fff7a86504b04abc725d8632dc5d9117354269c90b08ed26054b050a2a5d0f14d693c80077a991efbe7c171c6a966cc5f9c055e4aafdda8dd2
DIST apt-cacher-ng_3.orig.tar.xz 319996 SHA256 e5b435007ec13fafcebeef65a3a8ec4210853e339efeb98ea79d1a3557f63611 SHA512 4eb520d724c1397b9deefe8dc1b0af81f2151e50d1cabfc2480f040233ae1ee95434d0dcf2b4db8aec918204ae676a49e19e3c885674c7fb389972c2da64c3d4 WHIRLPOOL 261ae398d476498d74b22af91bf9e824b5b51f597eb010677d962e2f8a6327d9c0b3fa71211d293e6d98c8b11dcdb1edae91c97618679cfb185c87a2c63f5982
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-3.1.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-3.1.ebuild
new file mode 100644
index 000000000000..092180f5b76f
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-3.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils eutils toolchain-funcs user
+
+DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
+HOMEPAGE="
+ https://www.unix-ag.uni-kl.de/~bloch/acng/
+ https://packages.qa.debian.org/a/apt-cacher-ng.html
+"
+LICENSE="BSD-4 ZLIB public-domain"
+SLOT="0"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse systemd tcpd"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/openssl:*
+ sys-libs/zlib
+ systemd? (
+ sys-apps/systemd
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/cmake
+ >sys-devel/gcc-4.8
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/perl
+ fuse? ( sys-fs/fuse )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+S=${WORKDIR}/${P/_}
+
+pkg_pretend() {
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ fi
+}
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure(){
+ mycmakeargs=( "-DCMAKE_INSTALL_PREFIX=/usr" )
+ if use fuse; then
+ mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
+ else
+ mycmakeargs+=( "-DHAVE_FUSE_25=no" )
+ fi
+ if use tcpd; then
+ mycmakeargs=( "-DHAVE_LIBWRAP=yes" )
+ else
+ mycmakeargs=( "-DHAVE_LIBWRAP=no" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ pushd ${CMAKE_BUILD_DIR}
+ dosbin ${PN}
+ if use fuse; then
+ dobin acngfs
+ fi
+ popd
+
+ newinitd "${FILESDIR}"/initd-r1 ${PN}
+ newconfd "${FILESDIR}"/confd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN}
+
+ doman doc/man/${PN}*
+ if use fuse; then
+ doman doc/man/acngfs*
+ fi
+
+ # Documentation
+ dodoc doc/README TODO VERSION INSTALL ChangeLog
+ if use doc; then
+ dodoc doc/*.pdf
+ dohtml doc/html/*
+ docinto examples/conf
+ dodoc conf/*
+ fi
+
+ # perl daily cron script
+ dosbin scripts/expire-caller.pl
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN}
+
+ # default configuration
+ insinto /etc/${PN}
+ newins "${CMAKE_BUILD_DIR}"/conf/acng.conf ${PN}.conf
+ doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
+
+ keepdir /var/log/${PN}
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ fowners -R ${PN}:${PN} \
+ /etc/${PN} \
+ /var/log/${PN}
+}