summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2019-11-20 13:29:57 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-01-23 19:27:02 +0200
commitb17e10262c8ad3ce8d277cca58e2175e0568f38d (patch)
tree6424db77143c01c188260e561cb29e70a9d548fd /net-misc/asterisk-g729
parentnet-misc/asterisk-g729: take ownership. (diff)
downloadgentoo-b17e10262c8ad3ce8d277cca58e2175e0568f38d.tar.gz
gentoo-b17e10262c8ad3ce8d277cca58e2175e0568f38d.tar.bz2
gentoo-b17e10262c8ad3ce8d277cca58e2175e0568f38d.zip
net-misc/asterisk-g729: version bump to accomodate asterisk 13.
This includes: version bump to EAPI=7. Added -* to keywods (Downloads only available for x86 and amd64) All http:// to https:// Update homepage to avoid redirect (Digium vs Sangoma). Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/13718 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/asterisk-g729')
-rw-r--r--net-misc/asterisk-g729/Manifest2
-rw-r--r--net-misc/asterisk-g729/asterisk-g729-13.0.3.1.9.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/asterisk-g729/Manifest b/net-misc/asterisk-g729/Manifest
index b5e1af58070a..f138f2d5d372 100644
--- a/net-misc/asterisk-g729/Manifest
+++ b/net-misc/asterisk-g729/Manifest
@@ -4,3 +4,5 @@ DIST astregister-x86_32 2103608 BLAKE2B 7fdf1c196152612cd28cfe7bf832dedb625b392f
DIST astregister-x86_64 2193440 BLAKE2B 9c9ac2343f5d7291251b9ceaa00fc4f8e4c39673e8d4854f8743beee5c86bbbc14c802c34ff26aa8412f1219113edeab7cb3b7adb94086c2f63724095d9f1fc5 SHA512 9302a7ead6bedd6683bcd0da92b7a7ca54fdb975784ef1783aa99f2bb26424dbb77b4c0fa6b809ae6e6ad839807feb055bee5c03a38292737412aa1c3d7df4e4
DIST codec_g729a-11.0_3.1.9-x86_32.tar.gz 411132 BLAKE2B 6325763e27c25ab101ec825f08e8ba86a1b42dac1e75e792dfd1467a03909523097a6cb5c92233e391b293069e7bed7d23cd955329653d0730f529a6b5a1495f SHA512 3426e0ce15cba5866c1ef8f3c692237f6910ebde5740cacdf27e04f110caf7f289834eb8dc793dd4fa50ec17854a2ebad19764d9c485221e0237ac207ccff991
DIST codec_g729a-11.0_3.1.9-x86_64.tar.gz 478377 BLAKE2B 409cdd436b0cf11c8d68372b1b22f29ed6e2d9f01d77ca8494415c29e89e88472c126461e9d124661dbd4ef26725301cbc3bb859884ae02592ad583a37608896 SHA512 f97972e4afac2897162cfce7c49423a36d313801246238e3923993e04a2add020028a509c11cb1f4f39ec612c4243007fe564438cf82e1c71543a44bf0bbd2c8
+DIST codec_g729a-13.0_3.1.9-x86_32.tar.gz 411156 BLAKE2B 179c77d32d1f8ac3314813a1d2ce51cee1cb7b9c1b9f5e8e78c4ed1169c0719f893c55c4fe890fb657196a37c5a4779164924a8696817ba7bbe6f17146286b82 SHA512 9b064b3db3c40f900b88937efde1605dfb67316d92adc3774b4e3322e9bc5042e6670a2d385b6487a8980620eb92c8564b4fd3535810bab117f53b2762e8ca68
+DIST codec_g729a-13.0_3.1.9-x86_64.tar.gz 478364 BLAKE2B 49136479e1bd139fcb22130868575d5be7d6784081307679cfeee16951f6a303b5328a62c23a0ade506f2df0527b275bd198560dacd59ba5b9ba237095622778 SHA512 5fa2dca977ca1dcbf3019fc86c3edc91fd561c814bfa9a5202680b7a581f03faa1705a4392a70409f9cd30a4379691b609f0f572030972cbe432cad435314951
diff --git a/net-misc/asterisk-g729/asterisk-g729-13.0.3.1.9.ebuild b/net-misc/asterisk-g729/asterisk-g729-13.0.3.1.9.ebuild
new file mode 100644
index 000000000000..8bd7baccb9d6
--- /dev/null
+++ b/net-misc/asterisk-g729/asterisk-g729-13.0.3.1.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib
+
+DESCRIPTION="G.729 codec and supporting files for asterisk"
+HOMEPAGE="https://www.sangoma.com/asterisk/software/g729-codec/"
+
+AST_PV="$(ver_cut 1-2)"
+MY_PV="$(ver_rs 2 _)"
+
+SRC_URI="x86? (
+ https://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-x86_32.tar.gz
+ https://downloads.digium.com/pub/register/x86-32/register -> astregister-x86_32
+ https://downloads.digium.com/pub/register/x86-32/asthostid -> asthostid-x86_32
+)
+amd64? (
+ https://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-x86_64.tar.gz
+ https://downloads.digium.com/pub/register/x86-64/register -> astregister-x86_64
+ https://downloads.digium.com/pub/register/x86-64/asthostid -> asthostid-x86_64
+)"
+
+LICENSE="Digium"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=net-misc/asterisk-$(ver_cut 1)*"
+
+RESTRICT="mirror strip"
+
+QA_FLAGS_IGNORED_amd64="usr/lib64/asterisk/modules/codec_g729a.so"
+QA_FLAGS_IGNORED_x86="usr/lib/asterisk/modules/codec_g729a.so"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local dfile
+
+ for dfile in ${A}; do
+ [[ "${dfile}" = *.tar.gz ]] && unpack "${dfile}"
+ cp "${DISTDIR}/${dfile}" "${WORKDIR}/" || die "Error copying ${dfile} to ${WORKDIR}"
+ done
+}
+
+src_install() {
+ local binsuffix
+
+ if use x86; then
+ binsuffix=x86_32
+ elif use amd64; then
+ binsuffix=x86_64
+ else
+ die "Ebuild only functions for x86 and amd64."
+ fi
+
+ newsbin astregister-${binsuffix} astregister
+ newsbin asthostid-${binsuffix} asthostid
+
+ dodoc codec_g729a-${MY_PV}-${binsuffix}/README
+ insinto usr/$(get_libdir)/asterisk/modules/
+ doins "codec_g729a-${MY_PV}-${binsuffix}/codec_g729a.so"
+}
+
+pkg_postinst() {
+ einfo "Please note that Digium's register utility has been installed as astregister"
+}