summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-12-23 21:20:15 +0200
committerMarek Szuba <marecki@gentoo.org>2020-12-23 21:31:15 +0000
commita3cafd53b24a1a01b8ef2add7e91896e80c16ca3 (patch)
tree5b25bd23314fa7ef44f553a10091637ab2c2f5b9 /net-misc/asterisk
parentnet-misc/asterisk: adjust lua mask to specific revision. (diff)
downloadgentoo-a3cafd53b24a1a01b8ef2add7e91896e80c16ca3.tar.gz
gentoo-a3cafd53b24a1a01b8ef2add7e91896e80c16ca3.tar.bz2
gentoo-a3cafd53b24a1a01b8ef2add7e91896e80c16ca3.zip
net-misc/asterisk: bumps for SLOTed lua and func_lock races.
1. Alternate patch for LUA, also upstream: https://gerrit.asterisk.org/c/asterisk/+/15234 2. Include LOCK(),TRYLOCK and UNLOCK() fixes: https://gerrit.asterisk.org/c/asterisk/+/15227 Closes: https://github.com/gentoo/gentoo/pull/18410 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc/asterisk')
-rw-r--r--net-misc/asterisk/asterisk-13.38.1-r1.ebuild308
-rw-r--r--net-misc/asterisk/asterisk-16.15.1-r1.ebuild (renamed from net-misc/asterisk/asterisk-16.14.0-r100.ebuild)8
-rw-r--r--net-misc/asterisk/files/asterisk-13.38.1-r1-autoconf-lua-version.patch56
-rw-r--r--net-misc/asterisk/files/asterisk-13.38.1-r1-func_lock-fix-races.patch291
-rw-r--r--net-misc/asterisk/files/asterisk-16.14.0-autoconf-lua-version.patch31
5 files changed, 660 insertions, 34 deletions
diff --git a/net-misc/asterisk/asterisk-13.38.1-r1.ebuild b/net-misc/asterisk/asterisk-13.38.1-r1.ebuild
new file mode 100644
index 000000000000..7fd03e6fd84c
--- /dev/null
+++ b/net-misc/asterisk/asterisk-13.38.1-r1.ebuild
@@ -0,0 +1,308 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit autotools linux-info lua-single systemd
+
+DESCRIPTION="Asterisk: A Modular Open Source PBX System"
+HOMEPAGE="https://www.asterisk.org/"
+SRC_URI="https://downloads.asterisk.org/pub/telephony/asterisk/releases/${P}.tar.gz
+ https://downloads.uls.co.za/gentoo/asterisk/gentoo-asterisk-patchset-4.08.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE_VOICEMAIL_STORAGE="
+ +voicemail_storage_file
+ voicemail_storage_odbc
+ voicemail_storage_imap
+"
+IUSE="${IUSE_VOICEMAIL_STORAGE} alsa bluetooth calendar +caps cluster curl dahdi debug doc freetds gtalk http iconv ilbc ldap libressl lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog vorbis xmpp"
+IUSE_EXPAND="VOICEMAIL_STORAGE"
+REQUIRED_USE="gtalk? ( xmpp )
+ lua? ( ${LUA_REQUIRED_USE} )
+ ^^ ( ${IUSE_VOICEMAIL_STORAGE/+/} )
+ voicemail_storage_odbc? ( odbc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-historic-no-var-run-install.patch"
+ "${FILESDIR}/${PN}-13.38.1-r1-autoconf-lua-version.patch"
+ "${FILESDIR}/${PN}-13.38.1-r1-func_lock-fix-races.patch"
+)
+
+DEPEND="acct-user/asterisk
+ acct-group/asterisk
+ dev-db/sqlite:3
+ dev-libs/popt
+ dev-libs/jansson
+ dev-libs/libedit
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ bluetooth? ( net-wireless/bluez:= )
+ calendar? (
+ net-libs/neon:=
+ dev-libs/libical:=
+ dev-libs/iksemel
+ )
+ caps? ( sys-libs/libcap )
+ cluster? ( sys-cluster/corosync )
+ curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
+ freetds? ( dev-db/freetds )
+ gtalk? ( dev-libs/iksemel )
+ http? ( dev-libs/gmime:2.6 )
+ iconv? ( virtual/libiconv )
+ ilbc? ( media-libs/libilbc )
+ ldap? ( net-nds/openldap )
+ lua? ( ${LUA_DEPS} )
+ mysql? ( dev-db/mysql-connector-c:= )
+ newt? ( dev-libs/newt )
+ odbc? ( dev-db/unixODBC )
+ pjproject? ( net-libs/pjproject )
+ portaudio? ( media-libs/portaudio )
+ postgres? ( dev-db/postgresql:* )
+ radius? ( net-dialup/freeradius-client )
+ snmp? ( net-analyzer/net-snmp:= )
+ span? ( media-libs/spandsp )
+ speex? (
+ media-libs/libogg
+ media-libs/speex
+ media-libs/speexdsp
+ )
+ srtp? ( net-libs/libsrtp:0 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ voicemail_storage_imap? ( virtual/imap-c-client )
+ xmpp? ( dev-libs/iksemel )
+"
+
+RDEPEND="${DEPEND}
+ net-misc/asterisk-core-sounds
+ net-misc/asterisk-extra-sounds
+ net-misc/asterisk-moh-opsound
+ selinux? ( sec-policy/selinux-asterisk )
+ syslog? ( virtual/logger )"
+
+BDEPEND="virtual/pkgconfig"
+
+QA_DT_NEEDED="/usr/lib.*/libasteriskssl[.]so[.][0-9]\+"
+
+pkg_setup() {
+ CONFIG_CHECK="~!NF_CONNTRACK_SIP"
+ local WARNING_NF_CONNTRACK_SIP="SIP (NAT) connection tracking is enabled. Some users
+ have reported that this module dropped critical SIP packets in their deployments. You
+ may want to disable it if you see such problems."
+ check_extra_config
+
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+}
+
+src_configure() {
+ local vmst
+
+ econf \
+ LUA_VERSION="${ELUA#lua}" \
+ --libdir="/usr/$(get_libdir)" \
+ --localstatedir="/var" \
+ --with-crypto \
+ --with-gsm=internal \
+ --with-popt \
+ --with-z \
+ --with-libedit \
+ $(use_with caps cap) \
+ $(use_with lua lua) \
+ $(use_with http gmime) \
+ $(use_with newt) \
+ $(use_with pjproject) \
+ $(use_with portaudio) \
+ $(use_with ssl)
+
+ _menuselect() {
+ menuselect/menuselect "$@" || die "menuselect $* failed."
+ }
+
+ _use_select() {
+ local state=$(usex "$1" enable disable)
+ shift # remove use from parameters
+
+ while [[ -n $1 ]]; do
+ _menuselect --${state} "$1" menuselect.makeopts
+ shift
+ done
+ }
+
+ # Blank out sounds/sounds.xml file to prevent
+ # asterisk from installing sounds files (we pull them in via
+ # asterisk-{core,extra}-sounds and asterisk-moh-opsound.
+ >"${S}"/sounds/sounds.xml
+
+ # That NATIVE_ARCH chatter really is quite bothersome
+ sed -i 's/NATIVE_ARCH=/NATIVE_ARCH=0/' build_tools/menuselect-deps || die "Unable to squelch noisy build system"
+
+ # Compile menuselect binary for optional components
+ emake NOISE_BUILD=yes menuselect.makeopts
+
+ # Disable BUILD_NATIVE (bug #667498)
+ _menuselect --disable build_native menuselect.makeopts
+
+ # Broken functionality is forcibly disabled (bug #360143)
+ _menuselect --disable chan_misdn menuselect.makeopts
+ _menuselect --disable chan_ooh323 menuselect.makeopts
+
+ # Utility set is forcibly enabled (bug #358001)
+ _menuselect --enable smsq menuselect.makeopts
+ _menuselect --enable streamplayer menuselect.makeopts
+ _menuselect --enable aelparse menuselect.makeopts
+ _menuselect --enable astman menuselect.makeopts
+
+ # this is connected, otherwise it would not find
+ # ast_pktccops_gate_alloc symbol
+ _menuselect --enable chan_mgcp menuselect.makeopts
+ _menuselect --enable res_pktccops menuselect.makeopts
+
+ # SSL is forcibly enabled, IAX2 & DUNDI are expected to be available
+ _menuselect --enable pbx_dundi menuselect.makeopts
+ _menuselect --enable func_aes menuselect.makeopts
+ _menuselect --enable chan_iax2 menuselect.makeopts
+
+ # SQlite3 is now the main database backend, enable related features
+ _menuselect --enable cdr_sqlite3_custom menuselect.makeopts
+ _menuselect --enable cel_sqlite3_custom menuselect.makeopts
+
+ # The others are based on USE-flag settings
+ _use_select alsa chan_alsa
+ _use_select bluetooth chan_mobile
+ _use_select calendar res_calendar res_calendar_{caldav,ews,exchange,icalendar}
+ _use_select cluster res_corosync
+ _use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
+ _use_select freetds {cdr,cel}_tds
+ _use_select gtalk chan_motif
+ _use_select http res_http_post
+ _use_select iconv func_iconv
+ _use_select ilbc codec_ilbc format_ilbc
+ _use_select ldap res_config_ldap
+ _use_select lua pbx_lua
+ _use_select mysql app_mysql cdr_mysql res_config_mysql
+ _use_select odbc cdr_adaptive_odbc res_config_odbc {cdr,cel,res,func}_odbc
+ _use_select oss chan_oss
+ _use_select postgres {cdr,cel}_pgsql res_config_pgsql
+ _use_select radius {cdr,cel}_radius
+ _use_select snmp res_snmp
+ _use_select span res_fax_spandsp
+ _use_select speex {codec,func}_speex
+ _use_select speex format_ogg_speex
+ _use_select srtp res_srtp
+ _use_select statsd res_statsd res_{endpoint,chan}_stats
+ _use_select syslog cdr_syslog
+ _use_select vorbis format_ogg_vorbis
+ _use_select xmpp res_xmpp
+
+ # Voicemail storage ...
+ for vmst in ${IUSE_VOICEMAIL_STORAGE/+/}; do
+ if use ${vmst}; then
+ _menuselect --enable $(echo ${vmst##*_} | tr '[:lower:]' '[:upper:]')_STORAGE menuselect.makeopts
+ fi
+ done
+
+ if use debug; then
+ for o in DONT_OPTIMIZE DEBUG_THREADS BETTER_BACKTRACES; do
+ _menuselect --enable $o menuselect.makeopts
+ done
+ fi
+}
+
+src_compile() {
+ emake ASTCFLAGS="${CFLAGS}" ASTLDFLAGS="${LDFLAGS}" NOISY_BUILD=yes
+}
+
+src_install() {
+ local d
+
+ mkdir -p "${ED}/usr/$(get_libdir)/pkgconfig" || die
+ emake DESTDIR="${ED}" NOISY_BUILD=yes install
+
+ if use radius; then
+ insinto /etc/radiusclient/
+ doins contrib/dictionary.digium
+ fi
+ diropts -m 0750 -o root -g asterisk
+ keepdir /etc/asterisk
+ emake NOISY_BUILD=yes DESTDIR="${ED}" CONFIG_SRC=configs/samples CONFIG_EXTEN=.sample install-configs
+ for conffile in "${ED}/etc/asterisk/"*
+ do
+ fowners root:root "${conffile#${ED}}"
+ fperms 0644 "${conffile#${ED}}"
+ done
+
+ # keep directories
+ diropts -m 0750 -o asterisk -g root
+ keepdir /var/lib/asterisk
+ keepdir /var/spool/asterisk
+ keepdir /var/spool/asterisk/{system,tmp,meetme,monitor,dictate,voicemail,recording}
+ diropts -m 0750 -o asterisk -g asterisk
+ keepdir /var/log/asterisk/{cdr-csv,cdr-custom}
+
+ newinitd "${FILESDIR}"/initd-13.32.0-r1 asterisk
+ newconfd "${FILESDIR}"/confd-13.32.0 asterisk
+
+ systemd_dounit "${FILESDIR}"/asterisk.service
+ systemd_newtmpfilesd "${FILESDIR}"/asterisk.tmpfiles.conf asterisk.conf
+ systemd_install_serviced "${FILESDIR}"/asterisk.service.conf
+
+ # Reset diropts else dodoc uses it for doc installations.
+ diropts -m0755
+
+ # install the upgrade documentation
+ dodoc UPGRADE* BUGS CREDITS
+
+ # install extra documentation
+ if use doc; then
+ dodoc doc/*.txt
+ dodoc doc/*.pdf
+ fi
+
+ # install logrotate snippet; bug #329281
+ #
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/1.6.2/asterisk.logrotate4" asterisk
+
+ # Asterisk installs a few folders that's empty by design,
+ # but still required. This finds them, and marks them for
+ # portage.
+ for d in $(find "${ED}"/var -type d -empty || die "Find failed."); do
+ keepdir "${d#${ED}}"
+ done
+}
+
+pkg_postinst() {
+ if [ -z "${REPLACING_VERSIONS}" ]; then
+ elog "Asterisk Wiki: https://wiki.asterisk.org/wiki/"
+ elog "Gentoo VoIP IRC Channel: #gentoo-voip @ irc.freenode.net"
+ elif [ "$(ver_cut 1 "${REPLACING_VERSIONS}")" != "$(ver_cut 1)" ]; then
+ elog "You are updating from Asterisk $(ver_cut 1 "${REPLACING_VERSIONS}") upgrade document:"
+ elog "https://wiki.asterisk.org/wiki/display/AST/Upgrading+to+Asterisk+$(ver_cut 1)"
+ elog "Gentoo VoIP IRC Channel: #gentoo-voip @ irc.freenode.net"
+ fi
+}
diff --git a/net-misc/asterisk/asterisk-16.14.0-r100.ebuild b/net-misc/asterisk/asterisk-16.15.1-r1.ebuild
index 43d3c3dcdb5f..7259961c65f9 100644
--- a/net-misc/asterisk/asterisk-16.14.0-r100.ebuild
+++ b/net-misc/asterisk/asterisk-16.15.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-LUA_COMPAT=( lua5-{1..3} )
+LUA_COMPAT=( lua5-{1..4} )
inherit autotools linux-info lua-single systemd
@@ -30,7 +30,8 @@ REQUIRED_USE="gtalk? ( xmpp )
PATCHES=(
"${FILESDIR}/${PN}-historic-no-var-run-install.patch"
- "${FILESDIR}/${PN}-16.14.0-autoconf-lua-version.patch"
+ "${FILESDIR}/${PN}-13.38.1-r1-autoconf-lua-version.patch"
+ "${FILESDIR}/${PN}-13.38.1-r1-func_lock-fix-races.patch"
)
DEPEND="acct-user/asterisk
@@ -123,7 +124,7 @@ src_configure() {
local vmst
econf \
- LUA_IMPL="${ELUA}" \
+ LUA_VERSION="${ELUA#lua}" \
--libdir="/usr/$(get_libdir)" \
--localstatedir="/var" \
--with-crypto \
@@ -134,6 +135,7 @@ src_configure() {
--without-jansson-bundled \
--without-pjproject-bundled \
$(use_with caps cap) \
+ $(use_with lua lua) \
$(use_with http gmime) \
$(use_with newt) \
$(use_with pjproject) \
diff --git a/net-misc/asterisk/files/asterisk-13.38.1-r1-autoconf-lua-version.patch b/net-misc/asterisk/files/asterisk-13.38.1-r1-autoconf-lua-version.patch
new file mode 100644
index 000000000000..00a922ce0738
--- /dev/null
+++ b/net-misc/asterisk/files/asterisk-13.38.1-r1-autoconf-lua-version.patch
@@ -0,0 +1,56 @@
+From 61ef1a71e312f846b08ec4307c449f03907610a6 Mon Sep 17 00:00:00 2001
+From: Jaco Kroon <jaco@uls.co.za>
+Date: Wed, 23 Dec 2020 19:41:10 +0200
+Subject: [PATCH] pbx_lua: Add LUA_VERSION environment variable to
+ ./configure.
+
+On Gentoo it's possible to have multiple lua versions installed, all
+with a path of /usr, so it's not possible to use the current --with-lua
+option to determisticly pin to a specific version as is required by the
+Gentoo PMS standards.
+
+This environment variable allows to lock to specific versions,
+unversioned check will be skipped if this variable is supplied.
+
+Change-Id: I8c403eda05df25ee0193960262ce849c7d2fd088
+Signed-off-by: Jaco Kroon <jaco@uls.co.za>
+---
+ configure | 7 ++++++-
+ configure.ac | 7 +++++--
+ 2 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 64a0a5ace5..b380759b2b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -511,6 +511,7 @@ AST_EXT_LIB_SETUP([LIBXML2], [LibXML2], [libxml2])
+ AST_EXT_LIB_SETUP([LIBXSLT], [LibXSLT], [libxslt])
+ AST_EXT_LIB_SETUP_OPTIONAL([LIBXSLT_CLEANUP], [LibXSLT Library Cleanup Function], [LIBXSLT], [libxslt])
+ AST_EXT_LIB_SETUP([LUA], [Lua], [lua])
++AC_ARG_VAR([LUA_VERSION],[A space separated list of target lua versions to test.])
+ AST_EXT_LIB_SETUP([MISDN], [mISDN user], [misdn])
+ AST_EXT_LIB_SETUP([MYSQLCLIENT], [MySQL client], [mysqlclient])
+ AST_EXT_LIB_SETUP([NBS], [Network Broadcast Sound], [nbs])
+@@ -2559,7 +2560,7 @@ if test -z "$__opus_include" -o x"$__opus_include" = x" " ; then
+ fi
+ AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
+
+-for ver in 5.4 5.3 5.2 5.1; do
++for ver in ${LUA_VERSION:-5.4 5.3 5.2 5.1}; do
+ AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
+ if test "x${PBX_LUA}" = "x1" ; then
+ if test x"${LUA_DIR}" = x; then
+@@ -2572,7 +2573,9 @@ for ver in 5.4 5.3 5.2 5.1; do
+ done
+
+ # Some distributions (like openSUSE and NetBSD) remove the 5.x suffix.
+-AST_EXT_LIB_CHECK([LUA], [lua], [luaL_newstate], [lua.h], [-lm])
++if test "x${LUA_VERSION}" = "x"; then
++ AST_EXT_LIB_CHECK([LUA], [lua], [luaL_newstate], [lua.h], [-lm])
++fi
+
+ # Accept either RADIUS client library, their APIs are fully compatible,
+ # just different header filenames and different SONAMEs
+--
+2.26.2
+
diff --git a/net-misc/asterisk/files/asterisk-13.38.1-r1-func_lock-fix-races.patch b/net-misc/asterisk/files/asterisk-13.38.1-r1-func_lock-fix-races.patch
new file mode 100644
index 000000000000..b8b98e4929b2
--- /dev/null
+++ b/net-misc/asterisk/files/asterisk-13.38.1-r1-func_lock-fix-races.patch
@@ -0,0 +1,291 @@
+From 8ec686ebb4fa68512ca2dfe40b117523074aed0f Mon Sep 17 00:00:00 2001
+From: Jaco Kroon <jaco@uls.co.za>
+Date: Fri, 18 Dec 2020 21:06:20 +0200
+Subject: [PATCH] func_lock: fix multiple-channel-grant problems.
+
+Under contention it becomes possible that multiple channels will be told
+they successfully obtained the lock, which is a bug. Please refer
+
+ASTERISK-29217
+
+This introduces a couple of changes.
+
+1. Replaces requesters ao2 container with simple counter (we don't
+ really care who is waiting for the lock, only how many). This is
+ updated undex ->mutex to prevent memory access races.
+2. Correct semantics for ast_cond_timedwait() as described in
+ pthread_cond_broadcast(3P) is used (multiple threads can be released
+ on a single _signal()).
+3. Module unload races are taken care of and memory properly cleaned
+ up.
+
+Change-Id: I6f68b5ec82ff25b2909daf6e4d19ca864a463e29
+Signed-off-by: Jaco Kroon <jaco@uls.co.za>
+---
+ funcs/func_lock.c | 163 ++++++++++++++++------------------------------
+ 1 file changed, 56 insertions(+), 107 deletions(-)
+
+diff --git a/funcs/func_lock.c b/funcs/func_lock.c
+index acb5fc935c..072640751e 100644
+--- a/funcs/func_lock.c
++++ b/funcs/func_lock.c
+@@ -110,7 +110,6 @@ static AST_LIST_HEAD_STATIC(locklist, lock_frame);
+ static void lock_free(void *data);
+ static void lock_fixup(void *data, struct ast_channel *oldchan, struct ast_channel *newchan);
+ static int unloading = 0;
+-static pthread_t broker_tid = AST_PTHREADT_NULL;
+
+ static const struct ast_datastore_info lock_info = {
+ .type = "MUTEX",
+@@ -124,8 +123,8 @@ struct lock_frame {
+ ast_cond_t cond;
+ /*! count is needed so if a recursive mutex exits early, we know how many times to unlock it. */
+ unsigned int count;
+- /*! Container of requesters for the named lock */
+- struct ao2_container *requesters;
++ /*! Count of waiting of requesters for the named lock */
++ unsigned int requesters;
+ /*! who owns us */
+ struct ast_channel *owner;
+ /*! name of the lock */
+@@ -147,8 +146,11 @@ static void lock_free(void *data)
+ while ((clframe = AST_LIST_REMOVE_HEAD(oldlist, list))) {
+ /* Only unlock if we own the lock */
+ if (clframe->channel == clframe->lock_frame->owner) {
++ ast_mutex_lock(&clframe->lock_frame->mutex);
+ clframe->lock_frame->count = 0;
+ clframe->lock_frame->owner = NULL;
++ ast_cond_signal(&clframe->lock_frame->cond);
++ ast_mutex_unlock(&clframe->lock_frame->mutex);
+ }
+ ast_free(clframe);
+ }
+@@ -173,54 +175,11 @@ static void lock_fixup(void *data, struct ast_channel *oldchan, struct ast_chann
+ if (clframe->lock_frame->owner == oldchan) {
+ clframe->lock_frame->owner = newchan;
+ }
+- /* We don't move requesters, because the thread stack is different */
+ clframe->channel = newchan;
+ }
+ AST_LIST_UNLOCK(list);
+ }
+
+-static void *lock_broker(void *unused)
+-{
+- struct lock_frame *frame;
+- struct timespec forever = { 1000000, 0 };
+- for (;;) {
+- int found_requester = 0;
+-
+- /* Test for cancel outside of the lock */
+- pthread_testcancel();
+- AST_LIST_LOCK(&locklist);
+-
+- AST_LIST_TRAVERSE(&locklist, frame, entries) {
+- if (ao2_container_count(frame->requesters)) {
+- found_requester++;
+- ast_mutex_lock(&frame->mutex);
+- if (!frame->owner) {
+- ast_cond_signal(&frame->cond);
+- }
+- ast_mutex_unlock(&frame->mutex);
+- }
+- }
+-
+- AST_LIST_UNLOCK(&locklist);
+- pthread_testcancel();
+-
+- /* If there are no requesters, then wait for a signal */
+- if (!found_requester) {
+- nanosleep(&forever, NULL);
+- } else {
+- sched_yield();
+- }
+- }
+- /* Not reached */
+- return NULL;
+-}
+-
+-static int ast_channel_cmp_cb(void *obj, void *arg, int flags)
+-{
+- struct ast_channel *chan = obj, *cmp_args = arg;
+- return strcasecmp(ast_channel_name(chan), ast_channel_name(cmp_args)) ? 0 : CMP_MATCH;
+-}
+-
+ static int get_lock(struct ast_channel *chan, char *lockname, int trylock)
+ {
+ struct ast_datastore *lock_store = ast_channel_datastore_find(chan, &lock_info, NULL);
+@@ -290,17 +249,13 @@ static int get_lock(struct ast_channel *chan, char *lockname, int trylock)
+ AST_LIST_UNLOCK(&locklist);
+ return -1;
+ }
+- current->requesters = ao2_container_alloc_list(AO2_ALLOC_OPT_LOCK_MUTEX, 0,
+- NULL, ast_channel_cmp_cb);
+- if (!current->requesters) {
+- ast_mutex_destroy(&current->mutex);
+- ast_cond_destroy(&current->cond);
+- ast_free(current);
+- AST_LIST_UNLOCK(&locklist);
+- return -1;
+- }
++ current->requesters = 0;
+ AST_LIST_INSERT_TAIL(&locklist, current, entries);
+ }
++ /* Add to requester list */
++ ast_mutex_lock(&current->mutex);
++ current->requesters++;
++ ast_mutex_unlock(&current->mutex);
+ AST_LIST_UNLOCK(&locklist);
+
+ /* Found lock or created one - now find or create the corresponding link in the channel */
+@@ -337,44 +292,42 @@ static int get_lock(struct ast_channel *chan, char *lockname, int trylock)
+ * the same amount, before we'll release this one.
+ */
+ if (current->owner == chan) {
++ /* We're not a requester, we already have it */
++ ast_mutex_lock(&current->mutex);
++ current->requesters--;
++ ast_mutex_unlock(&current->mutex);
+ current->count++;
+ return 0;
+ }
+
+- /* Okay, we have both frames, so now we need to try to lock.
+- *
+- * Locking order: always lock locklist first. We need the
+- * locklist lock because the broker thread counts whether
+- * there are requesters with the locklist lock held, and we
+- * need to hold it, so that when we send our signal, below,
+- * to wake up the broker thread, it definitely will see that
+- * a requester exists at that point in time. Otherwise, we
+- * could add to the requesters after it has already seen that
+- * that lock is unoccupied and wait forever for another signal.
+- */
+- AST_LIST_LOCK(&locklist);
+- ast_mutex_lock(&current->mutex);
+- /* Add to requester list */
+- ao2_link(current->requesters, chan);
+- pthread_kill(broker_tid, SIGURG);
+- AST_LIST_UNLOCK(&locklist);
+-
+ /* Wait up to three seconds from now for LOCK. */
+ now = ast_tvnow();
+ timeout.tv_sec = now.tv_sec + 3;
+ timeout.tv_nsec = now.tv_usec * 1000;
+
+- if (!current->owner
+- || (!trylock
+- && !(res = ast_cond_timedwait(&current->cond, &current->mutex, &timeout)))) {
+- res = 0;
++ ast_mutex_lock(&current->mutex);
++
++ res = 0;
++ while (!trylock && !res && current->owner) {
++ res = ast_cond_timedwait(&current->cond, &current->mutex, &timeout);
++ }
++ if (current->owner) {
++ /* timeout;
++ * trylock; or
++ * cond_timedwait failed.
++ *
++ * either way, we fail to obtain the lock.
++ */
++ res = -1;
++ } else {
+ current->owner = chan;
+ current->count++;
+- } else {
+- res = -1;
++ res = 0;
+ }
+ /* Remove from requester list */
+- ao2_unlink(current->requesters, chan);
++ current->requesters--;
++ if (res && unloading)
++ ast_cond_signal(&current->cond);
+ ast_mutex_unlock(&current->mutex);
+
+ return res;
+@@ -422,7 +375,10 @@ static int unlock_read(struct ast_channel *chan, const char *cmd, char *data, ch
+ }
+
+ if (--clframe->lock_frame->count == 0) {
++ ast_mutex_lock(&clframe->lock_frame->mutex);
+ clframe->lock_frame->owner = NULL;
++ ast_cond_signal(&clframe->lock_frame->cond);
++ ast_mutex_unlock(&clframe->lock_frame->mutex);
+ }
+
+ ast_copy_string(buf, "1", len);
+@@ -478,34 +434,34 @@ static int unload_module(void)
+ /* Module flag */
+ unloading = 1;
+
++ /* Make it impossible for new requesters to be added
++ * NOTE: channels could already be in get_lock() */
++ ast_custom_function_unregister(&lock_function);
++ ast_custom_function_unregister(&trylock_function);
++
+ AST_LIST_LOCK(&locklist);
+- while ((current = AST_LIST_REMOVE_HEAD(&locklist, entries))) {
+- /* If any locks are currently in use, then we cannot unload this module */
+- if (current->owner || ao2_container_count(current->requesters)) {
+- /* Put it back */
+- AST_LIST_INSERT_HEAD(&locklist, current, entries);
+- AST_LIST_UNLOCK(&locklist);
+- unloading = 0;
+- return -1;
++ AST_LIST_TRAVERSE(&locklist, current, entries) {
++ ast_mutex_lock(&current->mutex);
++ while (current->owner || current->requesters) {
++ /* either the mutex is locked, or other parties are currently in get_lock,
++ * we need to wait for all of those to clear first */
++ ast_cond_wait(&current->cond, &current->mutex);
+ }
++ ast_mutex_unlock(&current->mutex);
++ /* At this point we know:
++ * 1. the lock has been released,
++ * 2. there are no requesters (nor should any be able to sneak in).
++ */
+ ast_mutex_destroy(&current->mutex);
+- ao2_ref(current->requesters, -1);
++ ast_cond_destroy(&current->cond);
+ ast_free(current);
+ }
++ AST_LIST_UNLOCK(&locklist);
++ AST_LIST_HEAD_DESTROY(&locklist);
+
+- /* No locks left, unregister functions */
+- ast_custom_function_unregister(&lock_function);
+- ast_custom_function_unregister(&trylock_function);
++ /* At this point we can safely stop access to UNLOCK */
+ ast_custom_function_unregister(&unlock_function);
+
+- if (broker_tid != AST_PTHREADT_NULL) {
+- pthread_cancel(broker_tid);
+- pthread_kill(broker_tid, SIGURG);
+- pthread_join(broker_tid, NULL);
+- }
+-
+- AST_LIST_UNLOCK(&locklist);
+-
+ return 0;
+ }
+
+@@ -515,13 +471,6 @@ static int load_module(void)
+ res |= ast_custom_function_register_escalating(&trylock_function, AST_CFE_READ);
+ res |= ast_custom_function_register_escalating(&unlock_function, AST_CFE_READ);
+
+- if (ast_pthread_create_background(&broker_tid, NULL, lock_broker, NULL)) {
+- ast_log(LOG_ERROR, "Failed to start lock broker thread. Unloading func_lock module.\n");
+- broker_tid = AST_PTHREADT_NULL;
+- unload_module();
+- return AST_MODULE_LOAD_DECLINE;
+- }
+-
+ return res;
+ }
+
+--
+2.26.2
+
diff --git a/net-misc/asterisk/files/asterisk-16.14.0-autoconf-lua-version.patch b/net-misc/asterisk/files/asterisk-16.14.0-autoconf-lua-version.patch
deleted file mode 100644
index 6e4c8237e667..000000000000
--- a/net-misc/asterisk/files/asterisk-16.14.0-autoconf-lua-version.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -2553,20 +2553,15 @@
- fi
- AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
-
--for ver in 5.3 5.2 5.1; do
-- AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
-- if test "x${PBX_LUA}" = "x1" ; then
-- if test x"${LUA_DIR}" = x; then
-- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${ver}"
-- else
-- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${ver}"
-- fi
-- break;
-+AST_EXT_LIB_CHECK([LUA], ${LUA_IMPL}, [luaL_newstate], ${LUA_IMPL}/lua.h, [-lm])
-+if test "x${PBX_LUA}" = "x1" ; then
-+ if test x"${LUA_DIR}" = x; then
-+ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/${LUA_IMPL}"
-+ else
-+ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/${LUA_IMPL}"
- fi
--done
--
--# Some distributions (like openSUSE and NetBSD) remove the 5.x suffix.
--AST_EXT_LIB_CHECK([LUA], [lua], [luaL_newstate], [lua.h], [-lm])
-+ break;
-+fi
-
- # Accept either RADIUS client library, their APIs are fully compatible,
- # just different header filenames and different SONAMEs