summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-02 09:49:27 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-02 10:43:18 +0200
commitaf73ad4881c33899d4a796aec673d4021e697e22 (patch)
treed8e194e3c608c7287ab9b4be01ba133c6eab420b /net-misc/autoupnp/autoupnp-9999.ebuild
parentmedia-sound/mumble: Bump to version 1.2.10 (bug #552092) (diff)
downloadgentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.gz
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.bz2
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.zip
net-misc/autoupnp: Version bump with miniupnpc compat fix
Package-Manager: portage-2.2.22
Diffstat (limited to 'net-misc/autoupnp/autoupnp-9999.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
index be3f1f8a8c9b..0dc42eeb1d46 100644
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -5,17 +5,16 @@
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-inherit git-r3
+inherit autotools git-r3
#endif
-inherit autotools-utils
+inherit eutils
DESCRIPTION="Automatic open port forwarder using UPnP"
HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/${P}.tar.bz2"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
@@ -29,12 +28,19 @@ DEPEND="${RDEPEND}"
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() { eautoreconf; }
#endif
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_with libnotify)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
}