summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-11-25 22:51:31 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2020-11-25 22:52:47 +0100
commit038140d81b3f6bef55872554e79a896d14d3b71d (patch)
tree7f6d175aaa17524f62dbfece31d7977babd2fa51 /net-misc/axel
parentnet-vpn/openvpn-1.5.0-r1: Restore + on openssl USE flag (diff)
downloadgentoo-038140d81b3f6bef55872554e79a896d14d3b71d.tar.gz
gentoo-038140d81b3f6bef55872554e79a896d14d3b71d.tar.bz2
gentoo-038140d81b3f6bef55872554e79a896d14d3b71d.zip
net-misc/axel: 2.17.10 bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/Manifest1
-rw-r--r--net-misc/axel/axel-2.17.10.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
index a6f00fc8a3f6..82743b9d4cec 100644
--- a/net-misc/axel/Manifest
+++ b/net-misc/axel/Manifest
@@ -1,2 +1,3 @@
+DIST axel-2.17.10.tar.xz 274648 BLAKE2B ee89614412dda04092bd89821ce78d1fff9224d0e026b136d50f2c52a42bbb6a3a110dcf8c0e8110dfdb6a67d0b6aecf0322101f75016b38888f35f44849340c SHA512 f102ae742940d123364de49f01fe97cc146afc32adfb3776437a53ffef14fcca0c5926c39d6ac338fe2bd368529d18b0c885b694de48f7cb0e6d0195d2339437
DIST axel-2.17.8.tar.xz 201224 BLAKE2B 0a10187013aa888ae8fa7f165b88955f5a7d63241157f552778c042eaecc7873e10e27537a8c7a26a09df5e655097845037f23a6c39f4d46328d633f944a316a SHA512 9158cc0f1c7b54d84e5c15331ddcf6056b5eb654c0ad068e058eedbea99bb87c1b2e759b57872a86d76d83d6807500989ad6bbf87f1c0210db2d4dab100933ea
DIST axel-2.17.9.tar.xz 204212 BLAKE2B 8ec63a5ccf73bf8e17c559b7fbce08ee926b0001b1d6f8ea09cbe1a7c600ceba69b6b6ecd19f989da333b57ed11e9a93913b2fa520d7e56b7d796cf18dcb9f1a SHA512 a0cabf43f451d61f4b1f4892a381fd5cf4088f7148502bf4e27d1c98177c3777bab9b732780cb9ba60c45aeead6cf9b79f870ac16db7148180f26350e69d8b01
diff --git a/net-misc/axel/axel-2.17.10.ebuild b/net-misc/axel/axel-2.17.10.ebuild
new file mode 100644
index 000000000000..dad9472d9679
--- /dev/null
+++ b/net-misc/axel/axel-2.17.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}