summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-25 16:39:49 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-25 17:11:29 +0100
commit3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f (patch)
treeb4569c9bbf89d75640e2a75127f3cde98ba59b19 /net-misc/balance/files
parentdev-util/fatrace: Version bump. (diff)
downloadgentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.tar.gz
gentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.tar.bz2
gentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.zip
net-misc/balance: Version bump, drop USE=doc (no need to install pdf version of manpage).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/balance/files')
-rw-r--r--net-misc/balance/files/balance-3.57-Makefile.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/balance/files/balance-3.57-Makefile.patch b/net-misc/balance/files/balance-3.57-Makefile.patch
new file mode 100644
index 000000000000..fad7f1f13151
--- /dev/null
+++ b/net-misc/balance/files/balance-3.57-Makefile.patch
@@ -0,0 +1,52 @@
+--- balance-3.57/Makefile
++++ balance-3.57/Makefile
+@@ -1,14 +1,14 @@
+ # $Id: Makefile,v 1.14 2015/04/28 07:49:37 t Exp t $
+
+ #CFLAGS=-g -I.
+-CFLAGS=-O2 -Wall -Wstrict-prototypes -Wuninitialized
++CFLAGS+=-Wall -Wstrict-prototypes -Wuninitialized
+
+ # uncomment for any OS other than Cygwin
+ BALANCE=balance
+ ROOT=root
+ INSTALL=install
+ BINDIR=/usr/sbin
+-MANDIR=${BINDIR}/../man/man1
++MANDIR=/usr/share/man/man1
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+@@ -20,13 +20,13 @@
+ # BALANCE=balance.exe
+ # ROOT=Administrators
+
+-CC=gcc
++CC?=gcc
+ RELEASE=3.57
+
+ all: balance
+
+ balance: balance.o butils.o
+- $(CC) $(CFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
+
+ balance.o: balance.c balance.h
+ $(CC) $(CFLAGS) -I. -c balance.c
+@@ -48,12 +48,15 @@
+ rm -f $(BALANCE) *.o balance.ps balance.pdf
+
+ install:
++ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 -d \
++ $(DESTDIR)$(BINDIR) \
++ $(DESTDIR)$(MANDIR)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 $(BALANCE) \
+ $(DESTDIR)$(BINDIR)/$(BALANCE)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 balance.1 \
+ $(DESTDIR)$(MANDIR)
+ mkdir -p $(DESTDIR)/var/run/balance
+- chmod 1777 $(DESTDIR)/var/run/balance
++ chmod 1755 $(DESTDIR)/var/run/balance
+
+ release: balance.pdf
+ rm -rf ./releases/balance-$(RELEASE)