summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-11 11:52:39 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-11 11:52:39 +0100
commit3d51450eefade6863f443b07a2f16adcd7316fa5 (patch)
tree724697a0cf8c8ddde95c4d22fcac3d9407fcc494 /net-misc/batctl/batctl-2017.4.ebuild
parentnet-misc/batctl: Switch to https:// (https://github.com/gentoo/gentoo/pull/5505) (diff)
downloadgentoo-3d51450eefade6863f443b07a2f16adcd7316fa5.tar.gz
gentoo-3d51450eefade6863f443b07a2f16adcd7316fa5.tar.bz2
gentoo-3d51450eefade6863f443b07a2f16adcd7316fa5.zip
net-misc/batctl: Version bump.
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'net-misc/batctl/batctl-2017.4.ebuild')
-rw-r--r--net-misc/batctl/batctl-2017.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/batctl/batctl-2017.4.ebuild b/net-misc/batctl/batctl-2017.4.ebuild
new file mode 100644
index 000000000000..1a86c94be2ba
--- /dev/null
+++ b/net-misc/batctl/batctl-2017.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="https://www.open-mesh.org/"
+SRC_URI="https://downloads.open-mesh.org/batman/releases/batman-adv-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libnl:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.rst
+}