summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/batman-adv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/batman-adv')
-rw-r--r--net-misc/batman-adv/Manifest2
-rw-r--r--net-misc/batman-adv/batman-adv-2013.4.0.ebuild38
-rw-r--r--net-misc/batman-adv/batman-adv-2014.2.0.ebuild39
-rw-r--r--net-misc/batman-adv/metadata.xml15
4 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/batman-adv/Manifest b/net-misc/batman-adv/Manifest
new file mode 100644
index 000000000000..c2e9dfbaedfe
--- /dev/null
+++ b/net-misc/batman-adv/Manifest
@@ -0,0 +1,2 @@
+DIST batman-adv-2013.4.0.tar.gz 138232 SHA256 a9b1b7542c94cc6bf7c97b7b0d02bf071b5632a64480ae419358b9cb9cab6870 SHA512 e4f29b9bf9b13a6afe25ed138e4c811b8a3b09917c435ccd5a7720b60922f215e5bb04322d9299cf6464f4f0ade892f913e3510dc19907efa475abab4a84dfa3 WHIRLPOOL 56cd2eeccd4317459162afb3995f992e90795099c2e0dde29b7f5a7ba8b2e2aa0b09d16927c1ebe580113388ced7654fef23f0af4b63466ef793202526a5eab9
+DIST batman-adv-2014.2.0.tar.gz 170320 SHA256 34764607e1ce4256105d2c49e3445fedd2bd5d56480e011a7b66449a0baeab52 SHA512 35650aa3eb8b4ddd70284d42a41ac81ea5b9184ee22cb0cbf322312b45cb0761e5344c4c20543480b58d37c9616299355694560bd38677144a9f258b5b027daa WHIRLPOOL 4b8bc3c397414245f7b88906e65c833abf4e70e4f587a2ff98524cd3648f627190f977d635d44eac10016ca18d00ead3a0f6c668f32d7d984d36a99e89b812ae
diff --git a/net-misc/batman-adv/batman-adv-2013.4.0.ebuild b/net-misc/batman-adv/batman-adv-2013.4.0.ebuild
new file mode 100644
index 000000000000..a8fe845b0189
--- /dev/null
+++ b/net-misc/batman-adv/batman-adv-2013.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CONFIG_CHECK="~!CONFIG_BATMAN_ADV"
+MODULE_NAMES="${PN}(net:${S}:${S})"
+BUILD_TARGETS="all"
+
+inherit eutils linux-mod
+
+DESCRIPTION="Better approach to mobile Ad-Hoc networking on layer 2 kernel module"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bla dat debug nc"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ BUILD_PARAMS="CONFIG_BATMAN_ADV_DEBUG=$(usex debug y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_BLA=$(usex bla y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_DAT=$(usex dat y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_NC=$(usex nc y n)"
+ export BUILD_PARAMS
+ export KERNELPATH="${KERNEL_DIR}"
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README CHANGELOG
+}
diff --git a/net-misc/batman-adv/batman-adv-2014.2.0.ebuild b/net-misc/batman-adv/batman-adv-2014.2.0.ebuild
new file mode 100644
index 000000000000..31ab40ce6a3d
--- /dev/null
+++ b/net-misc/batman-adv/batman-adv-2014.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CONFIG_CHECK="~!BATMAN_ADV ~LIBCRC32C ~CRC16"
+MODULE_NAMES="${PN}(net:${S}:${S})"
+BUILD_TARGETS="all"
+
+inherit eutils linux-mod
+
+DESCRIPTION="Better approach to mobile Ad-Hoc networking on layer 2 kernel module"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bla dat debug nc mcast"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ BUILD_PARAMS="CONFIG_BATMAN_ADV_DEBUG=$(usex debug y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_BLA=$(usex bla y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_DAT=$(usex dat y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_NC=$(usex nc y n)"
+ BUILD_PARAMS+=" CONFIG_BATMAN_ADV_NC=$(usex mcast y n)"
+ export BUILD_PARAMS
+ export KERNELPATH="${KERNEL_DIR}"
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README CHANGELOG
+}
diff --git a/net-misc/batman-adv/metadata.xml b/net-misc/batman-adv/metadata.xml
new file mode 100644
index 000000000000..91ea9dfad76e
--- /dev/null
+++ b/net-misc/batman-adv/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<use>
+ <flag name="bla">B.A.T.M.A.N. bridge loop avoidance</flag>
+ <flag name="dat">B.A.T.M.A.N. distributed arp table</flag>
+ <flag name="nc">B.A.T.M.A.N. network coding</flag>
+ <flag name="mcast">B.A.T.M.A.N. multicast optimizations</flag>
+</use>
+</pkgmetadata>
+