summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/blinkperl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/blinkperl/files')
-rw-r--r--net-misc/blinkperl/files/blinkperl-20030301-Makefile.patch20
-rw-r--r--net-misc/blinkperl/files/blinkperl-20030301-non-local.patch13
-rw-r--r--net-misc/blinkperl/files/blinkperl.confd3
-rw-r--r--net-misc/blinkperl/files/blinkperl.rc19
4 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/blinkperl/files/blinkperl-20030301-Makefile.patch b/net-misc/blinkperl/files/blinkperl-20030301-Makefile.patch
new file mode 100644
index 000000000000..1f8d3bee0df6
--- /dev/null
+++ b/net-misc/blinkperl/files/blinkperl-20030301-Makefile.patch
@@ -0,0 +1,20 @@
+Do not install into /usr/man and be consistent about the package name.
+
+--- blinkperl/Makefile.orig 2003-02-08 15:58:10.000000000 +0100
++++ blinkperl/Makefile 2008-11-27 21:14:03.000000000 +0100
+@@ -1,12 +1,12 @@
+ SHELL=/bin/sh
+-PREFIX=/usr/local
+-MANDIR=${PREFIX}/man
++PREFIX=/usr
+ BINDIR=${PREFIX}/bin
+ SHAREDIR=${PREFIX}/share
++MANDIR=${SHAREDIR}/man
+ #
+ # Be sure to modify $moviedir in blinkserver.pl if you modify it here!
+ #
+-BLINKENPERLSHAREDIR=${SHAREDIR}/blinkenperl
++BLINKENPERLSHAREDIR=${SHAREDIR}/blinkperl
+ MOVIEDIR=${BLINKENPERLSHAREDIR}/movies
+
+ # Enable "make install DESTDIR=some-path" to make it easier
diff --git a/net-misc/blinkperl/files/blinkperl-20030301-non-local.patch b/net-misc/blinkperl/files/blinkperl-20030301-non-local.patch
new file mode 100644
index 000000000000..3394918ebb47
--- /dev/null
+++ b/net-misc/blinkperl/files/blinkperl-20030301-non-local.patch
@@ -0,0 +1,13 @@
+Do not install in locale/share and be consistent about the package name.
+
+--- blinkperl/blinkserver.pl.orig 2003-02-06 19:38:00.000000000 +0100
++++ blinkperl/blinkserver.pl 2008-11-27 21:14:24.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ # be sure to modify ${MOVIEDIR} in the Makefile
+ # (if you want to use "make install"), if you modify it here!
+-my $moviedir = "/usr/local/share/blinkenperl/movies" ; # where to find the movies
++my $moviedir = "/usr/share/blinkperl/movies" ; # where to find the movies
+ my $blmext = "blm" ; # extensions of blm files in the movie directory
+
+
diff --git a/net-misc/blinkperl/files/blinkperl.confd b/net-misc/blinkperl/files/blinkperl.confd
new file mode 100644
index 000000000000..3eab7db5a977
--- /dev/null
+++ b/net-misc/blinkperl/files/blinkperl.confd
@@ -0,0 +1,3 @@
+# config what port to listen for telnet connections on
+BLINKPORT="10001"
+
diff --git a/net-misc/blinkperl/files/blinkperl.rc b/net-misc/blinkperl/files/blinkperl.rc
new file mode 100644
index 000000000000..b5b07bda1c1e
--- /dev/null
+++ b/net-misc/blinkperl/files/blinkperl.rc
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting blinkserver"
+ start-stop-daemon -o --background --quiet --start --exec /usr/bin/blinkserver.pl --pidfile /var/run/blinkserver.pid -- --port=${BLINKPORT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping blinkserver"
+ start-stop-daemon -o --quiet --stop --name blinkserver.pl
+ eend $?
+}