summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/bridge-utils/bridge-utils-1.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/bridge-utils/bridge-utils-1.5.ebuild')
-rw-r--r--net-misc/bridge-utils/bridge-utils-1.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/bridge-utils/bridge-utils-1.5.ebuild b/net-misc/bridge-utils/bridge-utils-1.5.ebuild
new file mode 100644
index 000000000000..dda72365896b
--- /dev/null
+++ b/net-misc/bridge-utils/bridge-utils-1.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils linux-info toolchain-funcs
+
+DESCRIPTION="Tools for configuring the Linux kernel 802.1d Ethernet Bridge"
+HOMEPAGE="http://bridge.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bridge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="selinux"
+
+DEPEND="virtual/os-headers"
+RDEPEND="selinux? ( sec-policy/selinux-brctl )"
+
+CONFIG_CHECK="~BRIDGE"
+WARNING_BRIDGE="CONFIG_BRIDGE is required to get bridge devices in the kernel"
+
+get_headers() {
+ CTARGET=${CTARGET:-${CHOST}}
+ dir=/usr/include
+ tc-is-cross-compiler && dir=/usr/${CTARGET}/usr/include
+ echo "${dir}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-3.8.patch
+ eautoreconf
+}
+
+src_configure() {
+ # use santitized headers and not headers from /usr/src
+ econf \
+ --prefix=/ \
+ --libdir=/usr/$(get_libdir) \
+ --includedir=/usr/include \
+ --with-linux-headers="$(get_headers)"
+}
+
+src_install () {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog README THANKS TODO \
+ doc/{FAQ,FIREWALL,HOWTO,PROJECTS,RPM-GPG-KEY,SMPNOTES,WISHLIST}
+ [ -f "${D}"/sbin/brctl ] || die "upstream makefile failed to install binary"
+}