summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild')
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild142
1 files changed, 142 insertions, 0 deletions
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
new file mode 100644
index 000000000000..319c72afd147
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE="unicode"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="net-dialup/capi4k-utils
+ media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # apply bugfix patch (see bug #145982)
+ epatch "${FILESDIR}/${P}-recvdev.diff"
+
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in config.faxCAPI; do
+ einfo "Converting ${i} to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo "To use capi4hylafax:"
+ einfo "Make sure that your isdn/capi devices are owned by"
+ einfo "the \"uucp\" user (see udev or devfsd config)."
+ einfo "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ einfo "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ einfo
+ einfo "If you're upgrading from a previous version"
+ einfo "please check for new or changed options."
+ einfo "A sample default config is installed as:"
+ einfo "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ einfo
+ einfo "You should also check special options in:"
+ einfo "/etc/conf.d/${PN}"
+ einfo
+ einfo "If you want to use capi4hylafax together with"
+ einfo "hylafax, then please emerge net-misc/hylafax"
+ einfo
+ einfo "Then append the following line to your hylafax"
+ einfo "config file (${FAX_SPOOL_DIR}/etc/config):"
+ einfo "SendFaxCmd: /usr/bin/c2faxsend"
+}