summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 18:10:41 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:08:37 -0500
commitbde2de06291222b7787b54cb2be936a67bfa063a (patch)
tree756c29024cdb1f31afbc12a9fc8b3b8817e4a7d3 /net-misc/capi4hylafax
parentnet-misc/blinkperl: remove old/broken ebuild (diff)
downloadgentoo-bde2de06291222b7787b54cb2be936a67bfa063a.tar.gz
gentoo-bde2de06291222b7787b54cb2be936a67bfa063a.tar.bz2
gentoo-bde2de06291222b7787b54cb2be936a67bfa063a.zip
net-misc/capi4hylafax: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/capi4hylafax')
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20-r1.ebuild155
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r2.ebuild142
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9-r1.ebuild133
-rw-r--r--net-misc/capi4hylafax/files/capi4hylafax.initd4
4 files changed, 432 insertions, 2 deletions
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20-r1.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20-r1.ebuild
new file mode 100644
index 000000000000..d4f049fe6cfe
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20-r1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="${ROOT}/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.debian.tar.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ app-shells/bash:0
+ media-libs/tiff:0
+ virtual/jpeg:0
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+DOCS=( AUTHORS ChangeLog Readme_src )
+HTML_DOCS=( README.html LIESMICH.html )
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" epatch
+
+ eapply_user
+
+ eautoreconf
+
+ mv ../debian . || die
+
+ # fix location of fax spool
+ sed -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" \
+ -i config.faxCAPI \
+ -i Readme_src \
+ -i src/defaults.h.in \
+ -i debian/*.1 || die
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile || die
+
+ # fix name and location of logfile
+ sed -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" \
+ -i config.faxCAPI || die
+
+ sed -e "s:/tmp/capifax.log:/var/log/${PN}.log:" \
+ -i src/defaults.h.in config.faxCAPI || die
+
+ # patch man pages
+ sed -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" \
+ -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" \
+ -i debian/*.1 || die
+
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8 || die
+}
+
+src_configure() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ default
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ newdoc debian/changelog ChangeLog.debian
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ elog "To use capi4hylafax:"
+ elog "Make sure that your isdn/capi devices are owned by"
+ elog "the \"uucp\" user (see udev or devfsd config)."
+ elog "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ elog "to suit your system."
+
+ if [ -n "${REPLACING_VERSIONS}" ]; then
+ elog
+ elog "If you're upgrading from a previous version"
+ elog "please check for new or changed options."
+ elog "A sample default config is installed as:"
+ elog "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ elog
+ elog "Please run package config to install a default configuration."
+ fi
+
+ elog
+ elog "You should also check special options in:"
+ elog "/etc/conf.d/${PN}"
+ elog
+ elog "The following optional dependency is also available:"
+ optfeature "hylafax integration" net-misc/hylafax
+ elog
+ elog "Then append the following line to your hylafax"
+ elog "config file (${FAX_SPOOL_DIR}/etc/config):"
+ elog "SendFaxCmd: /usr/bin/c2faxsend"
+ einfo
+}
+
+pkg_config() {
+ local config_file="${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ if [ -e "${config_file}" ]; then
+ eerror "The configuration file already exists. Please either update"
+ eerror "or remove this file and re-run package configuration."
+ eerror "Configuration file location: ${config_file}"
+ else
+ elog "Installing template configuration file to ${config_file}"
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${config_file}" || die
+ fi
+}
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r2.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r2.ebuild
new file mode 100644
index 000000000000..f60dcb35266a
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r2.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE="unicode"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="net-dialup/capi4k-utils
+ media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # apply bugfix patch (see bug #145982)
+ epatch "${FILESDIR}/${P}-recvdev.diff"
+
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in config.faxCAPI; do
+ einfo "Converting ${i} to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo "To use capi4hylafax:"
+ einfo "Make sure that your isdn/capi devices are owned by"
+ einfo "the \"uucp\" user (see udev or devfsd config)."
+ einfo "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ einfo "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ einfo
+ einfo "If you're upgrading from a previous version"
+ einfo "please check for new or changed options."
+ einfo "A sample default config is installed as:"
+ einfo "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ einfo
+ einfo "You should also check special options in:"
+ einfo "/etc/conf.d/${PN}"
+ einfo
+ einfo "If you want to use capi4hylafax together with"
+ einfo "hylafax, then please emerge net-misc/hylafax"
+ einfo
+ einfo "Then append the following line to your hylafax"
+ einfo "config file (${FAX_SPOOL_DIR}/etc/config):"
+ einfo "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9-r1.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9-r1.ebuild
new file mode 100644
index 000000000000..10c3a2f71234
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ app-shells/bash
+ media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # update autotools
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ elog "To use capi4hylafax:"
+ elog "Make sure that your isdn/capi devices are owned by"
+ elog "the \"uucp\" user (see udev or devfsd config)."
+ elog "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ elog "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ elog
+ elog "If you're upgrading from a previous version"
+ elog "please check for new or changed options."
+ elog "A sample default config is installed as:"
+ elog "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ elog
+ elog "You should also check special options in:"
+ elog "/etc/conf.d/${PN}"
+ elog
+ elog "If you want to use capi4hylafax together with"
+ elog "hylafax, then please emerge net-misc/hylafax"
+ elog
+ elog "Then append the following line to your hylafax"
+ elog "config file (${FAX_SPOOL_DIR}/etc/config):"
+ elog "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/files/capi4hylafax.initd b/net-misc/capi4hylafax/files/capi4hylafax.initd
index bfba068a0285..e7ad4e858a01 100644
--- a/net-misc/capi4hylafax/files/capi4hylafax.initd
+++ b/net-misc/capi4hylafax/files/capi4hylafax.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$