summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:32:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:32:54 +0100
commitcb4b67edc310230fde780458896b3b5089a58eec (patch)
tree3eb8cb8aa07e2552078cc5238d5f3b8c50d4098b /net-misc/cgminer
parentnet-misc/cgminer: Apply gcc-10 workaround (diff)
downloadgentoo-cb4b67edc310230fde780458896b3b5089a58eec.tar.gz
gentoo-cb4b67edc310230fde780458896b3b5089a58eec.tar.bz2
gentoo-cb4b67edc310230fde780458896b3b5089a58eec.zip
net-misc/cgminer: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/Manifest1
-rw-r--r--net-misc/cgminer/cgminer-4.9.2.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/net-misc/cgminer/Manifest b/net-misc/cgminer/Manifest
index 6a4fa3234060..0722bb99c587 100644
--- a/net-misc/cgminer/Manifest
+++ b/net-misc/cgminer/Manifest
@@ -1,2 +1 @@
DIST cgminer-4.10.0.tar.bz2 1306225 BLAKE2B 29d34e5d9246fc5b0409a1647e4ddf291f1e7610888110c1917ddbc1c30a9d0301bb70dba187690f2685b2fd476d5c0b0cd65e87fafa56b62a7f3a0202a374de SHA512 ed39bffa51715756875c101f4aaf984cab566fc1c8b657f6da37d0cdf921faee752c3efadf97c98ca6e749175457fbc2c37e9332cd26d2ff1675752250ac21db
-DIST cgminer-4.9.2.tar.bz2 1476371 BLAKE2B 01ff700cb5dc2fb12709da41aeaa22c6fc6b9dc6fb1e12116eef3a382ad328961b8d6ddd6ac6fce47ab8084c96e1a7be74a697b3d885c7e78dfadf07b678ad24 SHA512 48371657c84f09ad8c500a29ca85f35af70eb8720d9d97b565cd8c5356289d889ee60c06f37c0507a53c8f50ae827a77fa0c41609bac6b1e8849ad26b55d67d4
diff --git a/net-misc/cgminer/cgminer-4.9.2.ebuild b/net-misc/cgminer/cgminer-4.9.2.ebuild
deleted file mode 100644
index 6cf544e6b085..000000000000
--- a/net-misc/cgminer/cgminer-4.9.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
-HOMEPAGE="https://bitcointalk.org/?topic=28402.msg357369 https://github.com/ckolivas/cgminer"
-SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
-#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-HARDWARE="ants1 ants2 ants3 avalon avalon2 avalon4 bab bflsc bitforce bitfury bitmine_A1 blockerupter cointerra drillbit hashfast hashratio icarus klondike knc minion modminer sp10 sp30"
-IUSE="doc examples udev hardened ncurses ${HARDWARE}"
-
-REQUIRED_USE="|| ( ${HARDWARE} )"
-
-RDEPEND="net-misc/curl
- >=dev-libs/jansson-2.6
- virtual/libusb:1[udev]
- ncurses? ( sys-libs/ncurses:0= )
- udev? ( virtual/libudev )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
-
-src_configure() {
- use hardened && append-cflags "-no-pie"
-
- # PKG_CHECK_MODULES needs PKG_CONFIG for --with-system-jansson.
- export PKG_CONFIG=/usr/bin/pkg-config
- econf $(use_with ncurses curses) \
- $(use_enable ants1) \
- $(use_enable ants2) \
- $(use_enable ants3) \
- $(use_enable avalon) \
- $(use_enable avalon2) \
- $(use_enable avalon4) \
- $(use_enable bab) \
- $(use_enable bitmine_A1) \
- $(use_enable bflsc) \
- $(use_enable bitforce) \
- $(use_enable bitfury) \
- $(use_enable blockerupter) \
- $(use_enable cointerra) \
- $(use_enable drillbit) \
- $(use_enable hashfast) \
- $(use_enable hashratio) \
- $(use_enable icarus) \
- $(use_enable klondike) \
- $(use_enable knc) \
- $(use_enable minion) \
- $(use_enable modminer) \
- $(use_enable sp10) \
- $(use_enable sp30) \
- $(use_enable udev) \
- --disable-forcecombo \
- --with-system-libusb \
- --with-system-jansson
- # sanitize directories (is this still needed?)
- sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
-}
-
-src_install() { # How about using some make install?
- dobin cgminer
-
- if use udev; then
- insinto /lib/udev/rules.d
- use udev && doins 01-cgminer.rules
- fi
-
- if use doc; then
- dodoc AUTHORS NEWS README API-README
- use icarus || use bitforce || use modminer && dodoc FPGA-README
- use avalon || use bflsc && dodoc ASIC-README
- fi
-
- if use examples; then
- docinto examples
- dodoc api-example.php miner.php API.java api-example.c example.conf
- fi
-}